All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mats Karrman <mats.dev.list@gmail.com>
To: Li Jun <jun.li@nxp.com>,
	robh+dt@kernel.org, gregkh@linuxfoundation.org,
	heikki.krogerus@linux.intel.com, linux@roeck-us.net
Cc: a.hajda@samsung.com, cw00.choi@samsung.com,
	shufan_lee@richtek.com, peter.chen@nxp.com, gsomlo@gmail.com,
	devicetree@vger.kernel.org, linux-usb@vger.kernel.org,
	linux-imx@nxp.com
Subject: Re: [PATCH v5 05/14] usb: typec: add API to get typec basic port power and data config
Date: Fri, 11 May 2018 21:55:31 +0200	[thread overview]
Message-ID: <c28a8352-e960-449b-e7c1-7965d340536e@gmail.com> (raw)
In-Reply-To: <1525307094-27402-6-git-send-email-jun.li@nxp.com>

Hi Li Jun,

On 2018-05-03 02:24, Li Jun wrote:

> This patch adds 3 APIs to get the typec port power and data type,
> and preferred power role by its name string.
>
> Signed-off-by: Li Jun <jun.li@nxp.com>
> ---
>   drivers/usb/typec/class.c | 52 +++++++++++++++++++++++++++++++++++++++++++++++
>   include/linux/usb/typec.h |  3 +++
>   2 files changed, 55 insertions(+)
>
> diff --git a/drivers/usb/typec/class.c b/drivers/usb/typec/class.c
> index 53df10d..5981e18 100644
> --- a/drivers/usb/typec/class.c
> +++ b/drivers/usb/typec/class.c
> @@ -9,6 +9,7 @@
>   #include <linux/device.h>
>   #include <linux/module.h>
>   #include <linux/mutex.h>
> +#include <linux/property.h>
>   #include <linux/slab.h>
>   #include <linux/usb/typec.h>
>   #include <linux/usb/typec_mux.h>
> @@ -802,6 +803,12 @@ static const char * const typec_port_types[] = {
>   	[TYPEC_PORT_DRP] = "dual",
>   };
>   
> +static const char * const typec_data_types[] = {
> +	[TYPEC_PORT_DFP] = "host",
> +	[TYPEC_PORT_UFP] = "device",
> +	[TYPEC_PORT_DRD] = "dual",
> +};
> +
>   static const char * const typec_port_types_drp[] = {
>   	[TYPEC_PORT_SRC] = "dual [source] sink",
>   	[TYPEC_PORT_SNK] = "dual source [sink]",
> @@ -1252,6 +1259,51 @@ void typec_set_pwr_opmode(struct typec_port *port,
>   }
>   EXPORT_SYMBOL_GPL(typec_set_pwr_opmode);
>   
> +/**
> + * typec_find_power_type - Get the typec port power type

Why is this function called typec_find_power_type() and not typec_find_port_type()?
It's called port_type in sysfs, having different names just adds confusion.
(Otherwise I agree power_type is a better name but...)

> + * @name: port type string
> + *
> + * This routine is used to find the typec_port_type by its string name.
> + *
> + * Returns typec_port_type if success, otherwise negative error code.
> + */
> +int typec_find_power_type(const char *name)
> +{
> +	return match_string(typec_port_types, ARRAY_SIZE(typec_port_types),
> +			    name);
> +}
> +EXPORT_SYMBOL_GPL(typec_find_power_type);
> +
> +/**
> + * typec_find_preferred_role - Find the typec drp port preferred power role

Why typec_find_preferred_role()? Could be used for any power_role so
why not typec_find_power_role()?

BR // Mats

> + * @name: power role string
> + *
> + * This routine is used to find the typec_role by its string name of
> + * preferred power role(Try.SRC or Try.SNK).
> + *
> + * Returns typec_role if success, otherwise negative error code.
> + */
> +int typec_find_preferred_role(const char *name)
> +{
> +	return match_string(typec_roles, ARRAY_SIZE(typec_roles), name);
> +}
> +EXPORT_SYMBOL_GPL(typec_find_preferred_role);
> +
> +/**
> + * typec_find_data_type - Get the typec port data capability
> + * @name: data type string
> + *
> + * This routine is used to find the typec_port_data by its string name.
> + *
> + * Returns typec_port_data if success, otherwise negative error code.
> + */
> +int typec_find_data_type(const char *name)
> +{
> +	return match_string(typec_data_types, ARRAY_SIZE(typec_data_types),
> +			    name);
> +}
> +EXPORT_SYMBOL_GPL(typec_find_data_type);
> +
>   /* ------------------------------------------ */
>   /* API for Multiplexer/DeMultiplexer Switches */
>   
> diff --git a/include/linux/usb/typec.h b/include/linux/usb/typec.h
> index 672b39b..00c93e7 100644
> --- a/include/linux/usb/typec.h
> +++ b/include/linux/usb/typec.h
> @@ -267,4 +267,7 @@ int typec_set_orientation(struct typec_port *port,
>   			  enum typec_orientation orientation);
>   int typec_set_mode(struct typec_port *port, int mode);
>   
> +int typec_find_power_type(const char *name);
> +int typec_find_preferred_role(const char *name);
> +int typec_find_data_type(const char *name);
>   #endif /* __LINUX_USB_TYPEC_H */
>

WARNING: multiple messages have this Message-ID (diff)
From: Mats Karrman <mats.dev.list@gmail.com>
To: Li Jun <jun.li@nxp.com>,
	robh+dt@kernel.org, gregkh@linuxfoundation.org,
	heikki.krogerus@linux.intel.com, linux@roeck-us.net
Cc: a.hajda@samsung.com, cw00.choi@samsung.com,
	shufan_lee@richtek.com, peter.chen@nxp.com, gsomlo@gmail.com,
	devicetree@vger.kernel.org, linux-usb@vger.kernel.org,
	linux-imx@nxp.com
Subject: [v5,05/14] usb: typec: add API to get typec basic port power and data config
Date: Fri, 11 May 2018 21:55:31 +0200	[thread overview]
Message-ID: <c28a8352-e960-449b-e7c1-7965d340536e@gmail.com> (raw)

Hi Li Jun,

On 2018-05-03 02:24, Li Jun wrote:

> This patch adds 3 APIs to get the typec port power and data type,
> and preferred power role by its name string.
>
> Signed-off-by: Li Jun <jun.li@nxp.com>
> ---
>   drivers/usb/typec/class.c | 52 +++++++++++++++++++++++++++++++++++++++++++++++
>   include/linux/usb/typec.h |  3 +++
>   2 files changed, 55 insertions(+)
>
> diff --git a/drivers/usb/typec/class.c b/drivers/usb/typec/class.c
> index 53df10d..5981e18 100644
> --- a/drivers/usb/typec/class.c
> +++ b/drivers/usb/typec/class.c
> @@ -9,6 +9,7 @@
>   #include <linux/device.h>
>   #include <linux/module.h>
>   #include <linux/mutex.h>
> +#include <linux/property.h>
>   #include <linux/slab.h>
>   #include <linux/usb/typec.h>
>   #include <linux/usb/typec_mux.h>
> @@ -802,6 +803,12 @@ static const char * const typec_port_types[] = {
>   	[TYPEC_PORT_DRP] = "dual",
>   };
>   
> +static const char * const typec_data_types[] = {
> +	[TYPEC_PORT_DFP] = "host",
> +	[TYPEC_PORT_UFP] = "device",
> +	[TYPEC_PORT_DRD] = "dual",
> +};
> +
>   static const char * const typec_port_types_drp[] = {
>   	[TYPEC_PORT_SRC] = "dual [source] sink",
>   	[TYPEC_PORT_SNK] = "dual source [sink]",
> @@ -1252,6 +1259,51 @@ void typec_set_pwr_opmode(struct typec_port *port,
>   }
>   EXPORT_SYMBOL_GPL(typec_set_pwr_opmode);
>   
> +/**
> + * typec_find_power_type - Get the typec port power type

Why is this function called typec_find_power_type() and not typec_find_port_type()?
It's called port_type in sysfs, having different names just adds confusion.
(Otherwise I agree power_type is a better name but...)

> + * @name: port type string
> + *
> + * This routine is used to find the typec_port_type by its string name.
> + *
> + * Returns typec_port_type if success, otherwise negative error code.
> + */
> +int typec_find_power_type(const char *name)
> +{
> +	return match_string(typec_port_types, ARRAY_SIZE(typec_port_types),
> +			    name);
> +}
> +EXPORT_SYMBOL_GPL(typec_find_power_type);
> +
> +/**
> + * typec_find_preferred_role - Find the typec drp port preferred power role

Why typec_find_preferred_role()? Could be used for any power_role so
why not typec_find_power_role()?

BR // Mats

> + * @name: power role string
> + *
> + * This routine is used to find the typec_role by its string name of
> + * preferred power role(Try.SRC or Try.SNK).
> + *
> + * Returns typec_role if success, otherwise negative error code.
> + */
> +int typec_find_preferred_role(const char *name)
> +{
> +	return match_string(typec_roles, ARRAY_SIZE(typec_roles), name);
> +}
> +EXPORT_SYMBOL_GPL(typec_find_preferred_role);
> +
> +/**
> + * typec_find_data_type - Get the typec port data capability
> + * @name: data type string
> + *
> + * This routine is used to find the typec_port_data by its string name.
> + *
> + * Returns typec_port_data if success, otherwise negative error code.
> + */
> +int typec_find_data_type(const char *name)
> +{
> +	return match_string(typec_data_types, ARRAY_SIZE(typec_data_types),
> +			    name);
> +}
> +EXPORT_SYMBOL_GPL(typec_find_data_type);
> +
>   /* ------------------------------------------ */
>   /* API for Multiplexer/DeMultiplexer Switches */
>   
> diff --git a/include/linux/usb/typec.h b/include/linux/usb/typec.h
> index 672b39b..00c93e7 100644
> --- a/include/linux/usb/typec.h
> +++ b/include/linux/usb/typec.h
> @@ -267,4 +267,7 @@ int typec_set_orientation(struct typec_port *port,
>   			  enum typec_orientation orientation);
>   int typec_set_mode(struct typec_port *port, int mode);
>   
> +int typec_find_power_type(const char *name);
> +int typec_find_preferred_role(const char *name);
> +int typec_find_data_type(const char *name);
>   #endif /* __LINUX_USB_TYPEC_H */
>
---
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

  reply	other threads:[~2018-05-11 19:55 UTC|newest]

Thread overview: 99+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-03  0:24 [PATCH v5 00/14] staging: typec: tcpci: move out of staging Li Jun
2018-05-03  0:24 ` [PATCH v5 01/14] dt-bindings: connector: add properties for typec Li Jun
2018-05-03  0:24   ` [v5,01/14] " Jun Li
2018-05-03  7:27   ` [PATCH v5 01/14] " Oliver Neukum
2018-05-03  7:27     ` [v5,01/14] " Oliver Neukum
2018-05-03  8:35     ` [PATCH v5 01/14] " Jun Li
2018-05-03  8:35       ` [v5,01/14] " Jun Li
2018-05-03  9:17       ` [PATCH v5 01/14] " Oliver Neukum
2018-05-03  9:17         ` [v5,01/14] " Oliver Neukum
2018-05-04  8:59         ` [PATCH v5 01/14] " Jun Li
2018-05-04  8:59           ` [v5,01/14] " Jun Li
2018-05-08 10:03           ` [PATCH v5 01/14] " Oliver Neukum
2018-05-08 10:03             ` [v5,01/14] " Oliver Neukum
2018-05-10  0:43             ` [PATCH v5 01/14] " Jun Li
2018-05-10  0:43               ` [v5,01/14] " Jun Li
2018-05-07 15:58   ` [PATCH v5 01/14] " Rob Herring
2018-05-07 15:58     ` [v5,01/14] " Rob Herring
2018-05-08  5:36     ` [PATCH v5 01/14] " Jun Li
2018-05-08  5:36       ` [v5,01/14] " Jun Li
2018-05-11 19:49   ` [PATCH v5 01/14] " Mats Karrman
2018-05-11 19:49     ` [v5,01/14] " Mats Karrman
2018-05-14  9:06     ` [PATCH v5 01/14] " Jun Li
2018-05-14  9:06       ` [v5,01/14] " Jun Li
2018-05-16  7:21   ` [PATCH v5 01/14] " Peter Chen
2018-05-16  7:21     ` [v5,01/14] " Peter Chen
2018-05-17 13:16     ` [PATCH v5 01/14] " Jun Li
2018-05-17 13:16       ` [v5,01/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 02/14] dt-bindings: usb: add documentation for typec port controller(TCPCI) Li Jun
2018-05-03  0:24   ` [v5,02/14] " Jun Li
2018-05-07 16:01   ` [PATCH v5 02/14] " Rob Herring
2018-05-07 16:01     ` [v5,02/14] " Rob Herring
2018-05-03  0:24 ` [PATCH v5 03/14] staging: typec: tcpci: add compatible string for nxp ptn5110 Li Jun
2018-05-03  0:24   ` [v5,03/14] " Jun Li
2018-05-11 19:51   ` [PATCH v5 03/14] " Mats Karrman
2018-05-11 19:51     ` [v5,03/14] " Mats Karrman
2018-05-14  9:15     ` [PATCH v5 03/14] " Jun Li
2018-05-14  9:15       ` [v5,03/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 04/14] usb: typec: add fwnode to tcpc Li Jun
2018-05-03  0:24   ` [v5,04/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 05/14] usb: typec: add API to get typec basic port power and data config Li Jun
2018-05-03  0:24   ` [v5,05/14] " Jun Li
2018-05-11 19:55   ` Mats Karrman [this message]
2018-05-11 19:55     ` Mats Karrman
2018-05-14  9:36     ` [PATCH v5 05/14] " Jun Li
2018-05-14  9:36       ` [v5,05/14] " Jun Li
2018-05-15 20:52       ` [PATCH v5 05/14] " Mats Karrman
2018-05-15 20:52         ` [v5,05/14] " Mats Karrman
2018-05-16 12:25         ` [PATCH v5 05/14] " Heikki Krogerus
2018-05-16 12:25           ` [v5,05/14] " Heikki Krogerus
2018-05-16 20:55           ` [PATCH v5 05/14] " Mats Karrman
2018-05-16 20:55             ` [v5,05/14] " Mats Karrman
2018-05-17 12:35             ` [PATCH v5 05/14] " Heikki Krogerus
2018-05-17 12:35               ` [v5,05/14] " Heikki Krogerus
2018-05-17 14:05               ` [PATCH v5 05/14] " Jun Li
2018-05-17 14:05                 ` [v5,05/14] " Jun Li
2018-05-17 14:24                 ` [PATCH v5 05/14] " Heikki Krogerus
2018-05-17 14:24                   ` [v5,05/14] " Heikki Krogerus
2018-05-17 14:41                   ` [PATCH v5 05/14] " Jun Li
2018-05-17 14:41                     ` [v5,05/14] " Jun Li
2018-05-21 13:12                     ` [PATCH v5 05/14] " Heikki Krogerus
2018-05-21 13:12                       ` [v5,05/14] " Heikki Krogerus
2018-05-22 14:19                       ` [PATCH v5 05/14] " Jun Li
2018-05-22 14:19                         ` [v5,05/14] " Jun Li
2018-05-17 13:53             ` [PATCH v5 05/14] " Jun Li
2018-05-17 13:53               ` [v5,05/14] " Jun Li
2018-05-17 13:26           ` [PATCH v5 05/14] " Jun Li
2018-05-17 13:26             ` [v5,05/14] " Jun Li
2018-05-17 13:16         ` [PATCH v5 05/14] " Jun Li
2018-05-17 13:16           ` [v5,05/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 06/14] usb: typec: tcpm: support get typec and pd config from device properties Li Jun
2018-05-03  0:24   ` [v5,06/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 07/14] staging: typec: tcpci: remove unused tcpci_tcpc_config Li Jun
2018-05-03  0:24   ` [v5,07/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 08/14] staging: typec: tcpci: register port before request irq Li Jun
2018-05-03  0:24   ` [v5,08/14] " Jun Li
2018-05-03  8:29   ` [PATCH v5 08/14] " Sergei Shtylyov
2018-05-03  8:29     ` [v5,08/14] " Sergei Shtylyov
2018-05-03  8:34     ` [PATCH v5 08/14] " Sergei Shtylyov
2018-05-03  8:34       ` [v5,08/14] " Sergei Shtylyov
2018-05-03  0:24 ` [PATCH v5 09/14] staging: typec: tcpci: enable vbus detection Li Jun
2018-05-03  0:24   ` [v5,09/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 10/14] typec: tcpm: add starting value for drp toggling Li Jun
2018-05-03  0:24   ` [v5,10/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 11/14] usb: typec: tcpm: set cc for drp toggling attach Li Jun
2018-05-03  0:24   ` [v5,11/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 12/14] staging: typec: tcpci: keep the not connecting cc line open Li Jun
2018-05-03  0:24   ` [v5,12/14] " Jun Li
2018-05-16  8:35   ` [PATCH v5 12/14] " Peter Chen
2018-05-16  8:35     ` [v5,12/14] " Peter Chen
2018-05-17 13:17     ` [PATCH v5 12/14] " Jun Li
2018-05-17 13:17       ` [v5,12/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 13/14] staging: typec: tcpci: Only touch target bit when enable vconn Li Jun
2018-05-03  0:24   ` [v5,13/14] " Jun Li
2018-05-03  0:24 ` [PATCH v5 14/14] staging: typec: tcpci: move tcpci driver out of staging Li Jun
2018-05-03  0:24   ` [v5,14/14] " Jun Li
2018-05-11 21:37   ` [PATCH v5 14/14] " Mats Karrman
2018-05-11 21:37     ` [v5,14/14] " Mats Karrman
2018-05-14  9:38     ` [PATCH v5 14/14] " Jun Li
2018-05-14  9:38       ` [v5,14/14] " Jun Li

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c28a8352-e960-449b-e7c1-7965d340536e@gmail.com \
    --to=mats.dev.list@gmail.com \
    --cc=a.hajda@samsung.com \
    --cc=cw00.choi@samsung.com \
    --cc=devicetree@vger.kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=gsomlo@gmail.com \
    --cc=heikki.krogerus@linux.intel.com \
    --cc=jun.li@nxp.com \
    --cc=linux-imx@nxp.com \
    --cc=linux-usb@vger.kernel.org \
    --cc=linux@roeck-us.net \
    --cc=peter.chen@nxp.com \
    --cc=robh+dt@kernel.org \
    --cc=shufan_lee@richtek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.