All of lore.kernel.org
 help / color / mirror / Atom feed
From: Felix Kuehling <felix.kuehling@amd.com>
To: Christophe JAILLET <christophe.jaillet@wanadoo.fr>,
	alexander.deucher@amd.com, christian.koenig@amd.com,
	Xinhui.Pan@amd.com, airlied@linux.ie, daniel@ffwll.ch
Cc: amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
	linux-kernel@vger.kernel.org, kernel-janitors@vger.kernel.org
Subject: Re: [PATCH 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable
Date: Tue, 26 Apr 2022 16:54:29 -0400	[thread overview]
Message-ID: <d43d9456-d2e4-2486-9970-8c358a599b6d@amd.com> (raw)
In-Reply-To: <80a426b3-ece2-129c-edca-03556e1ecbb6@wanadoo.fr>


Am 2022-04-26 um 14:47 schrieb Christophe JAILLET:
> Le 26/04/2022 à 20:01, Felix Kuehling a écrit :
>> Hi Christophe,
>>
>> I just stumbled over this patch series while cleaning up my inbox. 
>> Sorry for dropping it back in November. I'm about to apply it but I 
>> noticed that patch 1 is missing a Signed-off-by. Is it OK to add that 
>> in your name?
>
> Hi,
>
> No problem for me if you can add it. Thanks.
> But if you prefer a v2, it is also fine for me.

No need. I submitted the patches to amd-staging-drm-next.

Regards,
   Felix


>
> BTW sorry for missing the SoB tag. This definitively means that I 
> forgot the checkpatch.pl step for this patch, which is bad.
>
> CJ
>
>>
>> Thanks,
>>    Felix
>>
>>
>> Am 2021-11-28 um 11:45 schrieb Christophe JAILLET:
>>> 'kfd->gtt_sa_bitmap' is a bitmap. So use 'bitmap_zalloc()' to simplify
>>> code, improve the semantic and avoid some open-coded arithmetic in
>>> allocator arguments.
>>>
>>> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
>>> consistency.
>>> ---
>>>   drivers/gpu/drm/amd/amdkfd/kfd_device.c | 12 +++---------
>>>   1 file changed, 3 insertions(+), 9 deletions(-)
>>>
>>> diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_device.c 
>>> b/drivers/gpu/drm/amd/amdkfd/kfd_device.c
>>> index e1294fba0c26..c5a0ce44a295 100644
>>> --- a/drivers/gpu/drm/amd/amdkfd/kfd_device.c
>>> +++ b/drivers/gpu/drm/amd/amdkfd/kfd_device.c
>>> @@ -1252,8 +1252,6 @@ int 
>>> kgd2kfd_schedule_evict_and_restore_process(struct mm_struct *mm,
>>>   static int kfd_gtt_sa_init(struct kfd_dev *kfd, unsigned int 
>>> buf_size,
>>>                   unsigned int chunk_size)
>>>   {
>>> -    unsigned int num_of_longs;
>>> -
>>>       if (WARN_ON(buf_size < chunk_size))
>>>           return -EINVAL;
>>>       if (WARN_ON(buf_size == 0))
>>> @@ -1264,11 +1262,8 @@ static int kfd_gtt_sa_init(struct kfd_dev 
>>> *kfd, unsigned int buf_size,
>>>       kfd->gtt_sa_chunk_size = chunk_size;
>>>       kfd->gtt_sa_num_of_chunks = buf_size / chunk_size;
>>> -    num_of_longs = (kfd->gtt_sa_num_of_chunks + BITS_PER_LONG - 1) /
>>> -        BITS_PER_LONG;
>>> -
>>> -    kfd->gtt_sa_bitmap = kcalloc(num_of_longs, sizeof(long), 
>>> GFP_KERNEL);
>>> -
>>> +    kfd->gtt_sa_bitmap = bitmap_zalloc(kfd->gtt_sa_num_of_chunks,
>>> +                       GFP_KERNEL);
>>>       if (!kfd->gtt_sa_bitmap)
>>>           return -ENOMEM;
>>> @@ -1278,13 +1273,12 @@ static int kfd_gtt_sa_init(struct kfd_dev 
>>> *kfd, unsigned int buf_size,
>>>       mutex_init(&kfd->gtt_sa_lock);
>>>       return 0;
>>> -
>>>   }
>>>   static void kfd_gtt_sa_fini(struct kfd_dev *kfd)
>>>   {
>>>       mutex_destroy(&kfd->gtt_sa_lock);
>>> -    kfree(kfd->gtt_sa_bitmap);
>>> +    bitmap_free(kfd->gtt_sa_bitmap);
>>>   }
>>>   static inline uint64_t kfd_gtt_sa_calc_gpu_addr(uint64_t start_addr,
>>
>

WARNING: multiple messages have this Message-ID (diff)
From: Felix Kuehling <felix.kuehling@amd.com>
To: Christophe JAILLET <christophe.jaillet@wanadoo.fr>,
	alexander.deucher@amd.com, christian.koenig@amd.com,
	Xinhui.Pan@amd.com, airlied@linux.ie, daniel@ffwll.ch
Cc: kernel-janitors@vger.kernel.org, dri-devel@lists.freedesktop.org,
	amd-gfx@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable
Date: Tue, 26 Apr 2022 16:54:29 -0400	[thread overview]
Message-ID: <d43d9456-d2e4-2486-9970-8c358a599b6d@amd.com> (raw)
In-Reply-To: <80a426b3-ece2-129c-edca-03556e1ecbb6@wanadoo.fr>


Am 2022-04-26 um 14:47 schrieb Christophe JAILLET:
> Le 26/04/2022 à 20:01, Felix Kuehling a écrit :
>> Hi Christophe,
>>
>> I just stumbled over this patch series while cleaning up my inbox. 
>> Sorry for dropping it back in November. I'm about to apply it but I 
>> noticed that patch 1 is missing a Signed-off-by. Is it OK to add that 
>> in your name?
>
> Hi,
>
> No problem for me if you can add it. Thanks.
> But if you prefer a v2, it is also fine for me.

No need. I submitted the patches to amd-staging-drm-next.

Regards,
   Felix


>
> BTW sorry for missing the SoB tag. This definitively means that I 
> forgot the checkpatch.pl step for this patch, which is bad.
>
> CJ
>
>>
>> Thanks,
>>    Felix
>>
>>
>> Am 2021-11-28 um 11:45 schrieb Christophe JAILLET:
>>> 'kfd->gtt_sa_bitmap' is a bitmap. So use 'bitmap_zalloc()' to simplify
>>> code, improve the semantic and avoid some open-coded arithmetic in
>>> allocator arguments.
>>>
>>> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
>>> consistency.
>>> ---
>>>   drivers/gpu/drm/amd/amdkfd/kfd_device.c | 12 +++---------
>>>   1 file changed, 3 insertions(+), 9 deletions(-)
>>>
>>> diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_device.c 
>>> b/drivers/gpu/drm/amd/amdkfd/kfd_device.c
>>> index e1294fba0c26..c5a0ce44a295 100644
>>> --- a/drivers/gpu/drm/amd/amdkfd/kfd_device.c
>>> +++ b/drivers/gpu/drm/amd/amdkfd/kfd_device.c
>>> @@ -1252,8 +1252,6 @@ int 
>>> kgd2kfd_schedule_evict_and_restore_process(struct mm_struct *mm,
>>>   static int kfd_gtt_sa_init(struct kfd_dev *kfd, unsigned int 
>>> buf_size,
>>>                   unsigned int chunk_size)
>>>   {
>>> -    unsigned int num_of_longs;
>>> -
>>>       if (WARN_ON(buf_size < chunk_size))
>>>           return -EINVAL;
>>>       if (WARN_ON(buf_size == 0))
>>> @@ -1264,11 +1262,8 @@ static int kfd_gtt_sa_init(struct kfd_dev 
>>> *kfd, unsigned int buf_size,
>>>       kfd->gtt_sa_chunk_size = chunk_size;
>>>       kfd->gtt_sa_num_of_chunks = buf_size / chunk_size;
>>> -    num_of_longs = (kfd->gtt_sa_num_of_chunks + BITS_PER_LONG - 1) /
>>> -        BITS_PER_LONG;
>>> -
>>> -    kfd->gtt_sa_bitmap = kcalloc(num_of_longs, sizeof(long), 
>>> GFP_KERNEL);
>>> -
>>> +    kfd->gtt_sa_bitmap = bitmap_zalloc(kfd->gtt_sa_num_of_chunks,
>>> +                       GFP_KERNEL);
>>>       if (!kfd->gtt_sa_bitmap)
>>>           return -ENOMEM;
>>> @@ -1278,13 +1273,12 @@ static int kfd_gtt_sa_init(struct kfd_dev 
>>> *kfd, unsigned int buf_size,
>>>       mutex_init(&kfd->gtt_sa_lock);
>>>       return 0;
>>> -
>>>   }
>>>   static void kfd_gtt_sa_fini(struct kfd_dev *kfd)
>>>   {
>>>       mutex_destroy(&kfd->gtt_sa_lock);
>>> -    kfree(kfd->gtt_sa_bitmap);
>>> +    bitmap_free(kfd->gtt_sa_bitmap);
>>>   }
>>>   static inline uint64_t kfd_gtt_sa_calc_gpu_addr(uint64_t start_addr,
>>
>

  reply	other threads:[~2022-04-26 20:54 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-28 16:45 [PATCH 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable Christophe JAILLET
2021-11-28 16:45 ` Christophe JAILLET
2021-11-28 16:46 ` [PATCH 2/2] drm/amdkfd: Use non-atomic bitmap functions when possible Christophe JAILLET
2021-11-28 16:46   ` Christophe JAILLET
2022-04-26 18:01 ` [PATCH 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable Felix Kuehling
2022-04-26 18:01   ` Felix Kuehling
2022-04-26 18:47   ` Christophe JAILLET
2022-04-26 18:47     ` Christophe JAILLET
2022-04-26 18:47     ` Christophe JAILLET
2022-04-26 20:54     ` Felix Kuehling [this message]
2022-04-26 20:54       ` Felix Kuehling
  -- strict thread matches above, loose matches on Subject: below --
2021-11-21 17:41 Christophe JAILLET
2021-11-21 17:41 ` Christophe JAILLET
2021-11-22 22:10 ` kernel test robot
2021-11-22 22:10   ` kernel test robot
2021-11-22 22:10   ` kernel test robot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d43d9456-d2e4-2486-9970-8c358a599b6d@amd.com \
    --to=felix.kuehling@amd.com \
    --cc=Xinhui.Pan@amd.com \
    --cc=airlied@linux.ie \
    --cc=alexander.deucher@amd.com \
    --cc=amd-gfx@lists.freedesktop.org \
    --cc=christian.koenig@amd.com \
    --cc=christophe.jaillet@wanadoo.fr \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.