Backports Archive on lore.kernel.org
 help / Atom feed
* Backports not building configured drivers
@ 2018-08-27 22:01 Marlon Smith
  2018-08-28  4:42 ` Luca Coelho
  0 siblings, 1 reply; 6+ messages in thread
From: Marlon Smith @ 2018-08-27 22:01 UTC (permalink / raw)
  To: backports

Hi everyone,

I'm using backports 4.14 to build for a custom kernel 3.14.  That
kernel includes the RT2800 wifi driver, and if I configure backports
with menuconfig to build a newer version of that driver it works
perfectly.  However, if I configure backports to build the RTL8821
driver, which my kernel otherwise does not include, the driver never
gets built and backports shows it as not selected the next time I run
menuconfig.

Is this expected behaviour?  Is there something I can do to force this
driver to build?

Thanks!

Marlon
--
To unsubscribe from this list: send the line "unsubscribe backports" in

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Backports not building configured drivers
  2018-08-27 22:01 Backports not building configured drivers Marlon Smith
@ 2018-08-28  4:42 ` Luca Coelho
  2018-08-29 20:55   ` Marlon Smith
  0 siblings, 1 reply; 6+ messages in thread
From: Luca Coelho @ 2018-08-28  4:42 UTC (permalink / raw)
  To: Marlon Smith, backports

On Mon, 2018-08-27 at 15:01 -0700, Marlon Smith wrote:
> Hi everyone,

Hi Marlon,


> I'm using backports 4.14 to build for a custom kernel 3.14.  That
> kernel includes the RT2800 wifi driver, and if I configure backports
> with menuconfig to build a newer version of that driver it works
> perfectly.  However, if I configure backports to build the RTL8821
> driver, which my kernel otherwise does not include, the driver never
> gets built and backports shows it as not selected the next time I run
> menuconfig.
> 
> Is this expected behaviour?  Is there something I can do to force
> this
> driver to build?

This probably means that your 3.14 kernel doesn't have some of the
dependencies needed by the RTL8821 driver from 4.14.  Check the list of
dependencies for the driver and make sure they are included in your
3.14 kernel.

--
Luca.

--
To unsubscribe from this list: send the line "unsubscribe backports" in

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Backports not building configured drivers
  2018-08-28  4:42 ` Luca Coelho
@ 2018-08-29 20:55   ` Marlon Smith
  2018-08-29 21:14     ` Larry Finger
  2018-08-30  7:33     ` Johannes Berg
  0 siblings, 2 replies; 6+ messages in thread
From: Marlon Smith @ 2018-08-29 20:55 UTC (permalink / raw)
  To: Luca Coelho, backports

On Tue, 2018-08-28 at 07:42 +0300, Luca Coelho wrote:
> On Mon, 2018-08-27 at 15:01 -0700, Marlon Smith wrote:
> > 
> > Hi everyone,
> Hi Marlon,
> > > > 
> > I'm using backports 4.14 to build for a custom kernel 3.14.  That
> > kernel includes the RT2800 wifi driver, and if I configure
> > backports
> > with menuconfig to build a newer version of that driver it works
> > perfectly.  However, if I configure backports to build the RTL8821
> > driver, which my kernel otherwise does not include, the driver
> > never
> > gets built and backports shows it as not selected the next time I
> > run
> > menuconfig.
> > 
> > Is this expected behaviour?  Is there something I can do to force
> > this
> > driver to build?
> This probably means that your 3.14 kernel doesn't have some of the
> dependencies needed by the RTL8821 driver from 4.14.  Check the list
> of
> dependencies for the driver and make sure they are included in your
> 3.14 kernel.
> > --
> Luca.

Hey Luca, thanks for the reply!  The requirements in the backports 4.14
menuconfig are listed as follows:

Depends on: WLAN [=y] && WLAN_VENDOR_REALTEK [=y] && RTL_CARDS [=m] &&
m && BP_MODULES [=y] && PCI [=y]

I can find the symbol WLAN_VENDOR_REALTEK in the backports 4.14
menuconfig but not in the 3.14 kernel's menuconfig.  Does this mean I
can't use the driver with this kernel?
--
To unsubscribe from this list: send the line "unsubscribe backports" in

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Backports not building configured drivers
  2018-08-29 20:55   ` Marlon Smith
@ 2018-08-29 21:14     ` Larry Finger
  2018-08-30  7:33     ` Johannes Berg
  1 sibling, 0 replies; 6+ messages in thread
From: Larry Finger @ 2018-08-29 21:14 UTC (permalink / raw)
  To: Marlon Smith, Luca Coelho, backports

On 08/29/2018 03:55 PM, Marlon Smith wrote:
> On Tue, 2018-08-28 at 07:42 +0300, Luca Coelho wrote:
>> On Mon, 2018-08-27 at 15:01 -0700, Marlon Smith wrote:
>>>   
>>> Hi everyone,
>> Hi Marlon,
>>>>>   
>>> I'm using backports 4.14 to build for a custom kernel 3.14.  That
>>> kernel includes the RT2800 wifi driver, and if I configure
>>> backports
>>> with menuconfig to build a newer version of that driver it works
>>> perfectly.  However, if I configure backports to build the RTL8821
>>> driver, which my kernel otherwise does not include, the driver
>>> never
>>> gets built and backports shows it as not selected the next time I
>>> run
>>> menuconfig.
>>>   
>>> Is this expected behaviour?  Is there something I can do to force
>>> this
>>> driver to build?
>> This probably means that your 3.14 kernel doesn't have some of the
>> dependencies needed by the RTL8821 driver from 4.14.  Check the list
>> of
>> dependencies for the driver and make sure they are included in your
>> 3.14 kernel.
>>> --
>> Luca.
> 
> Hey Luca, thanks for the reply!  The requirements in the backports 4.14
> menuconfig are listed as follows:
> 
> Depends on: WLAN [=y] && WLAN_VENDOR_REALTEK [=y] && RTL_CARDS [=m] &&
> m && BP_MODULES [=y] && PCI [=y]
> 
> I can find the symbol WLAN_VENDOR_REALTEK in the backports 4.14
> menuconfig but not in the 3.14 kernel's menuconfig.  Does this mean I
> can't use the driver with this kernel?
> --

Marlon,

That symbol postdates kernel 3.14. I have no idea if the backports code will 
run, or even build, in kernels that old, but I think it would be safe for you to 
edit the symbol WLAN_VENDOR_REALTEK out of that "depends on" line in the 
configuration menu. At least, that will get you to the next problem. :)

Larry

--
To unsubscribe from this list: send the line "unsubscribe backports" in

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Backports not building configured drivers
  2018-08-29 20:55   ` Marlon Smith
  2018-08-29 21:14     ` Larry Finger
@ 2018-08-30  7:33     ` Johannes Berg
  2018-08-30 16:07       ` Marlon Smith
  1 sibling, 1 reply; 6+ messages in thread
From: Johannes Berg @ 2018-08-30  7:33 UTC (permalink / raw)
  To: Marlon Smith, Luca Coelho, backports

On Wed, 2018-08-29 at 13:55 -0700, Marlon Smith wrote:

> Hey Luca, thanks for the reply!  The requirements in the backports 4.14
> menuconfig are listed as follows:
> 
> Depends on: WLAN [=y] && WLAN_VENDOR_REALTEK [=y] && RTL_CARDS [=m] &&
> m && BP_MODULES [=y] && PCI [=y]
> 
> I can find the symbol WLAN_VENDOR_REALTEK in the backports 4.14
> menuconfig but not in the 3.14 kernel's menuconfig.  Does this mean I
> can't use the driver with this kernel?

No, actually the symbol is enabled? See the [=y] above.

The above looks like it is actually enabled though, so something else
must be going on?

johannes
--
To unsubscribe from this list: send the line "unsubscribe backports" in

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Backports not building configured drivers
  2018-08-30  7:33     ` Johannes Berg
@ 2018-08-30 16:07       ` Marlon Smith
  0 siblings, 0 replies; 6+ messages in thread
From: Marlon Smith @ 2018-08-30 16:07 UTC (permalink / raw)
  To: Johannes Berg, Luca Coelho, backports

Thanks everyone for the replies.  The setting I was missing in the
kernel was that I need to have PCI enabled.  I'm not sure why the
backports menuconfig said PCI [=y], since it was not enabled in the
kernel, but once I enabled it backports built the wifi driver
correctly.

Thanks again for the help!

Marlon

On Thu, 2018-08-30 at 09:33 +0200, Johannes Berg wrote:
> On Wed, 2018-08-29 at 13:55 -0700, Marlon Smith wrote:
> 
> > 
> > Hey Luca, thanks for the reply!  The requirements in the backports
> > 4.14
> > menuconfig are listed as follows:
> > 
> > Depends on: WLAN [=y] && WLAN_VENDOR_REALTEK [=y] && RTL_CARDS [=m]
> > &&
> > m && BP_MODULES [=y] && PCI [=y]
> > 
> > I can find the symbol WLAN_VENDOR_REALTEK in the backports 4.14
> > menuconfig but not in the 3.14 kernel's menuconfig.  Does this mean
> > I
> > can't use the driver with this kernel?
> No, actually the symbol is enabled? See the [=y] above.
> 
> The above looks like it is actually enabled though, so something else
> must be going on?
> 
> johannes
--
To unsubscribe from this list: send the line "unsubscribe backports" in

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, back to index

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-08-27 22:01 Backports not building configured drivers Marlon Smith
2018-08-28  4:42 ` Luca Coelho
2018-08-29 20:55   ` Marlon Smith
2018-08-29 21:14     ` Larry Finger
2018-08-30  7:33     ` Johannes Berg
2018-08-30 16:07       ` Marlon Smith

Backports Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/backports/0 backports/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 backports backports/ https://lore.kernel.org/backports \
		backports@vger.kernel.org backports@archiver.kernel.org
	public-inbox-index backports


Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.backports


AGPL code for this site: git clone https://public-inbox.org/ public-inbox