FSTests Archive on lore.kernel.org
 help / color / Atom feed
* generic/095 and generic/300 failures
@ 2021-04-20  5:54 Christoph Hellwig
  2021-04-25  5:05 ` Eryu Guan
  0 siblings, 1 reply; 3+ messages in thread
From: Christoph Hellwig @ 2021-04-20  5:54 UTC (permalink / raw)
  To: fstests

Hi all,

generic/095 and generic/300 have been failing for me with every config
on every file system for a while with the following messages:

--- tests/generic/095.out	2016-03-29 13:59:30.405053956 +0000
+++ results/generic/095.out.bad	2021-04-20 05:44:54.432081845 +0000
@@ -1,2 +1,7 @@
 QA output created by 095
+job9: No I/O performed by mmap, perhaps try --debug=io option for details?
+job9: No I/O performed by mmap, perhaps try --debug=io option for details?
+job9: No I/O performed by mmap, perhaps try --debug=io option for details?
+job9: No I/O performed by mmap, perhaps try --debug=io option for details?
+job9: No I/O performed by mmap, perhaps try --debug=io option for details?
 Silence is golden           

--- tests/generic/300.out	2016-03-29 13:59:30.431720622 +0000
+++ results/generic/300.out.bad	2021-04-20 05:45:06.324708699 +0000
@@ -2,3 +2,4 @@
 
 Run fio with random aio-dio pattern
   
+falloc_raicer: No I/O performed by falloc, perhaps try --debug=io option for details?


----- End forwarded message -----

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: generic/095 and generic/300 failures
  2021-04-20  5:54 generic/095 and generic/300 failures Christoph Hellwig
@ 2021-04-25  5:05 ` Eryu Guan
  2021-04-25  6:48   ` Zorro Lang
  0 siblings, 1 reply; 3+ messages in thread
From: Eryu Guan @ 2021-04-25  5:05 UTC (permalink / raw)
  To: Christoph Hellwig; +Cc: fstests, zlang

On Tue, Apr 20, 2021 at 07:54:16AM +0200, Christoph Hellwig wrote:
> Hi all,
> 
> generic/095 and generic/300 have been failing for me with every config
> on every file system for a while with the following messages:
> 
> --- tests/generic/095.out	2016-03-29 13:59:30.405053956 +0000
> +++ results/generic/095.out.bad	2021-04-20 05:44:54.432081845 +0000
> @@ -1,2 +1,7 @@
>  QA output created by 095
> +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
>  Silence is golden           
> 
> --- tests/generic/300.out	2016-03-29 13:59:30.431720622 +0000
> +++ results/generic/300.out.bad	2021-04-20 05:45:06.324708699 +0000
> @@ -2,3 +2,4 @@
>  
>  Run fio with random aio-dio pattern
>    
> +falloc_raicer: No I/O performed by falloc, perhaps try --debug=io option for details?
> 
> 
> ----- End forwarded message -----

Yeah, I've noticed these failures as well, and it seems that it's caused
by fio behavior change, as Zorro said he never hit such failures[1].

I'm using fio-3.7

# fio --version
fio-3.7-66-gedfc

Thanks,
Eryu

[1] https://www.spinics.net/lists/fstests/msg15871.html

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: generic/095 and generic/300 failures
  2021-04-25  5:05 ` Eryu Guan
@ 2021-04-25  6:48   ` Zorro Lang
  0 siblings, 0 replies; 3+ messages in thread
From: Zorro Lang @ 2021-04-25  6:48 UTC (permalink / raw)
  To: Eryu Guan; +Cc: Christoph Hellwig, fstests

On Sun, Apr 25, 2021 at 01:05:35PM +0800, Eryu Guan wrote:
> On Tue, Apr 20, 2021 at 07:54:16AM +0200, Christoph Hellwig wrote:
> > Hi all,
> > 
> > generic/095 and generic/300 have been failing for me with every config
> > on every file system for a while with the following messages:
> > 
> > --- tests/generic/095.out	2016-03-29 13:59:30.405053956 +0000
> > +++ results/generic/095.out.bad	2021-04-20 05:44:54.432081845 +0000
> > @@ -1,2 +1,7 @@
> >  QA output created by 095
> > +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> > +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> > +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> > +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> > +job9: No I/O performed by mmap, perhaps try --debug=io option for details?
> >  Silence is golden           
> > 
> > --- tests/generic/300.out	2016-03-29 13:59:30.431720622 +0000
> > +++ results/generic/300.out.bad	2021-04-20 05:45:06.324708699 +0000
> > @@ -2,3 +2,4 @@
> >  
> >  Run fio with random aio-dio pattern
> >    
> > +falloc_raicer: No I/O performed by falloc, perhaps try --debug=io option for details?
> > 
> > 
> > ----- End forwarded message -----
> 
> Yeah, I've noticed these failures as well, and it seems that it's caused
> by fio behavior change, as Zorro said he never hit such failures[1].
> 
> I'm using fio-3.7

I use fio-3.25-3. I never saw the errors you metioned above.

How about CC axboe@kernel.dk (fio maintainer) if you still can reproduce this
error on latest fio version?

Thanks,
Zorro

> 
> # fio --version
> fio-3.7-66-gedfc
> 
> Thanks,
> Eryu
> 
> [1] https://www.spinics.net/lists/fstests/msg15871.html
> 


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-20  5:54 generic/095 and generic/300 failures Christoph Hellwig
2021-04-25  5:05 ` Eryu Guan
2021-04-25  6:48   ` Zorro Lang

FSTests Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/fstests/0 fstests/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 fstests fstests/ https://lore.kernel.org/fstests \
		fstests@vger.kernel.org
	public-inbox-index fstests

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.fstests


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git