linux-bcache.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-06-09 00:57:57 to 2020-07-05 15:56:45 UTC [more...]

[RFC PATCH 00/16] bcache: extend bucket size to 32bit width
 2020-07-05 15:56 UTC  (22+ messages)
` [RFC PATCH 01/16] bcache: add comments to mark member offset of struct cache_sb_disk
` [RFC PATCH 02/16] bcache: add read_super_basic() to read major part of super block
` [RFC PATCH 03/16] bcache: add more accurate error information in read_super_basic()
` [RFC PATCH 04/16] bcache: disassemble the big if() checks in bch_cache_set_alloc()
` [RFC PATCH 05/16] bcache: fix super block seq numbers comparision in register_cache_set()
` [RFC PATCH 06/16] bcache: increase super block version for cache device and backing device
` [RFC PATCH 07/16] bcache: move bucket related code into read_super_basic()
` [RFC PATCH 08/16] bcache: struct cache_sb is only for in-memory super block now
` [RFC PATCH 09/16] bcache: introduce meta_bucket_pages() related helper routines
` [RFC PATCH 10/16] bcache: handle c->uuids properly for bucket size > 8MB
` [RFC PATCH 11/16] bcache: handle cache prio_buckets and disk_buckets "
` [RFC PATCH 12/16] bcache: handle cache set verify_ondisk "
` [RFC PATCH 13/16] bcache: handle btree node memory allocation "
` [RFC PATCH 14/16] bcache: add bucket_size_hi into struct cache_sb_disk for large bucket
` [RFC PATCH 15/16] bcache: avoid extra memory allocation from mempool c->fill_iter

Input requirement for persistent configuration items in bcache
 2020-07-05 10:23 UTC  (3+ messages)

rename ->make_request_fn and move it to the block_device_operations v2
 2020-07-02 18:22 UTC  (46+ messages)
` [PATCH 01/20] nfblock: stop using ->queuedata
` [PATCH 02/20] simdisk: "
` [PATCH 03/20] drbd: "
` [PATCH 04/20] null_blk: stop using ->queuedata for bio mode
` [PATCH 05/20] ps3vram: stop using ->queuedata
` [PATCH 06/20] rsxx: "
` [PATCH 07/20] umem: "
` [PATCH 08/20] zram: "
` [PATCH 09/20] bcache: stop setting ->queuedata
` [PATCH 10/20] dm: stop using ->queuedata
` [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc
` [PATCH 12/20] block: remove the request_queue argument from blk_queue_split
` [PATCH 13/20] block: tidy up a warning in bio_check_ro
` [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks
` [PATCH 15/20] block: remove the nr_sectors variable "
` [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations
` [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct
` [PATCH 18/20] block: refator submit_bio_noacct
` [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers
` [PATCH 20/20] block: remove direct_make_request

rename ->make_request_fn and move it to the block_device_operations
 2020-07-02 15:52 UTC  (61+ messages)
` [PATCH 01/20] nfblock: stop using ->queuedata
` [PATCH 02/20] simdisk: "
` [PATCH 03/20] drbd: "
` [PATCH 04/20] null_blk: stop using ->queuedata for bio mode
` [PATCH 05/20] ps3vram: stop using ->queuedata
` [PATCH 06/20] rsxx: "
` [PATCH 07/20] umem: "
` [PATCH 08/20] zram: "
` [PATCH 09/20] bcache: stop setting ->queuedata
` [PATCH 10/20] dm: stop using ->queuedata
` [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc
` [PATCH 12/20] block: remove the request_queue argument from blk_queue_split
` [PATCH 13/20] block: tidy up a warning in bio_check_ro
` [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks
` [PATCH 15/20] block: remove the nr_sectors variable "
` [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations
` [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct
` [PATCH 18/20] block: refator submit_bio_noacct
` [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers
` [PATCH 20/20] block: remove direct_make_request

remove dead bdi congestion leftovers
 2020-07-02  5:36 UTC  (22+ messages)
` [PATCH 1/4] drbd: remove a bogus bdi_rw_congested call
` [PATCH 2/4] writeback: remove {set,clear}_wb_congested
  ` [PATCH 3/4] writeback: remove struct bdi_writeback_congested
` [PATCH 4/4] writeback: remove bdi->congested_fn

Hello,
 2020-06-29 19:15 UTC 

[PATCH] bcache: journel: use for_each_clear_bit() to simplify the code
 2020-06-24 14:51 UTC  (3+ messages)

Re;
 2020-06-24 13:54 UTC 

Small Cache Dev Tuning
 2020-06-23 17:44 UTC  (4+ messages)

[PATCH AUTOSEL 5.7 05/28] bcache: check and adjust logical block size for backing devices
 2020-06-23 17:35 UTC  (2+ messages)

Hello
 2020-06-23 11:47 UTC 

Greetings From Mrs. Sarah Koffi
 2020-06-23 11:12 UTC 

URGENT REPLY
 2020-06-22 16:02 UTC 

[PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc()
 2020-06-20 14:17 UTC  (4+ messages)

Input requirement for persistent configuration items in bcache
 2020-06-22  8:01 UTC 

[PATCH][next] bcache: Use struct_size() in kzalloc()
 2020-06-19 15:01 UTC  (6+ messages)

Lucrative Proposal
 2020-06-13 20:55 UTC 

donation of Euro 2,000,000.00
 2020-06-15 21:54 UTC 

[PATCH 0/4] bcache: more fixes for v5.8-rc1
 2020-06-15  6:12 UTC  (11+ messages)
` [PATCH 1/4] bcache: fix potential deadlock problem in btree_gc_coalesce
` [PATCH 2/4] bcache: check and adjust logical block size for backing devices
` [PATCH 3/4] bcache: use delayed kworker fo asynchronous devices registration
` [PATCH 4/4] bcache: pr_info() format clean up in bcache_device_init()

[PATCH V3] bcache: fix potential deadlock problem in btree_gc_coalesce
 2020-06-12  1:02 UTC  (2+ messages)

[PATCH V2] bcache: fix potential deadlock problem in btree_gc_coalesce
 2020-06-12  1:01 UTC  (3+ messages)

[PATCH] bcache: check and adjust logical block size for backing devices
 2020-06-10 11:39 UTC  (4+ messages)

bcachefs status update (it's done cooking; let's get this sucker merged)
 2020-06-10 11:32 UTC  (3+ messages)

[PATCH AUTOSEL 5.7 121/274] bcache: remove a duplicate ->make_request_fn assignment
 2020-06-08 23:03 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).