linux-bcache.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-06-29 19:39:41 to 2020-07-15 05:46:43 UTC [more...]

[PATCH v2 00/17] bcache: extend bucket size to 32bit width
 2020-07-15  5:46 UTC  (11+ messages)
` [PATCH v2 01/17] bcache: add comments to mark member offset of struct cache_sb_disk
` [PATCH v2 02/17] bcache: add read_super_basic() to read major part of super block
` [PATCH v2 03/17] bcache: add more accurate error information in read_super_basic()
` [PATCH v2 04/17] bcache: disassemble the big if() checks in bch_cache_set_alloc()
` [PATCH v2 05/17] bcache: fix super block seq numbers comparision in register_cache_set()
` [PATCH v2 06/17] bcache: increase super block version for cache device and backing device
` [PATCH v2 07/17] bcache: move bucket related code into read_super_basic()
` [PATCH v2 08/17] bcache: struct cache_sb is only for in-memory super block now
` [PATCH v2 09/17] bcache: introduce meta_bucket_pages() related helper routines
` [PATCH v2 10/17] bcache: handle c->uuids properly for bucket size > 8MB

[PATCH 1/2] nvme-tpc: don't use sendpage for pages not taking reference counter
 2020-07-14  7:19 UTC  (4+ messages)
` [PATCH 2/2] bcache: allocate meta data pages as compound pages

[PATCH] bcache: add a new sysfs interface to disable refill when read miss
 2020-07-14  6:20 UTC  (3+ messages)

[PATCH v2] nvme-tcp: don't use sendpage for pages not taking reference counter
 2020-07-13 12:44 UTC 

[PATCH v2 1/2] bcache: avoid nr_stripes overflow in bcache_device_init()
 2020-07-13 11:15 UTC  (2+ messages)
` [PATCH v2 2/2] bcche: fix overflow in offset_to_stripe()

[PATCH 1/2] bcache: avoid nr_stripes overflow in bcache_device_init()
 2020-07-13  3:35 UTC  (7+ messages)
` [PATCH 2/2] bcche: fix overflow in offset_to_stripe()

bcache integer overflow for large devices w/small io_opt
 2020-07-12  9:31 UTC  (4+ messages)

how does the caching works in bcachefs
 2020-07-09 16:08 UTC  (4+ messages)

remove dead bdi congestion leftovers
 2020-07-09 14:01 UTC  (30+ messages)
` [PATCH 1/4] drbd: remove a bogus bdi_rw_congested call
` [PATCH 2/4] writeback: remove {set,clear}_wb_congested
  ` [PATCH 3/4] writeback: remove struct bdi_writeback_congested
` [PATCH 4/4] writeback: remove bdi->congested_fn

[PATCH] bcache: writeback: Remove unneeded variable i
 2020-07-09  6:04 UTC  (3+ messages)

[PATCH] bcache: writeback: Remove unneeded variable ret
 2020-07-09  4:07 UTC  (3+ messages)

My Dear Beloved One,
 2020-07-08 12:33 UTC 

[RFC PATCH 0/4] bcache-tools: changes for large bucket size
 2020-07-05 16:04 UTC  (7+ messages)
` [RFC PATCH 1/4] bcache-tools: comments offset for members of struct cache_sb
` [RFC PATCH 2/4] struct_offset: print offset of each member of the on-disk data structure
` [RFC PATCH 3/4] bcache-tools: The new super block version BCACHE_SB_VERSION_BDEV_WITH_FEATURES
` [RFC PATCH 4/4] bcache-tools: add large_bucket incompat feature

[RFC PATCH 00/16] bcache: extend bucket size to 32bit width
 2020-07-05 15:56 UTC  (23+ messages)
` [RFC PATCH 01/16] bcache: add comments to mark member offset of struct cache_sb_disk
` [RFC PATCH 02/16] bcache: add read_super_basic() to read major part of super block
` [RFC PATCH 03/16] bcache: add more accurate error information in read_super_basic()
` [RFC PATCH 04/16] bcache: disassemble the big if() checks in bch_cache_set_alloc()
` [RFC PATCH 05/16] bcache: fix super block seq numbers comparision in register_cache_set()
` [RFC PATCH 06/16] bcache: increase super block version for cache device and backing device
` [RFC PATCH 07/16] bcache: move bucket related code into read_super_basic()
` [RFC PATCH 08/16] bcache: struct cache_sb is only for in-memory super block now
` [RFC PATCH 09/16] bcache: introduce meta_bucket_pages() related helper routines
` [RFC PATCH 10/16] bcache: handle c->uuids properly for bucket size > 8MB
` [RFC PATCH 11/16] bcache: handle cache prio_buckets and disk_buckets "
` [RFC PATCH 12/16] bcache: handle cache set verify_ondisk "
` [RFC PATCH 13/16] bcache: handle btree node memory allocation "
` [RFC PATCH 14/16] bcache: add bucket_size_hi into struct cache_sb_disk for large bucket
` [RFC PATCH 15/16] bcache: avoid extra memory allocation from mempool c->fill_iter
` [RFC PATCH 16/16] bcache: avoid extra memory consumption in struct bbio for large bucket size

Input requirement for persistent configuration items in bcache
 2020-07-05 10:23 UTC  (3+ messages)

rename ->make_request_fn and move it to the block_device_operations v2
 2020-07-02 18:22 UTC  (46+ messages)
` [PATCH 01/20] nfblock: stop using ->queuedata
` [PATCH 02/20] simdisk: "
` [PATCH 03/20] drbd: "
` [PATCH 04/20] null_blk: stop using ->queuedata for bio mode
` [PATCH 05/20] ps3vram: stop using ->queuedata
` [PATCH 06/20] rsxx: "
` [PATCH 07/20] umem: "
` [PATCH 08/20] zram: "
` [PATCH 09/20] bcache: stop setting ->queuedata
` [PATCH 10/20] dm: stop using ->queuedata
` [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc
` [PATCH 12/20] block: remove the request_queue argument from blk_queue_split
` [PATCH 13/20] block: tidy up a warning in bio_check_ro
` [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks
` [PATCH 15/20] block: remove the nr_sectors variable "
` [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations
` [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct
` [PATCH 18/20] block: refator submit_bio_noacct
` [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers
` [PATCH 20/20] block: remove direct_make_request

rename ->make_request_fn and move it to the block_device_operations
 2020-07-02 15:52 UTC  (61+ messages)
` [PATCH 01/20] nfblock: stop using ->queuedata
` [PATCH 02/20] simdisk: "
` [PATCH 03/20] drbd: "
` [PATCH 04/20] null_blk: stop using ->queuedata for bio mode
` [PATCH 05/20] ps3vram: stop using ->queuedata
` [PATCH 06/20] rsxx: "
` [PATCH 07/20] umem: "
` [PATCH 08/20] zram: "
` [PATCH 09/20] bcache: stop setting ->queuedata
` [PATCH 10/20] dm: stop using ->queuedata
` [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc
` [PATCH 12/20] block: remove the request_queue argument from blk_queue_split
` [PATCH 13/20] block: tidy up a warning in bio_check_ro
` [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks
` [PATCH 15/20] block: remove the nr_sectors variable "
` [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations
` [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct
` [PATCH 18/20] block: refator submit_bio_noacct
` [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers
` [PATCH 20/20] block: remove direct_make_request


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).