linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/8] Misc device cleanup patches: part1
@ 2017-11-06  8:36 Anand Jain
  2017-11-06  8:36 ` [PATCH 1/7] btrfs: optimize use of volume_mutex in btrfs_ioctl_resize() Anand Jain
                   ` (6 more replies)
  0 siblings, 7 replies; 15+ messages in thread
From: Anand Jain @ 2017-11-06  8:36 UTC (permalink / raw)
  To: linux-btrfs

A miscellaneous device management related cleanup patches. The core
objective of this and upcoming patches is to able to have a clear
clarity on mutex usages and remove redundant codes. And few good
to have fixes.

Anand Jain (7):
  btrfs: optimize use of volume_mutex in btrfs_ioctl_resize()
  btrfs: move user provided string checks outside of volume_mutex
  btrfs: use i_size_read() instead of open code
  btrfs: rename btrfs_add_device to btrfs_add_dev_item
  btrfs: btrfs_rm_device() does not need uuid_mutex
  btrfs: move volume_mutex into btrfs_init_new_device()
  btrfs: rename btrfs_init_new_device() to btrfs_add_device()

 fs/btrfs/ioctl.c   | 64 +++++++++++++++++++++++++++---------------------------
 fs/btrfs/volumes.c | 20 ++++++++++-------
 fs/btrfs/volumes.h |  2 +-
 3 files changed, 45 insertions(+), 41 deletions(-)

-- 
2.13.1


^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2017-11-15 16:47 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-11-06  8:36 [PATCH 0/8] Misc device cleanup patches: part1 Anand Jain
2017-11-06  8:36 ` [PATCH 1/7] btrfs: optimize use of volume_mutex in btrfs_ioctl_resize() Anand Jain
2017-11-06 16:50   ` David Sterba
2017-11-06  8:36 ` [PATCH 2/7] btrfs: move user provided string checks outside of volume_mutex Anand Jain
2017-11-06  8:36 ` [PATCH 3/7] btrfs: use i_size_read() instead of open code Anand Jain
2017-11-06 16:52   ` David Sterba
2017-11-06 23:44     ` Anand Jain
2017-11-15 16:45       ` David Sterba
2017-11-06  8:36 ` [PATCH 4/7] btrfs: rename btrfs_add_device to btrfs_add_dev_item Anand Jain
2017-11-06 16:53   ` David Sterba
2017-11-06  8:36 ` [PATCH 5/7] btrfs: btrfs_rm_device() does not need uuid_mutex Anand Jain
2017-11-06 17:02   ` David Sterba
2017-11-06 23:59     ` Anand Jain
2017-11-06  8:36 ` [PATCH 6/7] btrfs: move volume_mutex into btrfs_init_new_device() Anand Jain
2017-11-06  8:36 ` [PATCH 7/7] btrfs: rename btrfs_init_new_device() to btrfs_add_device() Anand Jain

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).