linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Anand Jain <Anand.Jain@oracle.com>
To: dsterba@suse.cz, linux-btrfs@vger.kernel.org, jeffm@suse.com, clm@fb.com
Subject: Re: [PATCH 1/4] btrfs: dev delete should remove sysfs entry
Date: Fri, 30 May 2014 14:10:28 +0800	[thread overview]
Message-ID: <538820D4.3010808@oracle.com> (raw)
In-Reply-To: <20140529130428.GC29992@twin.jikos.cz>


Thanks for the review David.

On 29/05/14 21:04, David Sterba wrote:
> On Mon, May 26, 2014 at 05:30:23PM +0800, Anand Jain wrote:
>> --- a/fs/btrfs/sysfs.c
>> +++ b/fs/btrfs/sysfs.c
>> @@ -572,6 +572,26 @@ static void init_feature_attrs(void)
>>   	}
>>   }
>>
>> +int rm_device_membership(struct btrfs_fs_info *fs_info,
>> +		struct btrfs_device *one_device)
>
> The name is too generic for a non-static function, so it would be good
> to add at least the btrfs_ prefix. Same applies to the change of
> 'add_device_membership' in the next patch.

  Yes indeed. I wanted it to change as well. But the diff became
  unfriendly to read.  I shall do that in a separate patch.


> As this is only a trivial change, consider this
> Reviewed-by: David Sterba <dsterba@suse.cz>
>
>> +{
>> +	struct hd_struct *disk;
>> +	struct kobject *disk_kobj;
>> +
>> +	if (!fs_info->device_dir_kobj)
>> +		return -EINVAL;
>> +
>> +	if (one_device) {
>> +		disk = one_device->bdev->bd_part;
>> +		disk_kobj = &part_to_dev(disk)->kobj;
>> +
>> +		sysfs_remove_link(fs_info->device_dir_kobj,
>> +						disk_kobj->name);
>> +	}
>> +
>> +	return 0;
>> +}
>> +
>>   static int add_device_membership(struct btrfs_fs_info *fs_info)
>>   {
>>   	int error = 0;
> --
> To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>

  reply	other threads:[~2014-05-30  6:07 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-26  9:30 [PATCH 0/4] update sysfs per btrfs device operations Anand Jain
2014-05-26  9:30 ` [PATCH 1/4] btrfs: dev delete should remove sysfs entry Anand Jain
2014-05-29 13:04   ` David Sterba
2014-05-30  6:10     ` Anand Jain [this message]
2014-05-30 14:10       ` David Sterba
2014-05-26  9:30 ` [PATCH 2/4] btrfs: dev add should add its " Anand Jain
2014-05-29 14:49   ` David Sterba
2014-05-26  9:30 ` [PATCH 3/4] btrfs: dev replace should replace the " Anand Jain
2014-05-29 13:29   ` David Sterba
2014-05-30  7:40     ` Anand Jain
2014-06-03  3:47       ` Anand Jain
2014-06-03 13:39         ` David Sterba
2014-05-26  9:30 ` [PATCH 4/4] btrfs: create sprout should rename fsid on the sysfs as well Anand Jain
2014-05-29 12:54   ` David Sterba
2014-06-02  8:22     ` Anand Jain
2014-06-02 15:39       ` David Sterba
2014-06-03  0:27         ` Anand Jain
2014-05-28  8:30 ` [PATCH RFC v2] btrfs: revamp /sys/fs/btrfs/<fsid>/devices Anand Jain

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=538820D4.3010808@oracle.com \
    --to=anand.jain@oracle.com \
    --cc=clm@fb.com \
    --cc=dsterba@suse.cz \
    --cc=jeffm@suse.com \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).