linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] serial: 8250_pci: Prefer struct_size over open coded arithmetic
@ 2021-09-05 15:57 Len Baker
  2021-09-05 16:13 ` Andy Shevchenko
  0 siblings, 1 reply; 2+ messages in thread
From: Len Baker @ 2021-09-05 15:57 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Jiri Slaby
  Cc: Len Baker, Kees Cook, Maciej W. Rozycki, Andy Shevchenko,
	Mario Kleiner, Geert Uytterhoeven, Randy Wright,
	Christian Gmeiner, Tobias Diedrich, YueHaibing, linux-serial,
	linux-hardening, linux-kernel

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the struct_size() helper to do the arithmetic instead of the
argument "size + size * count" in the kzalloc() function.

[1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <len.baker@gmx.com>
---
 drivers/tty/serial/8250/8250_pci.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/tty/serial/8250/8250_pci.c b/drivers/tty/serial/8250/8250_pci.c
index a808c283883e..b97ade35d4a3 100644
--- a/drivers/tty/serial/8250/8250_pci.c
+++ b/drivers/tty/serial/8250/8250_pci.c
@@ -3981,9 +3981,7 @@ pciserial_init_ports(struct pci_dev *dev, const struct pciserial_board *board)
 			nr_ports = rc;
 	}

-	priv = kzalloc(sizeof(struct serial_private) +
-		       sizeof(unsigned int) * nr_ports,
-		       GFP_KERNEL);
+	priv = kzalloc(struct_size(priv, line, nr_ports), GFP_KERNEL);
 	if (!priv) {
 		priv = ERR_PTR(-ENOMEM);
 		goto err_deinit;
--
2.25.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] serial: 8250_pci: Prefer struct_size over open coded arithmetic
  2021-09-05 15:57 [PATCH] serial: 8250_pci: Prefer struct_size over open coded arithmetic Len Baker
@ 2021-09-05 16:13 ` Andy Shevchenko
  0 siblings, 0 replies; 2+ messages in thread
From: Andy Shevchenko @ 2021-09-05 16:13 UTC (permalink / raw)
  To: Len Baker
  Cc: Greg Kroah-Hartman, Jiri Slaby, Kees Cook, Maciej W. Rozycki,
	Andy Shevchenko, Mario Kleiner, Geert Uytterhoeven, Randy Wright,
	Christian Gmeiner, Tobias Diedrich, YueHaibing,
	open list:SERIAL DRIVERS, linux-hardening,
	Linux Kernel Mailing List

On Sun, Sep 5, 2021 at 6:58 PM Len Baker <len.baker@gmx.com> wrote:
>
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + size * count" in the kzalloc() function.

Makes sense
Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>

> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@gmx.com>
> ---
>  drivers/tty/serial/8250/8250_pci.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/tty/serial/8250/8250_pci.c b/drivers/tty/serial/8250/8250_pci.c
> index a808c283883e..b97ade35d4a3 100644
> --- a/drivers/tty/serial/8250/8250_pci.c
> +++ b/drivers/tty/serial/8250/8250_pci.c
> @@ -3981,9 +3981,7 @@ pciserial_init_ports(struct pci_dev *dev, const struct pciserial_board *board)
>                         nr_ports = rc;
>         }
>
> -       priv = kzalloc(sizeof(struct serial_private) +
> -                      sizeof(unsigned int) * nr_ports,
> -                      GFP_KERNEL);
> +       priv = kzalloc(struct_size(priv, line, nr_ports), GFP_KERNEL);
>         if (!priv) {
>                 priv = ERR_PTR(-ENOMEM);
>                 goto err_deinit;
> --
> 2.25.1
>


-- 
With Best Regards,
Andy Shevchenko

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-09-05 16:14 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-05 15:57 [PATCH] serial: 8250_pci: Prefer struct_size over open coded arithmetic Len Baker
2021-09-05 16:13 ` Andy Shevchenko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).