linux-iio.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andy Shevchenko <andy.shevchenko@gmail.com>
To: Jishnu Prakash <jprakash@codeaurora.org>
Cc: agross@kernel.org, Bjorn Andersson <bjorn.andersson@linaro.org>,
	devicetree <devicetree@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Matthias Kaehlcke <mka@chromium.org>,
	Linus Walleij <linus.walleij@linaro.org>,
	Jonathan Cameron <Jonathan.Cameron@huawei.com>,
	Amit Kucheria <amit.kucheria@verdurent.com>,
	smohanad@codeaurora.org, kgunda@codeaurora.org,
	aghayal@codeaurora.org, Jonathan Cameron <jic23@kernel.org>,
	Hartmut Knaack <knaack.h@gmx.de>,
	Lars-Peter Clausen <lars@metafoo.de>,
	Peter Meerwald-Stadler <pmeerw@pmeerw.net>,
	linux-arm-msm@vger.kernel.org,
	linux-iio <linux-iio@vger.kernel.org>,
	linux-arm-msm-owner@vger.kernel.org
Subject: Re: [PATCH V4 3/5] iio: adc: Add support for PMIC7 ADC
Date: Fri, 22 May 2020 18:31:05 +0300	[thread overview]
Message-ID: <CAHp75Vf0srsT6yonxiA1Lc8uP4=17u5E19iWfW7XGivfgJjFNg@mail.gmail.com> (raw)
In-Reply-To: <50ad0f74-22cc-c74f-afa4-df654e29bebb@codeaurora.org>

On Fri, May 22, 2020 at 2:58 PM Jishnu Prakash <jprakash@codeaurora.org> wrote:
> On 5/13/2020 3:18 PM, Andy Shevchenko wrote:
> > On Wed, May 13, 2020 at 12:23 PM Jishnu Prakash <jprakash@codeaurora.org> wrote:

...

> >> +static int qcom_vadc7_scale_hw_calib_die_temp(
> >> +                               const struct vadc_prescale_ratio *prescale,
> >> +                               const struct adc5_data *data,
> >> +                               u16 adc_code, int *result_mdec)
> >> +{
> >> +
> >> +       int voltage, vtemp0, temp, i = ARRAY_SIZE(adcmap7_die_temp) - 1;
> > How assignment to i is useful?
>
>
> I'm using it in adcmap7_die_temp[i] below, to keep it within the
> character limit per line. I think it's more readable that way.
>
> >
> >> +       voltage = qcom_vadc_scale_code_voltage_factor(adc_code,
> >> +                               prescale, data, 1);
> >> +
> >> +       if (adcmap7_die_temp[0].x > voltage) {
> >> +               *result_mdec = DIE_TEMP_ADC7_SCALE_1;
> >> +               return 0;
> >> +       } else if (adcmap7_die_temp[i].x <= voltage) {

I see now i in use, please, replace with direct meaning.

> > Redundant 'else'.
> The expression is different, it's adcmap7_die_temp[i] here, not
> adcmap7_die_temp[0].

if (a) {
 ...
 return;
} else if (b) {
 ...
}

'else' is redundant due to 'return'. Same when it's 'goto'.

> >> +               *result_mdec = DIE_TEMP_ADC7_MAX;
> >> +               return 0;
> >> +       }
> >> +
> >> +       for (i = 0; i < ARRAY_SIZE(adcmap7_die_temp); i++)
> >> +               if (adcmap7_die_temp[i].x > voltage)
> >> +                       break;
> >> +
> >> +       vtemp0 = adcmap7_die_temp[i - 1].x;
> >> +       voltage = voltage - vtemp0;
> >> +       temp = div64_s64(voltage * DIE_TEMP_ADC7_SCALE_FACTOR,
> >> +               adcmap7_die_temp[i - 1].y);
> >> +       temp += DIE_TEMP_ADC7_SCALE_1 + (DIE_TEMP_ADC7_SCALE_2 * (i - 1));
> >> +       *result_mdec = temp;
> >> +
> >> +       return 0;
> >> +}

-- 
With Best Regards,
Andy Shevchenko

  reply	other threads:[~2020-05-22 15:31 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <1589361736-816-1-git-send-email-jprakash@codeaurora.org>
2020-05-13  9:22 ` [PATCH V4 1/5] iio: adc: Convert the QCOM SPMI ADC bindings to .yaml format Jishnu Prakash
2020-05-18  7:25   ` Linus Walleij
2020-05-13  9:22 ` [PATCH V4 2/5] iio: adc: Add PMIC7 ADC bindings Jishnu Prakash
2020-05-13  9:22 ` [PATCH V4 3/5] iio: adc: Add support for PMIC7 ADC Jishnu Prakash
2020-05-13  9:48   ` Andy Shevchenko
2020-05-22 11:58     ` Jishnu Prakash
2020-05-22 15:31       ` Andy Shevchenko [this message]
2020-05-13  9:22 ` [PATCH V4 4/5] iio: adc: Update error checks and debug prints Jishnu Prakash
2020-05-13  9:49   ` Andy Shevchenko
2020-05-22 11:58     ` Jishnu Prakash
2020-05-13  9:22 ` [PATCH V4 5/5] iio: adc: Clean up ADC code common to PMIC5 and PMIC7 Jishnu Prakash
2020-05-13  9:51   ` Andy Shevchenko
2020-05-22 11:59     ` Jishnu Prakash

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAHp75Vf0srsT6yonxiA1Lc8uP4=17u5E19iWfW7XGivfgJjFNg@mail.gmail.com' \
    --to=andy.shevchenko@gmail.com \
    --cc=Jonathan.Cameron@huawei.com \
    --cc=aghayal@codeaurora.org \
    --cc=agross@kernel.org \
    --cc=amit.kucheria@verdurent.com \
    --cc=bjorn.andersson@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=jic23@kernel.org \
    --cc=jprakash@codeaurora.org \
    --cc=kgunda@codeaurora.org \
    --cc=knaack.h@gmx.de \
    --cc=lars@metafoo.de \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-msm-owner@vger.kernel.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mka@chromium.org \
    --cc=pmeerw@pmeerw.net \
    --cc=smohanad@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).