iommu.lists.linux-foundation.org archive mirror
 help / color / mirror / Atom feed
From: Lu Baolu <baolu.lu@linux.intel.com>
To: Joerg Roedel <joro@8bytes.org>, Jason Gunthorpe <jgg@nvidia.com>,
	Christoph Hellwig <hch@infradead.org>,
	Kevin Tian <kevin.tian@intel.com>,
	Ashok Raj <ashok.raj@intel.com>, Will Deacon <will@kernel.org>,
	Robin Murphy <robin.murphy@arm.com>,
	Jean-Philippe Brucker <jean-philippe@linaro.com>,
	Dave Jiang <dave.jiang@intel.com>, Vinod Koul <vkoul@kernel.org>
Cc: Eric Auger <eric.auger@redhat.com>, Liu Yi L <yi.l.liu@intel.com>,
	Jacob jun Pan <jacob.jun.pan@intel.com>,
	Zhangfei Gao <zhangfei.gao@linaro.org>,
	Zhu Tony <tony.zhu@intel.com>,
	iommu@lists.linux.dev, linux-kernel@vger.kernel.org,
	Lu Baolu <baolu.lu@linux.intel.com>
Subject: [PATCH v10 00/12] iommu: SVA and IOPF refactoring
Date: Tue,  5 Jul 2022 13:06:58 +0800	[thread overview]
Message-ID: <20220705050710.2887204-1-baolu.lu@linux.intel.com> (raw)

Hi folks,

The former part of this series refactors the IOMMU SVA code by assigning
an SVA type of iommu_domain to a shared virtual address and replacing
sva_bind/unbind iommu ops with set/block_dev_pasid domain ops.

The latter part changes the existing I/O page fault handling framework
from only serving SVA to a generic one. Any driver or component could
handle the I/O page faults for its domain in its own way by installing
an I/O page fault handler.

Thanks to Tony and Zhangfei. This series has been functionally tested on
both intel and ARM aarch64 platforms.

This series is also available on github:
[2] https://github.com/LuBaolu/intel-iommu/commits/iommu-sva-refactoring-v10

Please review and suggest.

Best regards,
baolu

Change log:
v10:
 - Rebase on next branch of iommu tree.
 - Split attach/detach_device_pasid interfaces and SVA domain extensions
   to different patches.
 - Handle the return error of xa_cmpxchg() gracefully.
 - Directly pass mm in as the SVA fault data.
 - Rename iopf_handle_group() to iopf_handler().
 - Some commit message and code comment refinement.
 - Add Tested-by's from Zhangfei and Tony.

v9:
 - https://lore.kernel.org/linux-iommu/20220621144353.17547-1-baolu.lu@linux.intel.com/
 - Some minor changes on comments and function names.
 - Simplify dev_iommu_get_max_pasids().

v8:
 - https://lore.kernel.org/linux-iommu/20220607014942.3954894-1-baolu.lu@linux.intel.com/
 - Add support for calculating the max pasids that a device could
   consume.
 - Replace container_of_safe() with container_of.
 - Remove iommu_ops->sva_domain_ops and make sva support through the
   generic domain_alloc/free() interfaces.
 - [Robin] It would be logical to pass IOMMU_DOMAIN_SVA to the normal
   domain_alloc call, so that driver-internal stuff like context
   descriptors can be still be hung off the domain as usual (rather than
   all drivers having to implement some extra internal lookup mechanism
   to handle all the SVA domain ops).
 - [Robin] I'd just stick the mm pointer in struct iommu_domain, in a
   union with the fault handler stuff those are mutually exclusive with
   SVA.
 - https://lore.kernel.org/linux-iommu/f3170016-4d7f-e78e-db48-68305f683349@arm.com/

v7:
 - https://lore.kernel.org/linux-iommu/20220519072047.2996983-1-baolu.lu@linux.intel.com/
 - Remove duplicate array for sva domain.
 - Rename detach_dev_pasid to block_dev_pasid.
 - Add raw device driver interfaces for iommufd.
 - Other misc refinements and patch reorganization.
 - Drop "dmaengine: idxd: Separate user and kernel pasid enabling" which
   has been picked for dmaengine tree.

v6:
 - https://lore.kernel.org/linux-iommu/20220510061738.2761430-1-baolu.lu@linux.intel.com/
 - Refine the SVA basic data structures.
   Link: https://lore.kernel.org/linux-iommu/YnFv0ps0Ad8v+7uH@myrica/
 - Refine arm smmuv3 sva domain allocation.
 - Fix a possible lock issue.
   Link: https://lore.kernel.org/linux-iommu/YnFydE8j8l7Q4m+b@myrica/

v5:
 - https://lore.kernel.org/linux-iommu/20220502014842.991097-1-baolu.lu@linux.intel.com/
 - Address review comments from Jean-Philippe Brucker. Very appreciated!
 - Remove redundant pci aliases check in
   device_group_immutable_singleton().
 - Treat all buses except PCI as static in immutable singleton check.
 - As the sva_bind/unbind() have already guaranteed sva domain free only
   after iopf_queue_flush_dev(), remove the unnecessary domain refcount.
 - Move domain get() out of the list iteration in iopf_handle_group().

v4:
 - https://lore.kernel.org/linux-iommu/20220421052121.3464100-1-baolu.lu@linux.intel.com/
 - Solve the overlap with another series and make this series
   self-contained.
 - No objection to the abstraction of data structure during v3 review.
   Hence remove the RFC subject prefix.
 - Refine the immutable singleton group code according to Kevin's
   comments.

v3:
 - https://lore.kernel.org/linux-iommu/20220410102443.294128-1-baolu.lu@linux.intel.com/
 - Rework iommu_group_singleton_lockdown() by adding a flag to the group
   that positively indicates the group can never have more than one
   member, even after hot plug.
 - Abstract the data structs used for iommu sva in a separated patches to
   make it easier for review.
 - I still keep the RFC prefix in this series as above two significant
   changes need at least another round review to be finalized.
 - Several misc refinements.

v2:
 - https://lore.kernel.org/linux-iommu/20220329053800.3049561-1-baolu.lu@linux.intel.com/
 - Add sva domain life cycle management to avoid race between unbind and
   page fault handling.
 - Use a single domain for each mm.
 - Return a single sva handler for the same binding.
 - Add a new helper to meet singleton group requirement.
 - Rework the SVA domain allocation for arm smmu v3 driver and move the
   pasid_bit initialization to device probe.
 - Drop the patch "iommu: Handle IO page faults directly".
 - Add mmget_not_zero(mm) in SVA page fault handler.

v1:
 - https://lore.kernel.org/linux-iommu/20220320064030.2936936-1-baolu.lu@linux.intel.com/
 - Initial post.

Lu Baolu (12):
  iommu: Add max_pasids field in struct iommu_device
  iommu: Add max_pasids field in struct dev_iommu
  iommu: Remove SVM_FLAG_SUPERVISOR_MODE support
  iommu: Add attach/detach_dev_pasid iommu interface
  iommu: Add IOMMU SVA domain support
  iommu/vt-d: Add SVA domain support
  arm-smmu-v3/sva: Add SVA domain support
  iommu/sva: Refactoring iommu_sva_bind/unbind_device()
  iommu: Remove SVA related callbacks from iommu ops
  iommu: Prepare IOMMU domain for IOPF
  iommu: Per-domain I/O page fault handling
  iommu: Rename iommu-sva-lib.{c,h}

 include/linux/intel-iommu.h                   |  12 +-
 include/linux/intel-svm.h                     |  13 -
 include/linux/iommu.h                         | 128 +++++++---
 drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.h   |  19 +-
 .../iommu/{iommu-sva-lib.h => iommu-sva.h}    |  14 +-
 drivers/dma/idxd/cdev.c                       |   3 +-
 drivers/dma/idxd/init.c                       |  25 +-
 .../iommu/arm/arm-smmu-v3/arm-smmu-v3-sva.c   | 112 +++++---
 drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c   |   9 +-
 drivers/iommu/intel/dmar.c                    |   7 +
 drivers/iommu/intel/iommu.c                   |   7 +-
 drivers/iommu/intel/svm.c                     | 149 +++++------
 drivers/iommu/io-pgfault.c                    |  77 ++----
 drivers/iommu/iommu-sva-lib.c                 |  71 ------
 drivers/iommu/iommu-sva.c                     | 227 +++++++++++++++++
 drivers/iommu/iommu.c                         | 239 +++++++++++-------
 drivers/misc/uacce/uacce.c                    |   2 +-
 drivers/iommu/Makefile                        |   2 +-
 18 files changed, 651 insertions(+), 465 deletions(-)
 rename drivers/iommu/{iommu-sva-lib.h => iommu-sva.h} (83%)
 delete mode 100644 drivers/iommu/iommu-sva-lib.c
 create mode 100644 drivers/iommu/iommu-sva.c

-- 
2.25.1


             reply	other threads:[~2022-07-05  5:11 UTC|newest]

Thread overview: 90+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-05  5:06 Lu Baolu [this message]
2022-07-05  5:06 ` [PATCH v10 01/12] iommu: Add max_pasids field in struct iommu_device Lu Baolu
2022-07-23 13:57   ` Jason Gunthorpe
2022-07-31 11:54   ` Yi Liu
2022-07-31 13:33     ` Baolu Lu
2022-07-05  5:07 ` [PATCH v10 02/12] iommu: Add max_pasids field in struct dev_iommu Lu Baolu
2022-07-23 14:02   ` Jason Gunthorpe
2022-07-31 11:55   ` Yi Liu
2022-07-05  5:07 ` [PATCH v10 03/12] iommu: Remove SVM_FLAG_SUPERVISOR_MODE support Lu Baolu
2022-07-31 12:01   ` Yi Liu
2022-07-31 13:39     ` Baolu Lu
2022-07-05  5:07 ` [PATCH v10 04/12] iommu: Add attach/detach_dev_pasid iommu interface Lu Baolu
2022-07-07  1:51   ` Tian, Kevin
2022-07-23 14:11   ` Jason Gunthorpe
2022-07-24  7:03     ` Baolu Lu
2022-07-25 14:40       ` Jason Gunthorpe
2022-07-26  6:23         ` Baolu Lu
2022-07-26 13:57           ` Jason Gunthorpe
2022-07-27  3:20             ` Tian, Kevin
2022-07-27 11:53               ` Jason Gunthorpe
2022-07-28  3:06                 ` Tian, Kevin
2022-07-28 11:59                   ` Jason Gunthorpe
2022-07-29  2:49                     ` Baolu Lu
2022-07-29  2:56                       ` Tian, Kevin
2022-07-29  3:20                         ` Baolu Lu
2022-07-29  4:22                           ` Tian, Kevin
2022-07-30  6:17                             ` Baolu Lu
2022-07-29  2:51                     ` Tian, Kevin
2022-07-29 12:22                       ` Jason Gunthorpe
2022-07-30  6:23                         ` Baolu Lu
2022-07-28  2:44             ` Baolu Lu
2022-07-28  6:27               ` Baolu Lu
2022-08-02  2:19             ` Baolu Lu
2022-08-02 12:37               ` Jason Gunthorpe
2022-08-03 13:07                 ` Baolu Lu
2022-08-03 19:03                   ` Jason Gunthorpe
2022-08-04  2:03                     ` Tian, Kevin
2022-08-04  2:42                     ` Baolu Lu
2022-07-24  7:23     ` Baolu Lu
2022-07-24  8:39     ` Baolu Lu
2022-07-24  9:13     ` Baolu Lu
2022-07-25  7:46       ` Tian, Kevin
2022-07-25 10:11         ` Baolu Lu
2022-07-31 12:10   ` Yi Liu
2022-07-05  5:07 ` [PATCH v10 05/12] iommu: Add IOMMU SVA domain support Lu Baolu
2022-07-07  1:52   ` Tian, Kevin
2022-07-07  3:01     ` Baolu Lu
2022-07-23 14:15   ` Jason Gunthorpe
2022-07-31 12:19   ` Yi Liu
2022-07-05  5:07 ` [PATCH v10 06/12] iommu/vt-d: Add " Lu Baolu
2022-07-23 14:16   ` Jason Gunthorpe
2022-07-31 12:20   ` Yi Liu
2022-07-05  5:07 ` [PATCH v10 07/12] arm-smmu-v3/sva: " Lu Baolu
2022-07-23 14:20   ` Jason Gunthorpe
2022-07-24 11:58     ` Baolu Lu
2022-07-05  5:07 ` [PATCH v10 08/12] iommu/sva: Refactoring iommu_sva_bind/unbind_device() Lu Baolu
2022-07-05 17:43   ` Jean-Philippe Brucker
2022-07-07  1:56   ` Tian, Kevin
2022-07-07  3:02     ` Baolu Lu
2022-07-23 14:26   ` Jason Gunthorpe
2022-07-24 13:48     ` Baolu Lu
2022-07-25  7:39       ` Jean-Philippe Brucker
2022-07-25  8:02         ` Tian, Kevin
2022-07-25  8:47           ` Jean-Philippe Brucker
2022-07-25  9:33         ` Baolu Lu
2022-07-25  9:52           ` Jean-Philippe Brucker
2022-07-25 14:46             ` Jason Gunthorpe
2022-07-25  7:50       ` Tian, Kevin
2022-07-25 10:22         ` Baolu Lu
2022-07-25 14:47           ` Jason Gunthorpe
2022-07-26  8:47             ` Baolu Lu
2022-07-31 12:36   ` Yi Liu
2022-07-31 13:45     ` Baolu Lu
2022-07-31 12:55   ` Yi Liu
2022-07-31 13:51     ` Baolu Lu
2022-07-05  5:07 ` [PATCH v10 09/12] iommu: Remove SVA related callbacks from iommu ops Lu Baolu
2022-07-23 14:27   ` Jason Gunthorpe
2022-07-31 12:38   ` Yi Liu
2022-07-05  5:07 ` [PATCH v10 10/12] iommu: Prepare IOMMU domain for IOPF Lu Baolu
2022-07-07  1:58   ` Tian, Kevin
2022-07-23 14:33   ` Jason Gunthorpe
2022-07-24 14:04     ` Baolu Lu
2022-07-25 14:49       ` Jason Gunthorpe
2022-07-31 12:50   ` Yi Liu
2022-07-31 13:47     ` Baolu Lu
2022-07-05  5:07 ` [PATCH v10 11/12] iommu: Per-domain I/O page fault handling Lu Baolu
2022-07-07  2:06   ` Tian, Kevin
2022-07-23 14:34   ` Jason Gunthorpe
2022-07-05  5:07 ` [PATCH v10 12/12] iommu: Rename iommu-sva-lib.{c,h} Lu Baolu
2022-07-23 14:34   ` Jason Gunthorpe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220705050710.2887204-1-baolu.lu@linux.intel.com \
    --to=baolu.lu@linux.intel.com \
    --cc=ashok.raj@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=eric.auger@redhat.com \
    --cc=hch@infradead.org \
    --cc=iommu@lists.linux.dev \
    --cc=jacob.jun.pan@intel.com \
    --cc=jean-philippe@linaro.com \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=tony.zhu@intel.com \
    --cc=vkoul@kernel.org \
    --cc=will@kernel.org \
    --cc=yi.l.liu@intel.com \
    --cc=zhangfei.gao@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).