linux-kselftest.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andy Shevchenko <andy.shevchenko@gmail.com>
To: David Gow <davidgow@google.com>
Cc: Brendan Higgins <brendanhiggins@google.com>,
	Daniel Latypov <dlatypov@google.com>,
	Shuah Khan <skhan@linuxfoundation.org>,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	KUnit Development <kunit-dev@googlegroups.com>,
	"open list:KERNEL SELFTEST FRAMEWORK" 
	<linux-kselftest@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [PATCH v2 10/10] lib/cmdline_kunit: Remove a cast which are no-longer required
Date: Mon, 17 May 2021 09:52:27 +0300	[thread overview]
Message-ID: <CAHp75VcJ0tJw_FuNWoFWuNBsE5H4CiLUT6RsUtLwk-S7JW-vnA@mail.gmail.com> (raw)
In-Reply-To: <20210513193204.816681-10-davidgow@google.com>

On Fri, May 14, 2021 at 2:32 AM David Gow <davidgow@google.com> wrote:
>
> With some of the stricter type checking in KUnit's EXPECT macros
> removed, a cast in cmdline_kunit is no longer required.
>
> Remove the unnecessary cast, using NULL instead of (int *) to make it
> clearer.

Acked-by: Andy Shevchenko <andy.shevchenko@gmail.com>

> Signed-off-by: David Gow <davidgow@google.com>
> ---
> This should be a no-op functionality wise, and while it depends on the
> first couple of patches in this series, it's otherwise independent from
> the others. I think this makes the test more readable, but if you
> particularly dislike it, I'm happy to drop it.
>
>  lib/cmdline_kunit.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/lib/cmdline_kunit.c b/lib/cmdline_kunit.c
> index 018bfc8113c4..a72a2c16066e 100644
> --- a/lib/cmdline_kunit.c
> +++ b/lib/cmdline_kunit.c
> @@ -124,7 +124,7 @@ static void cmdline_do_one_range_test(struct kunit *test, const char *in,
>                             n, e[0], r[0]);
>
>         p = memchr_inv(&r[1], 0, sizeof(r) - sizeof(r[0]));
> -       KUNIT_EXPECT_PTR_EQ_MSG(test, p, (int *)0, "in test %u at %u out of bound", n, p - r);
> +       KUNIT_EXPECT_PTR_EQ_MSG(test, p, NULL, "in test %u at %u out of bound", n, p - r);
>  }
>
>  static void cmdline_test_range(struct kunit *test)
> --
> 2.31.1.751.gd2f1c929bd-goog
>


-- 
With Best Regards,
Andy Shevchenko

  reply	other threads:[~2021-05-17  6:52 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-13 19:31 [PATCH v2 01/10] kunit: Do not typecheck binary assertions David Gow
2021-05-13 19:31 ` [PATCH v2 02/10] kunit: Assign strings to 'const char*' in STREQ assertions David Gow
2021-05-13 19:31 ` [PATCH v2 03/10] Documentation: kunit: Clean up some string casts in examples David Gow
2021-05-13 23:07   ` Daniel Latypov
2021-06-15 20:10   ` Brendan Higgins
2021-05-13 19:31 ` [PATCH v2 04/10] device property: Remove some casts in property-entry-test David Gow
2021-05-13 19:42   ` Greg Kroah-Hartman
2021-06-15 20:12   ` Brendan Higgins
2021-05-13 19:31 ` [PATCH v2 05/10] iio: Remove a cast in iio-test-format which is no longer required David Gow
2021-06-15 20:14   ` Brendan Higgins
2021-06-16 14:08     ` Jonathan Cameron
2021-05-13 19:32 ` [PATCH v2 06/10] mmc: sdhci-of-aspeed: Remove some unnecessary casts from KUnit tests David Gow
2021-05-14  1:55   ` Andrew Jeffery
2021-05-17  9:22   ` Ulf Hansson
2021-05-18  4:29     ` David Gow
2021-06-15 20:16   ` Brendan Higgins
2021-05-13 19:32 ` [PATCH v2 07/10] thunderbolt: test: Remove sone casts which are no longer required David Gow
2021-05-14  6:06   ` Mika Westerberg
2021-05-14  7:27     ` David Gow
2021-05-14 19:57       ` Shuah Khan
2021-06-15 20:31   ` Brendan Higgins
2021-05-13 19:32 ` [PATCH v2 08/10] kernel/sysctl-test: Remove some casts which are no-longer required David Gow
2021-06-15 20:33   ` Brendan Higgins
2021-05-13 19:32 ` [PATCH v2 09/10] apparmor: test: " David Gow
2021-06-15 20:40   ` Brendan Higgins
2021-06-15 21:26   ` John Johansen
2021-05-13 19:32 ` [PATCH v2 10/10] lib/cmdline_kunit: Remove a cast " David Gow
2021-05-17  6:52   ` Andy Shevchenko [this message]
2021-06-15 20:42   ` Brendan Higgins

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAHp75VcJ0tJw_FuNWoFWuNBsE5H4CiLUT6RsUtLwk-S7JW-vnA@mail.gmail.com \
    --to=andy.shevchenko@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=brendanhiggins@google.com \
    --cc=davidgow@google.com \
    --cc=dlatypov@google.com \
    --cc=geert+renesas@glider.be \
    --cc=kunit-dev@googlegroups.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=skhan@linuxfoundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).