linux-kselftest.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v12 0/7] gpio-sim: configfs-based GPIO simulator
@ 2021-12-03 13:29 Bartosz Golaszewski
  2021-12-03 13:29 ` [PATCH v12 1/7] gpiolib: provide gpiod_remove_hogs() Bartosz Golaszewski
                   ` (7 more replies)
  0 siblings, 8 replies; 28+ messages in thread
From: Bartosz Golaszewski @ 2021-12-03 13:29 UTC (permalink / raw)
  To: Kent Gibson, Linus Walleij, Andy Shevchenko, Shuah Khan,
	Geert Uytterhoeven, Viresh Kumar
  Cc: linux-gpio, linux-kernel, linux-kselftest, Bartosz Golaszewski

Another iteration of gpio-sim patches. This time the changes are quite
small. I removed the ifdefs from gpiolib.c as requested by Andy. In this
version gpiolib-of will also prefer fwnodes over of_nodes and - if set -
will convert them to of_nodes before proceeding.

Tested both with configfs as well as device-tree.

v1 -> v2:
- add selftests for gpio-sim
- add helper programs for selftests
- update the configfs rename callback to work with the new API introduced in
  v5.11
- fix a missing quote in the documentation
- use !! whenever using bits operation that are required to return 0 or 1
- use provided bitmap API instead of reimplementing copy or fill operations
- fix a deadlock in gpio_sim_direction_output()
- add new read-only configfs attributes for mapping of configfs items to GPIO
  device names
- and address other minor issues pointed out in reviews of v1

v2 -> v3:
- use devm_bitmap_alloc() instead of the zalloc variant if we're initializing
  the bitmap with 1s
- drop the patch exporting device_is_bound()
- don't return -ENODEV from dev_nam and chip_name configfs attributes, return
  a string indicating that the device is not available yet ('n/a')
- fix indentation where it makes sense
- don't protect IDA functions which use their own locking and where it's not
  needed
- use kmemdup() instead of kzalloc() + memcpy()
- collected review tags
- minor coding style fixes

v3 -> v4:
- return 'none' instead of 'n/a' from dev_name and chip_name before the device
  is registered
- use sysfs_emit() instead of s*printf()
- drop GPIO_SIM_MAX_PROP as it's only used in an array's definition where it's
  fine to hardcode the value

v4 -> v5:
- drop lib patches that are already upstream
- use BIT() instead of (1UL << bit) for flags
- fix refcounting for the configfs_dirent in rename()
- drop d_move() from the rename() callback
- free memory allocated for the live and pending groups in configfs_d_iput()
  and not in detach_groups()
- make sure that if a group of some name is in the live directory, a new group
  with the same name cannot be created in the pending directory

v5 -> v6:
- go back to using (1UL << bit) instead of BIT()
- if the live group dentry doesn't exist for whatever reason at the time when
  mkdir() in the pending group is called (would be a BUG()), return -ENOENT
  instead of -EEXIST which should only be returned if given subsystem already
  exists in either live or pending group

v6 -> v7:
- as detailed by Andy in commit 6fda593f3082 ("gpio: mockup: Convert to use
  software nodes") removing device properties after the platform device is
  removed but before the GPIO device gets dropped can lead to a use-after-free
  bug - use software nodes to manually control the freeing of the properties

v7 -> v8:
- fixed some minor coding style issues as pointed out by Andy

v8 -> v9:
- dropped the patches implementing committable-items and reworked the
  driver to not use them
- reworked the gpio-line-names property and configuring specific lines
  in general
- many smaller tweaks here and there

v9 -> v10:
- make writing to 'live' wait for the probe to finish and report an
  error to user-space if it failed
- add the ability to hog lines from the kernel-space
- rework locking (drop separate locks for line context objects)
- rework the sysfs interface (create a separate group for each line with
  a constant number of attributes instead of going the other way around)

v10 -> v11:
- rework the configfs structure to represent a deeper hierarchy that
  gpiolib supports, namely: multiple banks per platform device

v11 -> v12:
- simplify patch 2/7 by removing any mentions of OF from gpiolib.c
- improve the documentation by adding rest markups
- add a device-tree sample to the docs
- drop some trailing whitespaces from the driver
- make gpio_sim_make_bank_swnode() static
- fix coding style in patch 6/7
- add patch 3/7 that makes the OF part of gpiolib prefer to use gpio_chip's fwnode (if set) over of_node

Bartosz Golaszewski (7):
  gpiolib: provide gpiod_remove_hogs()
  gpiolib: allow to specify the firmware node in struct gpio_chip
  gpiolib: of: make fwnode take precedence in struct gpio_chip
  gpio: sim: new testing module
  selftests: gpio: provide a helper for reading chip info
  selftests: gpio: add a helper for reading GPIO line names
  selftests: gpio: add test cases for gpio-sim

 Documentation/admin-guide/gpio/gpio-sim.rst   |  134 ++
 drivers/gpio/Kconfig                          |    8 +
 drivers/gpio/Makefile                         |    1 +
 drivers/gpio/gpio-sim.c                       | 1594 +++++++++++++++++
 drivers/gpio/gpiolib-of.c                     |    3 +
 drivers/gpio/gpiolib.c                        |   18 +-
 include/linux/gpio/driver.h                   |    2 +
 include/linux/gpio/machine.h                  |    2 +
 tools/testing/selftests/gpio/.gitignore       |    2 +
 tools/testing/selftests/gpio/Makefile         |    4 +-
 tools/testing/selftests/gpio/config           |    1 +
 tools/testing/selftests/gpio/gpio-chip-info.c |   57 +
 tools/testing/selftests/gpio/gpio-line-name.c |   55 +
 tools/testing/selftests/gpio/gpio-sim.sh      |  396 ++++
 14 files changed, 2274 insertions(+), 3 deletions(-)
 create mode 100644 Documentation/admin-guide/gpio/gpio-sim.rst
 create mode 100644 drivers/gpio/gpio-sim.c
 create mode 100644 tools/testing/selftests/gpio/gpio-chip-info.c
 create mode 100644 tools/testing/selftests/gpio/gpio-line-name.c
 create mode 100755 tools/testing/selftests/gpio/gpio-sim.sh

-- 
2.25.1


^ permalink raw reply	[flat|nested] 28+ messages in thread

end of thread, other threads:[~2021-12-06 17:05 UTC | newest]

Thread overview: 28+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-03 13:29 [PATCH v12 0/7] gpio-sim: configfs-based GPIO simulator Bartosz Golaszewski
2021-12-03 13:29 ` [PATCH v12 1/7] gpiolib: provide gpiod_remove_hogs() Bartosz Golaszewski
2021-12-03 13:29 ` [PATCH v12 2/7] gpiolib: allow to specify the firmware node in struct gpio_chip Bartosz Golaszewski
2021-12-03 13:29 ` [PATCH v12 3/7] gpiolib: of: make fwnode take precedence " Bartosz Golaszewski
2021-12-03 18:51   ` Andy Shevchenko
2021-12-03 18:56     ` Andy Shevchenko
2021-12-03 19:02       ` Andy Shevchenko
2021-12-03 19:28         ` Bartosz Golaszewski
2021-12-03 20:09           ` Andy Shevchenko
2021-12-06  8:41             ` Bartosz Golaszewski
2021-12-06 13:33               ` Andy Shevchenko
2021-12-06 13:40                 ` Bartosz Golaszewski
2021-12-06 13:48                   ` Andy Shevchenko
2021-12-06 13:52                     ` Andy Shevchenko
2021-12-06 13:54   ` Andy Shevchenko
2021-12-06 14:03     ` Bartosz Golaszewski
2021-12-06 14:36       ` Andy Shevchenko
2021-12-06 14:08     ` Andy Shevchenko
2021-12-03 13:30 ` [PATCH v12 4/7] gpio: sim: new testing module Bartosz Golaszewski
2021-12-03 20:07   ` Andy Shevchenko
2021-12-06  9:48     ` Bartosz Golaszewski
2021-12-06 13:32       ` Andy Shevchenko
2021-12-06 15:38         ` Bartosz Golaszewski
2021-12-06 17:00           ` Andy Shevchenko
2021-12-03 13:30 ` [PATCH v12 5/7] selftests: gpio: provide a helper for reading chip info Bartosz Golaszewski
2021-12-03 13:30 ` [PATCH v12 6/7] selftests: gpio: add a helper for reading GPIO line names Bartosz Golaszewski
2021-12-03 13:30 ` [PATCH v12 7/7] selftests: gpio: add test cases for gpio-sim Bartosz Golaszewski
2021-12-03 20:10 ` [PATCH v12 0/7] gpio-sim: configfs-based GPIO simulator Andy Shevchenko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).