linux-mips.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/3] Make PMD_ORDER generically available
@ 2021-07-15 13:46 Matthew Wilcox (Oracle)
  2021-07-15 13:46 ` [PATCH 1/3] arm: Rename PMD_ORDER to PMD_TABLE_ORDER Matthew Wilcox (Oracle)
                   ` (3 more replies)
  0 siblings, 4 replies; 10+ messages in thread
From: Matthew Wilcox (Oracle) @ 2021-07-15 13:46 UTC (permalink / raw)
  To: linux-arch, linux-parisc, linux-mips, linux-arm-kernel
  Cc: Matthew Wilcox (Oracle), linux-kernel

These three architectures each define PMD_ORDER to mean "the order of
an allocation for a PMD table", but logically PMD_ORDER should be the
order of a PMD allocation, ie (PMD_SHIFT - PAGE_SHIFT) as DAX defines it.

Could each architecture maintainer please apply the appropriate patch
to their respective trees?

Matthew Wilcox (Oracle) (3):
  arm: Rename PMD_ORDER to PMD_TABLE_ORDER
  mips: Rename PMD_ORDER to PMD_TABLE_ORDER
  parisc: Rename PMD_ORDER to PMD_TABLE_ORDER

 arch/arm/kernel/head.S             | 34 +++++++++++++++---------------
 arch/mips/include/asm/pgalloc.h    |  2 +-
 arch/mips/include/asm/pgtable-32.h |  2 +-
 arch/mips/include/asm/pgtable-64.h | 18 ++++++++--------
 arch/mips/kernel/asm-offsets.c     |  2 +-
 arch/parisc/include/asm/pgalloc.h  |  6 +++---
 arch/parisc/include/asm/pgtable.h  |  4 ++--
 arch/parisc/mm/init.c              |  4 ++--
 8 files changed, 36 insertions(+), 36 deletions(-)

-- 
2.30.2


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2021-07-15 19:53 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-15 13:46 [PATCH 0/3] Make PMD_ORDER generically available Matthew Wilcox (Oracle)
2021-07-15 13:46 ` [PATCH 1/3] arm: Rename PMD_ORDER to PMD_TABLE_ORDER Matthew Wilcox (Oracle)
2021-07-15 16:47   ` Russell King (Oracle)
2021-07-15 18:10     ` Matthew Wilcox
2021-07-15 18:37       ` Russell King (Oracle)
2021-07-15 19:16         ` Matthew Wilcox
2021-07-15 13:46 ` [PATCH 2/3] mips: " Matthew Wilcox (Oracle)
2021-07-15 13:46 ` [PATCH 3/3] parisc: " Matthew Wilcox (Oracle)
2021-07-15 16:28 ` [PATCH 0/3] Make PMD_ORDER generically available Helge Deller
2021-07-15 16:38   ` Matthew Wilcox

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).