linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic
@ 2020-12-20  5:03 Nicholas Piggin
  2020-12-20  5:03 ` [PATCH 2/3] mm: add page_cpupid_reset_last atomic variant Nicholas Piggin
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Nicholas Piggin @ 2020-12-20  5:03 UTC (permalink / raw)
  To: linux-mm; +Cc: Nicholas Piggin, Peter Zijlstra

Add a __ prefix to indicate that it should be used in non-atomic
situations (where the page is not subject to concurrent flags
access, following the pattern of the other page flags modifications).

This prepares for an atomic version.

Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
---
 include/linux/mm.h | 6 +++---
 mm/page_alloc.c    | 4 ++--
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/include/linux/mm.h b/include/linux/mm.h
index 855161080f18..5b3fc2c8fd8b 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1358,7 +1358,7 @@ static inline int page_cpupid_last(struct page *page)
 {
 	return page->_last_cpupid;
 }
-static inline void page_cpupid_reset_last(struct page *page)
+static inline void __page_cpupid_reset_last(struct page *page)
 {
 	page->_last_cpupid = -1 & LAST_CPUPID_MASK;
 }
@@ -1370,7 +1370,7 @@ static inline int page_cpupid_last(struct page *page)
 
 extern int page_cpupid_xchg_last(struct page *page, int cpupid);
 
-static inline void page_cpupid_reset_last(struct page *page)
+static inline void __page_cpupid_reset_last(struct page *page)
 {
 	page->flags |= LAST_CPUPID_MASK << LAST_CPUPID_PGSHIFT;
 }
@@ -1411,7 +1411,7 @@ static inline bool cpupid_pid_unset(int cpupid)
 	return true;
 }
 
-static inline void page_cpupid_reset_last(struct page *page)
+static inline void __page_cpupid_reset_last(struct page *page)
 {
 }
 
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index 3beeb8d722f3..ead28946f3ce 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -1260,7 +1260,7 @@ static __always_inline bool free_pages_prepare(struct page *page,
 	if (bad)
 		return false;
 
-	page_cpupid_reset_last(page);
+	__page_cpupid_reset_last(page);
 	page->flags &= ~PAGE_FLAGS_CHECK_AT_PREP;
 	reset_page_owner(page, order);
 
@@ -1453,7 +1453,7 @@ static void __meminit __init_single_page(struct page *page, unsigned long pfn,
 	set_page_links(page, zone, nid, pfn);
 	init_page_count(page);
 	page_mapcount_reset(page);
-	page_cpupid_reset_last(page);
+	__page_cpupid_reset_last(page);
 	page_kasan_tag_reset(page);
 
 	INIT_LIST_HEAD(&page->lru);
-- 
2.23.0



^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 2/3] mm: add page_cpupid_reset_last atomic variant
  2020-12-20  5:03 [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic Nicholas Piggin
@ 2020-12-20  5:03 ` Nicholas Piggin
  2020-12-20  5:03 ` [PATCH 3/3] mm: skip page_cpupid_reset_last atomic update if the value is already reset Nicholas Piggin
  2020-12-21  1:53 ` [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic huang ying
  2 siblings, 0 replies; 4+ messages in thread
From: Nicholas Piggin @ 2020-12-20  5:03 UTC (permalink / raw)
  To: linux-mm; +Cc: Nicholas Piggin, Peter Zijlstra

This can be used when there is concurrency on the struct page. If cpupid
is not in page flags, it can use a store.

Use this to replace the open-coded reset in wp_page_reuse.

Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
---
 include/linux/mm.h | 15 +++++++++++++++
 mm/memory.c        |  2 +-
 2 files changed, 16 insertions(+), 1 deletion(-)

diff --git a/include/linux/mm.h b/include/linux/mm.h
index 5b3fc2c8fd8b..6ece500464e0 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1362,6 +1362,11 @@ static inline void __page_cpupid_reset_last(struct page *page)
 {
 	page->_last_cpupid = -1 & LAST_CPUPID_MASK;
 }
+
+static inline void page_cpupid_reset_last(struct page *page)
+{
+	WRITE_ONCE(page->_last_cpupid, -1 & LAST_CPUPID_MASK);
+}
 #else
 static inline int page_cpupid_last(struct page *page)
 {
@@ -1374,6 +1379,12 @@ static inline void __page_cpupid_reset_last(struct page *page)
 {
 	page->flags |= LAST_CPUPID_MASK << LAST_CPUPID_PGSHIFT;
 }
+
+static inline void page_cpupid_reset_last(struct page *page)
+{
+	page_cpupid_xchg_last(page, (1 << LAST_CPUPID_SHIFT) - 1);
+}
+
 #endif /* LAST_CPUPID_NOT_IN_PAGE_FLAGS */
 #else /* !CONFIG_NUMA_BALANCING */
 static inline int page_cpupid_xchg_last(struct page *page, int cpupid)
@@ -1415,6 +1426,10 @@ static inline void __page_cpupid_reset_last(struct page *page)
 {
 }
 
+static inline void page_cpupid_reset_last(struct page *page)
+{
+}
+
 static inline bool cpupid_match_pid(struct task_struct *task, int cpupid)
 {
 	return false;
diff --git a/mm/memory.c b/mm/memory.c
index 7d608765932b..990e5d704c08 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -2798,7 +2798,7 @@ static inline void wp_page_reuse(struct vm_fault *vmf)
 	 * unrelated process.
 	 */
 	if (page)
-		page_cpupid_xchg_last(page, (1 << LAST_CPUPID_SHIFT) - 1);
+		page_cpupid_reset_last(page);
 
 	flush_cache_page(vma, vmf->address, pte_pfn(vmf->orig_pte));
 	entry = pte_mkyoung(vmf->orig_pte);
-- 
2.23.0



^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 3/3] mm: skip page_cpupid_reset_last atomic update if the value is already reset
  2020-12-20  5:03 [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic Nicholas Piggin
  2020-12-20  5:03 ` [PATCH 2/3] mm: add page_cpupid_reset_last atomic variant Nicholas Piggin
@ 2020-12-20  5:03 ` Nicholas Piggin
  2020-12-21  1:53 ` [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic huang ying
  2 siblings, 0 replies; 4+ messages in thread
From: Nicholas Piggin @ 2020-12-20  5:03 UTC (permalink / raw)
  To: linux-mm; +Cc: Nicholas Piggin, Peter Zijlstra

Improves performance of a PROT_READ -> PROT_READ|PROT_WRITE -> store
microbenchmark (which goes via the wp_page_reuse fault path) by about
10% on a POWER9.

Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
---
 include/linux/mm.h | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/include/linux/mm.h b/include/linux/mm.h
index 6ece500464e0..c0a9e8de0738 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1382,6 +1382,9 @@ static inline void __page_cpupid_reset_last(struct page *page)
 
 static inline void page_cpupid_reset_last(struct page *page)
 {
+	if (page_cpupid_last(page) == (-1 & LAST_CPUPID_MASK))
+		return;
+
 	page_cpupid_xchg_last(page, (1 << LAST_CPUPID_SHIFT) - 1);
 }
 
-- 
2.23.0



^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic
  2020-12-20  5:03 [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic Nicholas Piggin
  2020-12-20  5:03 ` [PATCH 2/3] mm: add page_cpupid_reset_last atomic variant Nicholas Piggin
  2020-12-20  5:03 ` [PATCH 3/3] mm: skip page_cpupid_reset_last atomic update if the value is already reset Nicholas Piggin
@ 2020-12-21  1:53 ` huang ying
  2 siblings, 0 replies; 4+ messages in thread
From: huang ying @ 2020-12-21  1:53 UTC (permalink / raw)
  To: Nicholas Piggin; +Cc: linux-mm, Peter Zijlstra, Huang Ying

Hi, Nicholas,

On Sun, Dec 20, 2020 at 1:03 PM Nicholas Piggin <npiggin@gmail.com> wrote:
>
> Add a __ prefix to indicate that it should be used in non-atomic
> situations (where the page is not subject to concurrent flags
> access, following the pattern of the other page flags modifications).
>
> This prepares for an atomic version.
>
> Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
> ---
>  include/linux/mm.h | 6 +++---
>  mm/page_alloc.c    | 4 ++--
>  2 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index 855161080f18..5b3fc2c8fd8b 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -1358,7 +1358,7 @@ static inline int page_cpupid_last(struct page *page)
>  {
>         return page->_last_cpupid;
>  }
> -static inline void page_cpupid_reset_last(struct page *page)
> +static inline void __page_cpupid_reset_last(struct page *page)
>  {
>         page->_last_cpupid = -1 & LAST_CPUPID_MASK;

How about replace all these

  -1 & LAST_CPUPID_MASK

and

  (1 << LAST_CPUPID_SHIFT) - 1)

with

  LAST_CPUPID_MASK

I think that can improve the code readability a little.

Best Regards,
Huang, Ying


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-12-21  1:53 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-20  5:03 [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic Nicholas Piggin
2020-12-20  5:03 ` [PATCH 2/3] mm: add page_cpupid_reset_last atomic variant Nicholas Piggin
2020-12-20  5:03 ` [PATCH 3/3] mm: skip page_cpupid_reset_last atomic update if the value is already reset Nicholas Piggin
2020-12-21  1:53 ` [PATCH 1/3] mm: prefix page_cpupid_reset_last as non-atomic huang ying

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).