linux-parisc.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-04-02 14:00:21 to 2020-05-11 05:27:24 UTC [more...]

clean up and streamline probe_kernel_* and friends
 2020-05-11  5:27 UTC  (25+ messages)
` [PATCH 01/15] maccess: unexport probe_kernel_write and probe_user_write
` [PATCH 02/15] maccess: remove various unused weak aliases
` [PATCH 03/15] maccess: remove duplicate kerneldoc commens
` [PATCH 04/15] maccess: clarify kerneldoc comments
` [PATCH 05/15] maccess: update the top of file comment
` [PATCH 06/15] maccess: rename strncpy_from_unsafe_user to strncpy_from_user_unsafe
` [PATCH 07/15] maccess: rename strncpy_from_unsafe_strict to strncpy_from_kernel_unsafe
` [PATCH 08/15] maccess: rename strnlen_unsafe_user to strnlen_user_unsafe
` [PATCH 09/15] maccess: remove probe_read_common and probe_write_common
` [PATCH 10/15] maccess: unify the probe kernel arch hooks
` [PATCH 11/15] maccess: remove strncpy_from_unsafe
` [PATCH 12/15] maccess: always use strict semantics for probe_kernel_read
` [PATCH 13/15] maccess: move user access routines together
` [PATCH 14/15] maccess: allow architectures to provide kernel probing directly
` [PATCH 15/15] x86: use non-set_fs based maccess routines

[PATCH V3 0/3] mm/hugetlb: Add some new generic fallbacks
 2020-05-11  3:14 UTC  (5+ messages)
` [PATCH V3 2/3] mm/hugetlb: Define a generic fallback for is_hugepage_only_range()
` [PATCH V3 3/3] mm/hugetlb: Define a generic fallback for arch_clear_hugepage_flags()

linux-next: manual merge of the vfs tree with the parisc-hd tree
 2020-05-11  1:55 UTC  (2+ messages)

linux-next: manual merge of the parisc-hd tree with the kbuild tree
 2020-05-10 23:34 UTC 

[PATCH] parisc: suppress error messages for 'make clean'
 2020-05-10 20:28 UTC  (7+ messages)

[PATCH] parisc: use -fno-strict-aliasing for decompressor
 2020-05-08 21:43 UTC  (3+ messages)

[PATCH] parisc: add sysctl file interface panic_on_stackoverflow
 2020-05-08 21:37 UTC  (3+ messages)

[PATCH V3 00/15] Remove duplicated kmap code
 2020-05-07 22:52 UTC  (21+ messages)
` [PATCH V3 01/15] arch/kmap: Remove BUG_ON()
` [PATCH V3 02/15] arch/xtensa: Move kmap build bug out of the way
` [PATCH V3 03/15] arch/kmap: Remove redundant arch specific kmaps
` [PATCH V3 04/15] arch/kunmap: Remove duplicate kunmap implementations
` [PATCH V3 05/15] {x86,powerpc,microblaze}/kmap: Move preempt disable
` [PATCH V3 06/15] arch/kmap_atomic: Consolidate duplicate code
` [PATCH V3 07/15] arch/kunmap_atomic: "
` [PATCH V3 08/15] arch/kmap: Ensure kmap_prot visibility
` [PATCH V3 09/15] arch/kmap: Don't hard code kmap_prot values
` [PATCH V3 10/15] arch/kmap: Define kmap_atomic_prot() for all arch's
` [PATCH V3 11/15] drm: Remove drm specific kmap_atomic code
` [PATCH V3 12/15] kmap: Remove kmap_atomic_to_page()
` [PATCH V3 13/15] parisc/kmap: Remove duplicate kmap code
` [PATCH V3 14/15] sparc: Remove unnecessary includes
` [PATCH V3 15/15] kmap: Consolidate kmap_prot definitions
  ` [PATCH V3.1] "

[PATCH net-next] net: tulip: de4x5: make PCI_signature() return void
 2020-05-07 20:04 UTC  (2+ messages)

[PATCH V2 00/11] Subject: Remove duplicated kmap code
 2020-05-07  4:56 UTC  (28+ messages)
` [PATCH V2 01/11] arch/kmap: Remove BUG_ON()
` [PATCH V2 02/11] arch/xtensa: Move kmap build bug out of the way
` [PATCH V2 03/11] arch/kmap: Remove redundant arch specific kmaps
` [PATCH V2 04/11] arch/kunmap: Remove duplicate kunmap implementations
` [PATCH V2 05/11] {x86,powerpc,microblaze}/kmap: Move preempt disable
` [PATCH V2 06/11] arch/kmap_atomic: Consolidate duplicate code
` [PATCH V2 07/11] arch/kunmap_atomic: "
` [PATCH V2 08/11] arch/kmap: Ensure kmap_prot visibility
` [PATCH V2 09/11] arch/kmap: Don't hard code kmap_prot values
` [PATCH V2 10/11] arch/kmap: Define kmap_atomic_prot() for all arch's
` [PATCH V2 11/11] drm: Remove drm specific kmap_atomic code

is there a memleak in function pdcs_register_pathentries
 2020-05-06 14:25 UTC  (2+ messages)

[PATCH V2 0/3] mm/hugetlb: Add some new generic fallbacks
 2020-05-06  6:12 UTC  (3+ messages)
` [PATCH V2 2/3] mm/hugetlb: Define a generic fallback for is_hugepage_only_range()
` [PATCH V2 3/3] mm/hugetlb: Define a generic fallback for arch_clear_hugepage_flags()

[PATCH 0/3] mm/hugetlb: Add some new arch enabling macros
 2020-05-05 20:12 UTC  (8+ messages)
` [PATCH 2/3] mm/hugetlb: Introduce HAVE_ARCH_IS_HUGEPAGE_ONLY_RANGE
` [PATCH 3/3] mm/hugetlb: Introduce HAVE_ARCH_CLEAR_HUGEPAGE_FLAGS

Implement close-on-fork
 2020-05-04 13:46 UTC  (25+ messages)
` [PATCH 1/4] fs: "
` [PATCH 2/4] fs: Add O_CLOFORK flag for open(2) and dup3(2)
` [PATCH 3/4] fs: Add F_DUPFD_CLOFORK to fcntl(2)
` [PATCH 4/4] net: Add SOCK_CLOFORK

[PATCH 0/2] kmap cleanup 2
 2020-05-04  5:24 UTC  (3+ messages)
` [PATCH 1/2] kmap: Remove kmap_atomic_to_page()
` [PATCH 2/2] parisc/kmap: Remove duplicate kmap code

[PATCH V1 00/10] Remove duplicated kmap code
 2020-05-03  3:11 UTC  (31+ messages)
` [PATCH V1 01/10] arch/kmap: Remove BUG_ON()
` [PATCH V1 02/10] arch/xtensa: Move kmap build bug out of the way
` [PATCH V1 03/10] arch/kmap: Remove redundant arch specific kmaps
` [PATCH V1 04/10] arch/kunmap: Remove duplicate kunmap implementations
` [PATCH V1 05/10] arch/kmap_atomic: Consolidate duplicate code
` [PATCH V1 06/10] arch/kunmap_atomic: "
` [PATCH V1 07/10] arch/kmap: Ensure kmap_prot visibility
  ` sparc-related comment, to "
` [PATCH V1 08/10] arch/kmap: Don't hard code kmap_prot values
` [PATCH V1 09/10] arch/kmap: Define kmap_atomic_prot() for all arch's
` [PATCH V1 10/10] drm: Remove drm specific kmap_atomic code

[PATCH 00/37]net: manually convert files to ReST format - part 3 (final)
 2020-05-01 19:33 UTC  (4+ messages)
` [PATCH 19/37] docs: networking: device drivers: convert dec/de4x5.txt to ReST
` [PATCH 20/37] docs: networking: device drivers: convert dec/dmfe.txt "

[PATCH 0/5] Remove duplicated kmap code
 2020-04-27  6:25 UTC  (11+ messages)
` [PATCH 1/5] arch/kmap: Remove BUG_ON()
` [PATCH 2/5] arch/kmap: Remove redundant arch specific kmaps
` [PATCH 3/5] arch/kunmap: Remove duplicate kunmap implementations
` [PATCH 4/5] arch/kmap_atomic: Consolidate duplicate code
` [PATCH 5/5] arch/kunmap_atomic: "

STI init_graph failed on J6700
 2020-04-23 21:03 UTC 

[PATCH v2] sched/core: fix illegal RCU from offline CPUs
 2020-04-21 13:56 UTC  (8+ messages)

[PATCHv3 25/50] parisc: Add show_stack_loglvl()
 2020-04-18 20:54 UTC  (2+ messages)

[PATCH] net: tulip: make early_486_chipsets static
 2020-04-15 23:22 UTC  (2+ messages)

[GIT PULL] parisc architecture fixes for kernel v5.7
 2020-04-07 19:55 UTC  (2+ messages)

[PATCH] parisc: Rework arch_rw locking functions
 2020-04-05 20:38 UTC 

[PATCH] parisc: Improve interrupt handling in arch_spin_lock_flags()
 2020-04-05 20:37 UTC 

[PATCH 00/18] genirq: Remove setup_irq()
 2020-04-02 15:03 UTC  (5+ messages)
` [PATCH 0/6] Kill setup_irq()


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).