linux-pci.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 00/13] Refactor pci_is_brdige() to simplify code
@ 2014-05-04  4:23 Yijing Wang
  2014-05-04  4:23 ` [PATCH v2 01/13] PCI: rename pci_is_bridge() to pci_has_subordinate() Yijing Wang
                   ` (13 more replies)
  0 siblings, 14 replies; 15+ messages in thread
From: Yijing Wang @ 2014-05-04  4:23 UTC (permalink / raw)
  To: Bjorn Helgaas
  Cc: Benjamin Herrenschmidt, linuxppc-dev, linux-pci, Tony Luck,
	linux-ia64, David S. Miller, sparclinux, Thomas Gleixner, x86,
	Yijing Wang

v1->v2: Add comments for new pci_is_bridge().

This patchset rename the current pci_is_bridge() to pci_has_subordinate(), 
and introduce a new pci_is_bridge() which determine pci bridge by check
dev->hdr_type. The new one is more accurate. PCI Spec define the pci
device is a bridge by the dev->hdr_type = 0x01 || 0x02.

There is no guarantee that a PCI bridge must attached a subordinate bus.
When PCI bridge is created but before the scan child bus, it has no 
subordinate bus. Also users can remove the pci bus using
interface pci_remove_bus() in remove.c. 

So use new pci_is_bridge() check if the PCI device is bridge is better
choice. If user want check PCI bridge whether has a subordinate bus,
pci_has_subordinate() is a candidate.


Yijing Wang (13):
  PCI: rename pci_is_bridge() to pci_has_subordinate()
  PCI: Introduce new pci_is_bridge() helper function
  PCI: Use new pci_is_bridge() to simplify code
  x86/PCI: Use new pci_is_bridge() to simplify code
  IA64/PCI: Use new pci_is_bridge() to simplify code
  powerpc/PCI: Use new pci_is_bridge() to simplify code
  sparc/PCI: Use new pci_is_bridge() to simplify code
  PCI, rpaphp: Use new pci_is_bridge() to simplify code
  PCI, shpchp: Use new pci_is_bridge() to simplify code
  PCI, cpcihp: Use new pci_is_bridge() to simplify code
  PCI, acpiphp: Use new pci_is_bridge() to simplify code
  PCI, pcmcia: Use new pci_is_bridge() to simplify code
  PCI, pciehp: Use new pci_is_bridge() to simplify code

 arch/ia64/pci/fixup.c                  |    4 +---
 arch/powerpc/kernel/pci-hotplug.c      |    3 +--
 arch/powerpc/kernel/pci_of_scan.c      |    3 +--
 arch/sparc/kernel/pci.c                |    3 +--
 arch/x86/pci/fixup.c                   |    4 +---
 drivers/pci/hotplug/acpiphp_glue.c     |    3 +--
 drivers/pci/hotplug/cpci_hotplug_pci.c |    3 +--
 drivers/pci/hotplug/pciehp_pci.c       |    3 +--
 drivers/pci/hotplug/rpadlpar_core.c    |    3 +--
 drivers/pci/hotplug/shpchp_pci.c       |    3 +--
 drivers/pci/pci-acpi.c                 |    8 +-------
 drivers/pci/pci-driver.c               |    8 ++++----
 drivers/pci/pci.h                      |    2 +-
 drivers/pci/probe.c                    |    3 +--
 drivers/pci/setup-bus.c                |    4 +---
 drivers/pcmcia/cardbus.c               |    3 +--
 include/linux/pci.h                    |   13 +++++++++++++
 17 files changed, 32 insertions(+), 41 deletions(-)



^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2014-05-27 21:05 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-05-04  4:23 [PATCH v2 00/13] Refactor pci_is_brdige() to simplify code Yijing Wang
2014-05-04  4:23 ` [PATCH v2 01/13] PCI: rename pci_is_bridge() to pci_has_subordinate() Yijing Wang
2014-05-04  4:23 ` [PATCH v2 02/13] PCI: Introduce new pci_is_bridge() helper function Yijing Wang
2014-05-04  4:23 ` [PATCH v2 03/13] PCI: Use new pci_is_bridge() to simplify code Yijing Wang
2014-05-04  4:23 ` [PATCH v2 04/13] x86/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 05/13] IA64/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 06/13] powerpc/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 07/13] sparc/PCI: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 08/13] PCI, rpaphp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 09/13] PCI, shpchp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 10/13] PCI, cpcihp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 11/13] PCI, acpiphp: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 12/13] PCI, pcmcia: " Yijing Wang
2014-05-04  4:23 ` [PATCH v2 13/13] PCI, pciehp: " Yijing Wang
2014-05-27 21:05 ` [PATCH v2 00/13] Refactor pci_is_brdige() " Bjorn Helgaas

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).