linux-pm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: yuankuiz@codeaurora.org
To: Thomas Gleixner <tglx@linutronix.de>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
	Linux PM <linux-pm@vger.kernel.org>,
	"Rafael J. Wysocki" <rjw@rjwysocki.net>,
	Frederic Weisbecker <fweisbec@gmail.com>,
	Peter Zijlstra <peterz@infradead.org>,
	Ingo Molnar <mingo@kernel.org>, Len Brown <len.brown@intel.com>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	linux-pm-owner@vger.kernel.org
Subject: Re: [PATCH] time: tick-sched: use bool for tick_stopped
Date: Tue, 10 Apr 2018 22:49:16 +0800	[thread overview]
Message-ID: <c3e05a4aad4895046401519dc83fa623@codeaurora.org> (raw)
In-Reply-To: <2f7755fae34bb65ef0a4b5a11c67f431@codeaurora.org>

Typo...

On 2018-04-10 10:08 PM, yuankuiz@codeaurora.org wrote:
> On 2018-04-10 07:06 PM, Thomas Gleixner wrote:
>> On Tue, 10 Apr 2018, yuankuiz@codeaurora.org wrote:
>>> On 2018-04-10 05:10 PM, Thomas Gleixner wrote:
>>> > On Tue, 10 Apr 2018, yuankuiz@codeaurora.org wrote:
>>> > > On 2018-04-10 04:00 PM, Rafael J. Wysocki wrote:
>>> > > > On Tue, Apr 10, 2018 at 9:33 AM,  <yuankuiz@codeaurora.org> wrote:
>>> > > > > From: John Zhao <yuankuiz@codeaurora.org>
>>> > > > >
>>> > > > > Variable tick_stopped returned by tick_nohz_tick_stopped
>>> > > > > can have only true / false values. Since the return type
>>> > > > > of the tick_nohz_tick_stopped is also bool, variable
>>> > > > > tick_stopped nice to have data type as bool in place of unsigned int.
>>> > > > > Moreover, the executed instructions cost could be minimal
>>> > > > > without potiential data type conversion.
>>> > > > >
>>> > > > > Signed-off-by: John Zhao <yuankuiz@codeaurora.org>
>>> > > > > ---
>>> > > > >  kernel/time/tick-sched.h | 2 +-
>>> > > > >  1 file changed, 1 insertion(+), 1 deletion(-)
>>> > > > >
>>> > > > > diff --git a/kernel/time/tick-sched.h b/kernel/time/tick-sched.h
>>> > > > > index 6de959a..4d34309 100644
>>> > > > > --- a/kernel/time/tick-sched.h
>>> > > > > +++ b/kernel/time/tick-sched.h
>>> > > > > @@ -48,8 +48,8 @@ struct tick_sched {
>>> > > > >         unsigned long                   check_clocks;
>>> > > > >         enum tick_nohz_mode             nohz_mode;
>>> > > > >
>>> > > > > +       bool                            tick_stopped    : 1;
>>> > > > >         unsigned int                    inidle          : 1;
>>> > > > > -       unsigned int                    tick_stopped    : 1;
>>> > > > >         unsigned int                    idle_active     : 1;
>>> > > > >         unsigned int                    do_timer_last   : 1;
>>> > > > >         unsigned int                    got_idle_tick   : 1;
>>> > > >
>>> > > > I don't think this is a good idea at all.
>>> > > >
>>> > > > Please see https://lkml.org/lkml/2017/11/21/384 for example.
>>> > > [ZJ] Thanks for this sharing. Looks like, this patch fall into the case of
>>> > > "Maybe".
>>> >
>>> > This patch falls into the case 'pointless' because it adds extra storage
>>> [ZJ] 1 bit vs 1 bit. no more.
>> 
>> Groan. No. Care to look at the data structure? You create a new 
>> storage,
> [ZJ] Say, {unsigned int, unsigned int, unsigned int, unsigned int,
> unsigned int} becomes
>           {bool        , unsigned int, unsigned int, unsigned int, 
> unsigned int}
> As specified by the rule No.10 at the section 6.7.2.1 of C99 TC2 as:
> "If enough space remains, a bit-field that immediately follows another
> bit-field in a
> structure shall be packed into adjacent bits of the same unit." What
> is the new storage so far?
> 
>> which is incidentally merged into the other bitfield by the compiler 
>> at a
>> different bit position, but there is no guarantee that a compiler does
>> that. It's free to use distinct storage for that bool based bit.
> [ZJ] Per the rule No.10 at section 6.7.2.1 of C99 TC2 as:
> " If insufficient space remains, whether  a  bit-field  that  does
> not  fit  is  put  into
> the  next  unit  or overlaps  adjacent  units  is 
> implementation-defined."
> So, implementation is never mind which type will be stored if any.
> 
>> >> > for no benefit at all.
>>> [ZJ] tick_stopped is returned by the tick_nohz_tick_stopped() which 
>>> is bool.
>>> The benefit is no any potiential type conversion could be minded.
>> 
>> A bit stays a bit. 'bool foo : 1;' or 'unsigned int foo : 1' has to be
>> evaluated as a bit. So there is a type conversion from BIT to bool 
>> required
>> because BIT != bool.
> [ZJ] Per the rule No.9 at section 6.7.2.1 of C99 TC2 as:
> "If  the  value  0  or  1  is  stored  into  a  nonzero-width
> bit-field  of  types
> _Bool, the value of the bit-field shall compare equal to the value 
> stored."
> Obviously, it is nothing related to type conversion actually.
>> 
>> By chance the evaluation can be done by evaluating the byte in which 
>> the
>> bit is placed just because the compiler knows that the remaining bits 
>> are
>> not used. There is no guarantee that this is done, it happens to be 
>> true
>> for a particular compiler.
> [ZJ] Actually, such as GCC owe that kind of guarantee to be promised by 
> ABI.
>> 
>> But that does not make it any more interesting. It just makes the code
>> harder to read and eventually leads to bigger storage.
> [ZJ] To get the benctifit to be profiled, it is given as:
> number of instructions of function tick_nohz_tick_stopped():
[ZJ] Here, I used is not the tick_nohz_tick_stopped(), but an 
evaluation() as:
#include <stdio.h>
#include <stdbool.h>

struct tick_sched {
         unsigned int inidle             : 1;
         unsigned int tick_stopped       : 1;
};

bool get_status()
{
         struct tick_sched *ts;
         ts->tick_stopped = 1;
         return ts->tick_stopped;
}

int main()
{
         if (get_status()) return 0;
         return 0;
}

[ZJ] Toggle the declaration of tick_stopped in side of the tick_sched 
structure for comparison.


>                         original: 17
>                         patched:  14
>      Which was saved is:
>                movzbl	%al, %eax
>                testl	%eax, %eax
>                setne    %al
>      Say, 3 / 17 = 17 % could be gained in the instruction executed
> for this function can be evaluated.
> 
> Note:
>      The environment I used is:
>                OS : Ubuntu Desktop 16.04 LTS
>                gcc: 6.3.0                       (without optimization
> for in general purpose)
> 
>> 

Just FYI.

Thanks,
ZJ

  reply	other threads:[~2018-04-10 14:49 UTC|newest]

Thread overview: 56+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-10  7:33 Subject: [PATCH] [PATCH] time: tick-sched: use bool for tick_stopped yuankuiz
2018-04-10  7:45 ` yuankuiz
2018-04-10  8:51   ` yuankuiz
2018-04-10  8:54     ` yuankuiz
2018-04-10  7:55 ` Subject: [PATCH] " Thomas Gleixner
2018-04-10  8:12   ` yuankuiz
2018-04-10  8:00 ` Rafael J. Wysocki
2018-04-10  8:15   ` yuankuiz
2018-04-10  9:10     ` Thomas Gleixner
2018-04-10 10:07       ` yuankuiz
2018-04-10 11:06         ` Thomas Gleixner
2018-04-10 14:08           ` yuankuiz
2018-04-10 14:49             ` yuankuiz [this message]
2018-04-10 23:09               ` yuankuiz
2018-04-10 23:20                 ` yuankuiz
2018-04-20  1:47                   ` yuankuiz
2018-04-20  6:44                     ` yuankuiz
2018-04-20 19:24                       ` Joe Perches
2018-04-25  7:01                         ` yuankuiz
2018-04-10 11:26         ` Peter Zijlstra
2018-04-10 12:07           ` Thomas Gleixner
2018-04-10 12:26             ` Peter Zijlstra
2018-04-10 12:33   ` Subject: [PATCH] " Peter Zijlstra
2018-04-10 15:14     ` Joe Perches
2018-04-10 16:30       ` Peter Zijlstra
2018-04-10 15:41     ` [PATCH] checkpatch: whinge about bool bitfields Joe Perches
2018-04-10 18:19       ` [PATCH] checkpatch: Add a --strict test for structs with bool member definitions Joe Perches
2018-04-10 21:39         ` Andrew Morton
2018-04-10 21:53           ` Joe Perches
2018-04-10 22:00             ` Andrew Morton
2018-04-11  8:15               ` Peter Zijlstra
2018-04-11 16:29                 ` Andrew Morton
2018-04-11 16:51                   ` Joe Perches
2018-04-12  6:22                     ` Julia Lawall
2018-04-12  6:42                       ` Joe Perches
2018-04-12  7:03                         ` Julia Lawall
2018-04-12  8:13                         ` Peter Zijlstra
2018-04-14 21:19                         ` Julia Lawall
2018-04-17  9:07                           ` yuankuiz
2018-04-18 18:38                             ` Joe Perches
2018-04-19  4:40                               ` Julia Lawall
2018-04-19  4:51                                 ` Joe Perches
2018-04-19  5:16                                   ` Julia Lawall
2018-04-19  6:48                                     ` yuankuiz
2018-04-19 10:42                                       ` yuankuiz
2018-04-20  1:31                                         ` yuankuiz
2018-04-11 17:00                   ` Peter Zijlstra
2018-04-12  7:47                     ` Ingo Molnar
2018-04-12  8:11                       ` Peter Zijlstra
2018-04-12  9:35                       ` Andrea Parri
2018-04-12 11:50                         ` Peter Zijlstra
2018-04-12 12:01                           ` Joe Perches
2018-04-12 12:08                             ` Peter Zijlstra
2018-04-12 12:38                               ` Joe Perches
2018-04-12 16:47                               ` Andrew Morton
2018-04-12 11:52                         ` Kalle Valo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c3e05a4aad4895046401519dc83fa623@codeaurora.org \
    --to=yuankuiz@codeaurora.org \
    --cc=fweisbec@gmail.com \
    --cc=len.brown@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm-owner@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=peterz@infradead.org \
    --cc=rafael@kernel.org \
    --cc=rjw@rjwysocki.net \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).