linux-riscv.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: akpm@linux-foundation.org (Andrew Morton)
To: linux-riscv@lists.infradead.org
Subject: [PATCH 2/2] mm/sparse: add common helper to mark all memblocks present
Date: Wed, 7 Nov 2018 12:12:07 -0800	[thread overview]
Message-ID: <20181107121207.62cb37cf58484b7cc80a8fd8@linux-foundation.org> (raw)
In-Reply-To: <20181107173859.24096-3-logang@deltatee.com>

On Wed,  7 Nov 2018 10:38:59 -0700 Logan Gunthorpe <logang@deltatee.com> wrote:

> Presently the arches arm64, arm and sh have a function which loops through
> each memblock and calls memory present. riscv will require a similar
> function.
> 
> Introduce a common memblocks_present() function that can be used by
> all the arches. Subsequent patches will cleanup the arches that
> make use of this.
> 
> ...
>
> --- a/mm/sparse.c
> +++ b/mm/sparse.c
> @@ -239,6 +239,17 @@ void __init memory_present(int nid, unsigned long start, unsigned long end)
>  	}
>  }
>  
> +void __init memblocks_present(void)
> +{
> +	struct memblock_region *reg;
> +
> +	for_each_memblock(memory, reg) {
> +		memory_present(memblock_get_region_node(reg),
> +			       memblock_region_memory_base_pfn(reg),
> +			       memblock_region_memory_end_pfn(reg));
> +	}
> +}
> +

I don't like the name much.  To me, memblocks_present means "are
memblocks present" whereas this actually means "memblocks are present".
But whatever.  A little covering comment which describes what this
does and why it does it would be nice.

Acked-by: Andrew Morton <akpm@linux-foundation.org>

I can grab both patches and shall sneak them into 4.20-rcX, but feel
free to merge them into some git tree if you'd prefer.  If I see them
turn up in linux-next I shall drop my copy.

WARNING: multiple messages have this Message-ID (diff)
From: Andrew Morton <akpm@linux-foundation.org>
To: Logan Gunthorpe <logang@deltatee.com>
Cc: linux-arch@vger.kernel.org, Albert Ou <aou@eecs.berkeley.edu>,
	Arnd Bergmann <arnd@arndb.de>,
	linux-sh@vger.kernel.org, Palmer Dabbelt <palmer@sifive.com>,
	linux-kernel@vger.kernel.org, Stephen Bates <sbates@raithlin.com>,
	linux-mm@kvack.org, Michal Hocko <mhocko@suse.com>,
	Vlastimil Babka <vbabka@suse.cz>,
	linux-riscv@lists.infradead.org, Christoph Hellwig <hch@lst.de>,
	linux-arm-kernel@lists.infradead.org,
	Oscar Salvador <osalvador@suse.de>
Subject: Re: [PATCH 2/2] mm/sparse: add common helper to mark all memblocks present
Date: Wed, 7 Nov 2018 12:12:07 -0800	[thread overview]
Message-ID: <20181107121207.62cb37cf58484b7cc80a8fd8@linux-foundation.org> (raw)
Message-ID: <20181107201207.yCzYIP8sbHeSQ6mPa0KAJXQ1Dw2AH5k8qrbwxD-nPBI@z> (raw)
In-Reply-To: <20181107173859.24096-3-logang@deltatee.com>

On Wed,  7 Nov 2018 10:38:59 -0700 Logan Gunthorpe <logang@deltatee.com> wrote:

> Presently the arches arm64, arm and sh have a function which loops through
> each memblock and calls memory present. riscv will require a similar
> function.
> 
> Introduce a common memblocks_present() function that can be used by
> all the arches. Subsequent patches will cleanup the arches that
> make use of this.
> 
> ...
>
> --- a/mm/sparse.c
> +++ b/mm/sparse.c
> @@ -239,6 +239,17 @@ void __init memory_present(int nid, unsigned long start, unsigned long end)
>  	}
>  }
>  
> +void __init memblocks_present(void)
> +{
> +	struct memblock_region *reg;
> +
> +	for_each_memblock(memory, reg) {
> +		memory_present(memblock_get_region_node(reg),
> +			       memblock_region_memory_base_pfn(reg),
> +			       memblock_region_memory_end_pfn(reg));
> +	}
> +}
> +

I don't like the name much.  To me, memblocks_present means "are
memblocks present" whereas this actually means "memblocks are present".
But whatever.  A little covering comment which describes what this
does and why it does it would be nice.

Acked-by: Andrew Morton <akpm@linux-foundation.org>

I can grab both patches and shall sneak them into 4.20-rcX, but feel
free to merge them into some git tree if you'd prefer.  If I see them
turn up in linux-next I shall drop my copy.


_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

  parent reply	other threads:[~2018-11-07 20:12 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-07 17:38 [PATCH 0/2] Introduce common code for risc-v sparsemem support Logan Gunthorpe
2018-11-07 17:38 ` Logan Gunthorpe
2018-11-07 17:38 ` [PATCH 1/2] mm: Introduce common STRUCT_PAGE_MAX_SHIFT define Logan Gunthorpe
2018-11-07 17:38   ` Logan Gunthorpe
2018-11-07 20:11   ` Andrew Morton
2018-11-07 20:11     ` Andrew Morton
2018-11-07 17:38 ` [PATCH 2/2] mm/sparse: add common helper to mark all memblocks present Logan Gunthorpe
2018-11-07 17:38   ` Logan Gunthorpe
2018-11-07 20:12   ` Andrew Morton [this message]
2018-11-07 20:12     ` Andrew Morton
2018-11-07 20:19     ` Logan Gunthorpe
2018-11-07 20:19       ` Logan Gunthorpe
2018-11-07 20:26       ` Thomas Gleixner
2018-11-07 20:26         ` Thomas Gleixner
2018-11-07 20:36         ` Logan Gunthorpe
2018-11-07 20:36           ` Logan Gunthorpe
2018-11-07 20:38           ` Andrew Morton
2018-11-07 20:38             ` Andrew Morton
2018-11-07 20:56             ` Thomas Gleixner
2018-11-07 20:56               ` Thomas Gleixner
2018-12-06 17:40     ` Logan Gunthorpe
2018-12-07 19:56       ` Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181107121207.62cb37cf58484b7cc80a8fd8@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=linux-riscv@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).