linux-samsung-soc.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/7] PCI: dwc: miscellaneous fixes and cleanups
@ 2017-03-07  9:52 Kishon Vijay Abraham I
  2017-03-07  9:52 ` [PATCH v2 1/7] PCI: dwc: designware: Add new *ops* for cpu addr fixup Kishon Vijay Abraham I
                   ` (6 more replies)
  0 siblings, 7 replies; 14+ messages in thread
From: Kishon Vijay Abraham I @ 2017-03-07  9:52 UTC (permalink / raw)
  To: Bjorn Helgaas, Joao Pinto, linux-pci, linux-kernel, linux-omap,
	linux-arm-kernel, linux-samsung-soc, linux-arm-kernel
  Cc: nsekhar, Kishon Vijay Abraham I

This should be the final set of cleanups/fixes before endpoint
support can be merged.

Keerthy's patch is a general fix in dra7xx driver and is not
directly related to endpoint mode.

This series was previously sent with a different cover letter
$subject [1]

Changes from v1:
*) included a patch to rename _unroll() to _ob_unroll() as
   similar thing has to be done for inbound window in the case
   of EP mode.
*) used 'size_t' instead of 'int' for specifying the size
   in read_dbi/write_dbi function arguments.
*) Populate cpu_addr_fixup ops for artpec6 as suggested by
   Niklas

This series is based on 4.11-rc1

[1] -> https://lkml.org/lkml/2017/2/16/270

Keerthy (1):
  PCI: dwc: dra7xx: Push request_irq call to the bottom of probe

Kishon Vijay Abraham I (6):
  PCI: dwc: designware: Add new *ops* for cpu addr fixup
  PCI: dwc: dra7xx: Populate cpu_addr_fixup ops
  PCI: dwc: artpec6: Populate cpu_addr_fixup ops
  PCI: dwc: all: Modify dbi accessors to take dbi_base as argument
  PCI: dwc: all: Modify dbi accessors to access data of 4/2/1  bytes
  PCI: dwc: designware: Modify _unroll() to _ob_unroll()

 drivers/pci/dwc/Kconfig                |   18 ++---
 drivers/pci/dwc/pci-dra7xx.c           |   35 +++++----
 drivers/pci/dwc/pci-exynos.c           |   14 ++--
 drivers/pci/dwc/pci-imx6.c             |   62 +++++++++-------
 drivers/pci/dwc/pci-keystone-dw.c      |   16 ++--
 drivers/pci/dwc/pcie-armada8k.c        |   39 +++++-----
 drivers/pci/dwc/pcie-artpec6.c         |   22 ++++--
 drivers/pci/dwc/pcie-designware-host.c |   20 ++---
 drivers/pci/dwc/pcie-designware.c      |  127 ++++++++++++++++++++------------
 drivers/pci/dwc/pcie-designware.h      |   13 +++-
 drivers/pci/dwc/pcie-hisi.c            |   17 +++--
 11 files changed, 226 insertions(+), 157 deletions(-)

-- 
1.7.9.5

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2017-03-07 11:34 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-03-07  9:52 [PATCH v2 0/7] PCI: dwc: miscellaneous fixes and cleanups Kishon Vijay Abraham I
2017-03-07  9:52 ` [PATCH v2 1/7] PCI: dwc: designware: Add new *ops* for cpu addr fixup Kishon Vijay Abraham I
2017-03-07 11:11   ` Joao Pinto
2017-03-07  9:52 ` [PATCH v2 2/7] PCI: dwc: dra7xx: Populate cpu_addr_fixup ops Kishon Vijay Abraham I
2017-03-07 11:12   ` Joao Pinto
2017-03-07  9:52 ` [PATCH v2 3/7] PCI: dwc: artpec6: " Kishon Vijay Abraham I
2017-03-07 11:12   ` Joao Pinto
2017-03-07  9:52 ` [PATCH v2 4/7] PCI: dwc: all: Modify dbi accessors to take dbi_base as argument Kishon Vijay Abraham I
2017-03-07 11:34   ` Joao Pinto
2017-03-07  9:52 ` [PATCH v2 5/7] PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes Kishon Vijay Abraham I
2017-03-07 11:18   ` Joao Pinto
2017-03-07 11:23     ` Kishon Vijay Abraham I
2017-03-07  9:52 ` [PATCH v2 6/7] PCI: dwc: designware: Modify _unroll() to _ob_unroll() Kishon Vijay Abraham I
2017-03-07  9:52 ` [PATCH v2 7/7] PCI: dwc: dra7xx: Push request_irq call to the bottom of probe Kishon Vijay Abraham I

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).