linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-18 04:34:03 to 2020-07-25 00:08:28 UTC [more...]

[PATCH v11 00/25] xfs: Delay Ready Attributes
 2020-07-25  0:08 UTC  (40+ messages)
` [PATCH v11 01/25] xfs: Add xfs_has_attr and subroutines
` [PATCH v11 02/25] xfs: Check for -ENOATTR or -EEXIST
` [PATCH v11 03/25] xfs: Factor out new helper functions xfs_attr_rmtval_set
` [PATCH v11 04/25] xfs: Pull up trans handling in xfs_attr3_leaf_flipflags
` [PATCH v11 05/25] xfs: Split apart xfs_attr_leaf_addname
` [PATCH v11 06/25] xfs: Refactor xfs_attr_try_sf_addname
` [PATCH v11 07/25] xfs: Pull up trans roll from xfs_attr3_leaf_setflag
` [PATCH v11 08/25] xfs: Factor out xfs_attr_rmtval_invalidate
` [PATCH v11 09/25] xfs: Pull up trans roll in xfs_attr3_leaf_clearflag
` [PATCH v11 10/25] xfs: Refactor xfs_attr_rmtval_remove
` [PATCH v11 11/25] xfs: Pull up xfs_attr_rmtval_invalidate
` [PATCH v11 12/25] xfs: Add helper function xfs_attr_node_shrink
` [PATCH v11 13/25] xfs: Remove unneeded xfs_trans_roll_inode calls
` [PATCH v11 14/25] xfs: Remove xfs_trans_roll in xfs_attr_node_removename
` [PATCH v11 15/25] xfs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform
` [PATCH v11 16/25] xfs: Add helper function xfs_attr_leaf_mark_incomplete
` [PATCH v11 17/25] xfs: Add remote block helper functions
` [PATCH v11 18/25] xfs: Add helper function xfs_attr_node_removename_setup
` [PATCH v11 19/25] xfs: Add helper function xfs_attr_node_removename_rmt
` [PATCH v11 20/25] xfs: Simplify xfs_attr_leaf_addname
` [PATCH v11 21/25] xfs: Simplify xfs_attr_node_addname
` [PATCH v11 22/25] xfs: Lift -ENOSPC handler from xfs_attr_leaf_addname
` [PATCH v11 23/25] xfs: Add delay ready attr remove routines
` [PATCH v11 24/25] xfs: Add delay ready attr set routines
` [PATCH v11 25/25] xfs: Rename __xfs_attr_rmtval_remove

[DEVEL] libxfs update timing for xfsprogs 5.8.0
 2020-07-24 19:21 UTC  (2+ messages)

[ANNOUNCE] xfsprogs v5.7.0 released
 2020-07-24 19:05 UTC 

[PATCH v6 0/7] add support for direct I/O with fscrypt using blk-crypto
 2020-07-24 18:45 UTC  (8+ messages)
` [PATCH v6 1/7] fscrypt: Add functions for direct I/O support
` [PATCH v6 2/7] direct-io: add support for fscrypt using blk-crypto
` [PATCH v6 3/7] iomap: support direct I/O with "
` [PATCH v6 4/7] ext4: "
` [PATCH v6 5/7] f2fs: "
` [PATCH v6 6/7] fscrypt: document inline encryption support
` [PATCH v6 7/7] fscrypt: update documentation for direct I/O support

WARN_ON_ONCE(1) in iomap_dio_actor()
 2020-07-24 18:24 UTC  (3+ messages)

[PATCH] xfs_io: Document '-q' option for sendfile command
 2020-07-24 18:24 UTC  (2+ messages)

[PATCH v4 0/7] add support for direct I/O with fscrypt using blk-crypto
 2020-07-24 17:41 UTC  (30+ messages)
` [PATCH v4 1/7] fscrypt: Add functions for direct I/O support
` [PATCH v4 2/7] direct-io: add support for fscrypt using blk-crypto
` [PATCH v4 3/7] iomap: support direct I/O with "
` [PATCH v4 4/7] ext4: "
` [PATCH v4 5/7] f2fs: "
` [PATCH v4 6/7] fscrypt: document inline encryption support
` [PATCH v4 7/7] fscrypt: update documentation for direct I/O support

[ANNOUNCE] xfs-linux: for-next updated to 9f347d7a7e0e
 2020-07-24 16:44 UTC 

[PATCH v5 0/7] add support for direct I/O with fscrypt using blk-crypto
 2020-07-24 16:46 UTC  (9+ messages)
` [PATCH v5 1/7] fscrypt: Add functions for direct I/O support
` [PATCH v5 2/7] direct-io: add support for fscrypt using blk-crypto
` [PATCH v5 3/7] iomap: support direct I/O with "
` [PATCH v5 4/7] ext4: "
` [PATCH v5 5/7] f2fs: "
` [PATCH v5 6/7] fscrypt: document inline encryption support
` [PATCH v5 7/7] fscrypt: update documentation for direct I/O support

[ANNOUNCE] xfs-linux: for-next updated to 073a5a695e63
 2020-07-24 16:42 UTC 

[ANNOUNCE] xfs-linux: iomap-for-next updated to 979045f83ced
 2020-07-24 16:19 UTC 

Need to slow things down for a few days
 2020-07-24  7:36 UTC  (2+ messages)

[PATCH] xfs_io: Remove redundant setting/check for lsattr/stat command
 2020-07-24  7:14 UTC 

[PATCH v2] xfs_io: Make -D and -R options incompatible explicitly
 2020-07-24  6:32 UTC 

[RFC PATCH 0/2] xfs: more unlinked inode list optimization v1
 2020-07-24  6:12 UTC  (5+ messages)
` [RFC PATCH v2 0/3] xfs: more unlinked inode list optimization v2
  ` [RFC PATCH v2 1/3] xfs: arrange all unlinked inodes into one list
  ` [RFC PATCH v2 2/3] xfs: introduce perag iunlink lock
  ` [RFC PATCH v2 3/3] xfs: insert unlinked inodes from tail

[PATCH 0/5] Continue xfs kmem cleanup - V3
 2020-07-24  5:40 UTC  (18+ messages)
` [PATCH 1/5] xfs: Remove kmem_zone_alloc() usage
` [PATCH 2/5] xfs: Remove kmem_zone_zalloc() usage
` [PATCH 3/5] xfs: Modify xlog_ticket_alloc() to use kernel's MM API
` [PATCH 4/5] xfs: remove xfs_zone_{alloc,zalloc} helpers
` [PATCH 5/5] xfs: Refactor xfs_da_state_alloc() helper

[PATCH] io/attr.c: Disallow specifying both -D and -R options for chattr command
 2020-07-24  1:09 UTC  (6+ messages)

Processed (with 3 errors): gcc 10 FTBFS bugs housekeeping
 2020-07-23 12:16 UTC 

iomap write invalidation v2
 2020-07-22 23:13 UTC  (11+ messages)
` [PATCH 1/3] xfs: use ENOTBLK for direct I/O to buffered I/O fallback
` [PATCH 2/3] iomap: Only invalidate page cache pages on direct IO writes
` [PATCH 3/3] iomap: fall back to buffered writes for invalidation failures
    ` [Cluster-devel] "

[PATCH] xfs_io: Document '-q' option for pread/pwrite command
 2020-07-22  3:46 UTC  (4+ messages)

RFC: iomap write invalidation
 2020-07-21 16:05 UTC  (17+ messages)

[PATCH 0/3] xfsprogs: xfs_quota error message and state reporting improvement
 2020-07-21 15:55 UTC  (4+ messages)
` [PATCH 1/3] xfsprogs: xfs_quota command error message improvement

[PATCH] xfsprogs: remove the libxfs_* API redirections
 2020-07-21 15:51 UTC  (3+ messages)

[PATCH 3/3] xfsprogs: xfs_quota state command should report ugp grace times
 2020-07-21 15:05 UTC  (3+ messages)
` [PATCH v2 "

[PATCH] xfs: fix inode allocation block res calculation precedence
 2020-07-21 15:01 UTC  (2+ messages)

[PATCH v5 00/11] xfs: separate dquot type from flags
 2020-07-21 14:59 UTC  (24+ messages)
` [PATCH 01/11] xfs: drop the type parameter from xfs_dquot_verify
` [PATCH 02/11] xfs: rename XFS_DQ_{USER,GROUP,PROJ} to XFS_DQTYPE_*
` [PATCH 03/11] xfs: refactor testing if a particular dquot is being enforced
` [PATCH 04/11] xfs: remove the XFS_QM_IS[UGP]DQ macros
` [PATCH 05/11] xfs: refactor quota type testing
` [PATCH 06/11] xfs: always use xfs_dquot_type when extracting type from a dquot
` [PATCH 07/11] xfs: remove unnecessary quota type masking
` [PATCH 08/11] xfs: replace a few open-coded XFS_DQTYPE_REC_MASK uses
` [PATCH 09/11] xfs: create xfs_dqtype_t to represent quota types
` [PATCH 10/11] xfs: improve ondisk dquot flags checking
  ` [PATCH v2 "
` [PATCH 11/11] xfs: rename the ondisk dquot d_flags to d_type

[PATCH 0/4] xfsprogs: remove custom dir2 sf fork verifier from repair
 2020-07-21  0:57 UTC  (7+ messages)
` [PATCH 1/4] repair: set the in-core inode parent in phase 3
` [PATCH 2/4] repair: don't double check dir2 sf parent in phase 4
` [PATCH 4/4] repair: remove custom dir2 sf fork verifier from phase6

[PATCH 3/4] repair: use fs root ino for dummy parent value instead of zero
 2020-07-21  0:47 UTC  (4+ messages)
` [PATCH v2] repair: use fs rootino "

[PATCH v3 0/7] add support for direct I/O with fscrypt using blk-crypto
 2020-07-20 20:14 UTC  (9+ messages)
` [PATCH v3 1/7] fscrypt: Add functions for direct I/O support
` [PATCH v3 3/7] iomap: support direct I/O with fscrypt using blk-crypto
` [PATCH v3 6/7] fscrypt: document inline encryption support
` [PATCH v3 7/7] fscrypt: update documentation for direct I/O support

[PATCH v6] xfs: Fix false positive lockdep warning with sb_internal & fs_reclaim
 2020-07-20 15:46 UTC  (5+ messages)

[PATCH v4 00/26] xfs: remove xfs_disk_quot from incore dquot
 2020-07-20  5:38 UTC  (9+ messages)
` [PATCH 09/26] xfs: make XFS_DQUOT_CLUSTER_SIZE_FSB part of the ondisk format
` [PATCH 10/26] xfs: stop using q_core.d_flags in the quota code
` [PATCH 24/26] xfs: assume the default quota limits are always set in xfs_qm_adjust_dqlimits
` [PATCH 25/26] xfs: actually bump warning counts when we send warnings

[PATCH 00/10] xfs: automatic relogging
 2020-07-20  3:58 UTC  (10+ messages)

[PATCH] xfs: xfs_btree_staging.h: delete duplicated words
 2020-07-20  1:21 UTC  (2+ messages)

[PATCH v11 00/26] xfsprogs: Delay Ready Attributes
 2020-07-18  4:33 UTC  (7+ messages)
` [PATCH v11 02/26] xfsprogs: Add xfs_has_attr and subroutines
` [PATCH v11 03/26] xfsprogs: Check for -ENOATTR or -EEXIST
` [PATCH v11 17/26] xfsprogs: Add helper function xfs_attr_leaf_mark_incomplete
` [PATCH v11 21/26] xfsprogs: Simplify xfs_attr_leaf_addname
` [PATCH v11 24/26] xfsprogs: Add delay ready attr remove routines
` [PATCH v11 25/26] xfsprogs: Add delay ready attr set routines


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).