linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
To: Johan Hovold <johan@kernel.org>
Cc: Johan Hovold <johan+linaro@kernel.org>,
	Vinod Koul <vkoul@kernel.org>, Andy Gross <agross@kernel.org>,
	Bjorn Andersson <andersson@kernel.org>,
	Konrad Dybcio <konrad.dybcio@somainline.org>,
	Rob Herring <robh+dt@kernel.org>,
	Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
	linux-arm-msm@vger.kernel.org, linux-phy@lists.infradead.org,
	devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 08/15] phy: qcom-qmp-pcie: add register init helper
Date: Wed, 19 Oct 2022 16:44:33 +0300	[thread overview]
Message-ID: <0b0c752c-1f3d-bf5a-ade7-e2f8acac92a4@linaro.org> (raw)
In-Reply-To: <Y0/63eH82t2zXFi5@hovoldconsulting.com>

On 19/10/2022 16:25, Johan Hovold wrote:
> On Wed, Oct 19, 2022 at 04:12:02PM +0300, Dmitry Baryshkov wrote:
>> On 19/10/2022 14:35, Johan Hovold wrote:
>>> Generalise the serdes initialisation helper so that it can be used to
>>> initialise all the PHY registers (e.g. serdes, tx, rx, pcs).
>>>
>>> Note that this defers the ungating of the PIPE clock somewhat, which is
>>> fine as it isn't needed until starting the PHY.
>>>
>>> Signed-off-by: Johan Hovold <johan+linaro@kernel.org>
>>> ---
>>>    drivers/phy/qualcomm/phy-qcom-qmp-pcie.c | 51 +++++++-----------------
>>>    1 file changed, 15 insertions(+), 36 deletions(-)
>>>
>>> diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-pcie.c b/drivers/phy/qualcomm/phy-qcom-qmp-pcie.c
>>> index dd7e72424fc0..f57d10f20277 100644
>>> --- a/drivers/phy/qualcomm/phy-qcom-qmp-pcie.c
>>> +++ b/drivers/phy/qualcomm/phy-qcom-qmp-pcie.c
>>> @@ -1820,46 +1820,32 @@ static void qmp_pcie_configure(void __iomem *base,
>>>    	qmp_pcie_configure_lane(base, tbl, num, 0xff);
>>>    }
>>>    
>>> -static void qmp_pcie_serdes_init(struct qmp_pcie *qmp, const struct qmp_phy_cfg_tables *tables)
>>> -{
>>> -	void __iomem *serdes = qmp->serdes;
>>> -
>>> -	if (!tables)
>>> -		return;
>>> -
>>> -	qmp_pcie_configure(serdes, tables->serdes, tables->serdes_num);
>>> -}
>>> -
>>> -static void qmp_pcie_lanes_init(struct qmp_pcie *qmp, const struct qmp_phy_cfg_tables *tables)
>>> +static void qmp_pcie_init_registers(struct qmp_pcie *qmp, const struct qmp_phy_cfg_tables *tbls)
>>>    {
>>>    	const struct qmp_phy_cfg *cfg = qmp->cfg;
>>> +	void __iomem *serdes = qmp->serdes;
>>>    	void __iomem *tx = qmp->tx;
>>>    	void __iomem *rx = qmp->rx;
>>>    	void __iomem *tx2 = qmp->tx2;
>>>    	void __iomem *rx2 = qmp->rx2;
>>> +	void __iomem *pcs = qmp->pcs;
>>> +	void __iomem *pcs_misc = qmp->pcs_misc;
>>>    
>>> -	if (!tables)
>>> +	if (!tbls)
>>>    		return;
>>>    
>>> -	qmp_pcie_configure_lane(tx, tables->tx, tables->tx_num, 1);
>>> -	qmp_pcie_configure_lane(rx, tables->rx, tables->rx_num, 1);
>>> +	qmp_pcie_configure(serdes, tbls->serdes, tbls->serdes_num);
>>> +
>>> +	qmp_pcie_configure_lane(tx, tbls->tx, tbls->tx_num, 1);
>>> +	qmp_pcie_configure_lane(rx, tbls->rx, tbls->rx_num, 1);
>>>    
>>>    	if (cfg->lanes >= 2) {
>>> -		qmp_pcie_configure_lane(tx2, tables->tx, tables->tx_num, 2);
>>> -		qmp_pcie_configure_lane(rx2, tables->rx, tables->rx_num, 2);
>>> +		qmp_pcie_configure_lane(tx2, tbls->tx, tbls->tx_num, 2);
>>> +		qmp_pcie_configure_lane(rx2, tbls->rx, tbls->rx_num, 2);
>>>    	}
>>> -}
>>> -
>>> -static void qmp_pcie_pcs_init(struct qmp_pcie *qmp, const struct qmp_phy_cfg_tables *tables)
>>> -{
>>> -	void __iomem *pcs = qmp->pcs;
>>> -	void __iomem *pcs_misc = qmp->pcs_misc;
>>> -
>>> -	if (!tables)
>>> -		return;
>>>    
>>> -	qmp_pcie_configure(pcs, tables->pcs, tables->pcs_num);
>>> -	qmp_pcie_configure(pcs_misc, tables->pcs_misc, tables->pcs_misc_num);
>>> +	qmp_pcie_configure(pcs, tbls->pcs, tbls->pcs_num);
>>> +	qmp_pcie_configure(pcs_misc, tbls->pcs_misc, tbls->pcs_misc_num);
>>
>> Nit: could we please keep it as `tables'?
> 
> I considered that but found that the longer identifier hurt
> readability so I prefer to use "tbls" here.
> 
> Compare
> 
> 	qmp_pcie_configure(serdes, tbls->serdes, tbls->serdes_num);
> 
> 	qmp_pcie_configure_lane(tx, tbls->tx, tbls->tx_num, 1);
> 	qmp_pcie_configure_lane(rx, tbls->rx, tbls->rx_num, 1);
> 
> 	if (cfg->lanes >= 2) {
> 		qmp_pcie_configure_lane(tx2, tbls->tx, tbls->tx_num, 2);
> 		qmp_pcie_configure_lane(rx2, tbls->rx, tbls->rx_num, 2);
> 	}
> 
> 	qmp_pcie_configure(pcs, tbls->pcs, tbls->pcs_num);
> 	qmp_pcie_configure(pcs_misc, tbls->pcs_misc, tbls->pcs_misc_num);
> 
> with
> 
> 	qmp_pcie_configure(serdes, tables->serdes, tables->serdes_num);
> 
> 	qmp_pcie_configure_lane(tx, tables->tx, tables->tx_num, 1);
> 	qmp_pcie_configure_lane(rx, tables->rx, tables->rx_num, 1);
> 
> 	if (cfg->lanes >= 2) {
> 		qmp_pcie_configure_lane(tx2, tables->tx, tables->tx_num, 2);
> 		qmp_pcie_configure_lane(rx2, tables->rx, tables->rx_num, 2);
> 	}
> 
> 	qmp_pcie_configure(pcs, tables->pcs, tables->pcs_num);
> 	qmp_pcie_configure(pcs_misc, tables->pcs_misc, tables->pcs_misc_num);

I'd say, it's up to Vinod. I'd prefer the second version.


-- 
With best wishes
Dmitry


  reply	other threads:[~2022-10-19 14:05 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-10-19 11:35 [PATCH v2 00/15] phy: qcom-qmp-pcie: add support for sc8280xp Johan Hovold
2022-10-19 11:35 ` [PATCH v2 01/15] phy: qcom-qmp-pcie: sort device-id table Johan Hovold
2022-10-19 12:28   ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 02/15] phy: qcom-qmp-pcie: move " Johan Hovold
2022-10-19 12:29   ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 03/15] phy: qcom-qmp-pcie: merge driver data Johan Hovold
2022-10-19 13:03   ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 04/15] phy: qcom-qmp-pcie: clean up device-tree parsing Johan Hovold
2022-10-19 11:35 ` [PATCH v2 05/15] phy: qcom-qmp-pcie: clean up probe initialisation Johan Hovold
2022-10-19 13:05   ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 06/15] phy: qcom-qmp-pcie: rename PHY ops structure Johan Hovold
2022-10-19 13:05   ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 07/15] phy: qcom-qmp-pcie: clean up PHY lane init Johan Hovold
2022-10-19 13:45   ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 08/15] phy: qcom-qmp-pcie: add register init helper Johan Hovold
2022-10-19 13:12   ` Dmitry Baryshkov
2022-10-19 13:25     ` Johan Hovold
2022-10-19 13:44       ` Dmitry Baryshkov [this message]
2022-10-19 13:51         ` Johan Hovold
2022-10-19 11:35 ` [PATCH v2 09/15] dt-bindings: phy: qcom,qmp-pcie: rename current bindings Johan Hovold
2022-10-19 12:39   ` Krzysztof Kozlowski
2022-10-19 11:35 ` [PATCH v2 10/15] dt-bindings: phy: qcom,qmp-pcie: add sc8280xp bindings Johan Hovold
2022-10-19 12:41   ` Krzysztof Kozlowski
2022-10-19 11:35 ` [PATCH v2 11/15] phy: qcom-qmp-pcie: restructure PHY creation Johan Hovold
2022-10-19 13:51   ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 12/15] phy: qcom-qmp-pcie: fix initialisation reset Johan Hovold
2022-10-19 13:51   ` Dmitry Baryshkov
2022-10-19 13:52   ` Dmitry Baryshkov
2022-10-21  9:11     ` Johan Hovold
2022-10-19 11:35 ` [PATCH v2 13/15] phy: qcom-qmp-pcie: add support for pipediv2 clock Johan Hovold
2022-10-20  8:31   ` Dmitry Baryshkov
2022-10-20  9:05     ` Johan Hovold
2022-10-20  9:28       ` Dmitry Baryshkov
2022-10-20 10:49         ` Johan Hovold
2022-10-20 10:53           ` Dmitry Baryshkov
2022-10-19 11:35 ` [PATCH v2 14/15] phy: qcom-qmp-pcie: add support for sc8280xp Johan Hovold
2022-10-19 11:35 ` [PATCH v2 15/15] phy: qcom-qmp-pcie: add support for sc8280xp 4-lane PHYs Johan Hovold
2022-10-20  3:43   ` Dmitry Baryshkov
2022-10-20  6:43     ` Johan Hovold
2022-10-20  9:32       ` Dmitry Baryshkov
2022-10-20 10:59         ` Johan Hovold

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0b0c752c-1f3d-bf5a-ade7-e2f8acac92a4@linaro.org \
    --to=dmitry.baryshkov@linaro.org \
    --cc=agross@kernel.org \
    --cc=andersson@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=johan+linaro@kernel.org \
    --cc=johan@kernel.org \
    --cc=konrad.dybcio@somainline.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-phy@lists.infradead.org \
    --cc=robh+dt@kernel.org \
    --cc=vkoul@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).