linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header
@ 2016-02-12 18:05 Colin Vidal
  2016-02-12 18:05 ` [PATCH v3 2/5] Staging: rtl8188eu/core: Coding style fix, set conform spaces between identifiers Colin Vidal
  2016-02-15  0:40 ` [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header Greg Kroah-Hartman
  0 siblings, 2 replies; 8+ messages in thread
From: Colin Vidal @ 2016-02-12 18:05 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Colin Vidal, open list:STAGING SUBSYSTEM, open list

Signed-off-by: Colin Vidal <colin@cvidal.org>
---
 drivers/staging/rtl8188eu/core/rtw_iol.c | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c b/drivers/staging/rtl8188eu/core/rtw_iol.c
index cdcf0ea..000a81c 100644
--- a/drivers/staging/rtl8188eu/core/rtw_iol.c
+++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
@@ -11,10 +11,6 @@
  * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
  * more details.
  *
- * You should have received a copy of the GNU General Public License along with
- * this program; if not, write to the Free Software Foundation, Inc.,
- * 51 Franklin Street, Fifth Floor, Boston, MA 02110, USA
- *
  *
  ******************************************************************************/
 
-- 
2.5.0

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* [PATCH v3 2/5] Staging: rtl8188eu/core: Coding style fix, set conform spaces between identifiers
  2016-02-12 18:05 [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header Colin Vidal
@ 2016-02-12 18:05 ` Colin Vidal
  2016-02-12 18:05   ` [PATCH v3 3/5] Staging: rtl8188eu/core: Coding style fix, set constant operand on right in tests Colin Vidal
  2016-02-15  0:40 ` [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header Greg Kroah-Hartman
  1 sibling, 1 reply; 8+ messages in thread
From: Colin Vidal @ 2016-02-12 18:05 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Colin Vidal, open list:STAGING SUBSYSTEM, open list

Signed-off-by: Colin Vidal <colin@cvidal.org>
---
 drivers/staging/rtl8188eu/core/rtw_iol.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 000a81c..7642c22 100644
--- a/drivers/staging/rtl8188eu/core/rtw_iol.c
+++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
@@ -14,9 +14,9 @@
  *
  ******************************************************************************/
 
-#include<rtw_iol.h>
+#include <rtw_iol.h>
 
-bool rtw_IOL_applied(struct adapter  *adapter)
+bool rtw_IOL_applied(struct adapter *adapter)
 {
 	if (1 == adapter->registrypriv.fw_iol)
 		return true;
-- 
2.5.0

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* [PATCH v3 3/5] Staging: rtl8188eu/core: Coding style fix, set constant operand on right in tests
  2016-02-12 18:05 ` [PATCH v3 2/5] Staging: rtl8188eu/core: Coding style fix, set conform spaces between identifiers Colin Vidal
@ 2016-02-12 18:05   ` Colin Vidal
  2016-02-12 18:05     ` [PATCH v3 4/5] Staging: rtl8188eu/core: Coding style fix, avoid line over 80 characters Colin Vidal
  0 siblings, 1 reply; 8+ messages in thread
From: Colin Vidal @ 2016-02-12 18:05 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Colin Vidal, open list:STAGING SUBSYSTEM, open list

Signed-off-by: Colin Vidal <colin@cvidal.org>
---
 drivers/staging/rtl8188eu/core/rtw_iol.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 7642c22..3dd1a9a 100644
--- a/drivers/staging/rtl8188eu/core/rtw_iol.c
+++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
@@ -18,10 +18,10 @@
 
 bool rtw_IOL_applied(struct adapter *adapter)
 {
-	if (1 == adapter->registrypriv.fw_iol)
+	if (adapter->registrypriv.fw_iol == 1)
 		return true;
 
-	if ((2 == adapter->registrypriv.fw_iol) && (!adapter_to_dvobj(adapter)->ishighspeed))
+	if ((adapter->registrypriv.fw_iol == 2) && (!adapter_to_dvobj(adapter)->ishighspeed))
 		return true;
 	return false;
 }
-- 
2.5.0

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* [PATCH v3 4/5] Staging: rtl8188eu/core: Coding style fix, avoid line over 80 characters
  2016-02-12 18:05   ` [PATCH v3 3/5] Staging: rtl8188eu/core: Coding style fix, set constant operand on right in tests Colin Vidal
@ 2016-02-12 18:05     ` Colin Vidal
  2016-02-12 18:05       ` [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable Colin Vidal
  0 siblings, 1 reply; 8+ messages in thread
From: Colin Vidal @ 2016-02-12 18:05 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Colin Vidal, open list:STAGING SUBSYSTEM, open list

Signed-off-by: Colin Vidal <colin@cvidal.org>
---
 drivers/staging/rtl8188eu/core/rtw_iol.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 3dd1a9a..2e2145c 100644
--- a/drivers/staging/rtl8188eu/core/rtw_iol.c
+++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
@@ -21,7 +21,8 @@ bool rtw_IOL_applied(struct adapter *adapter)
 	if (adapter->registrypriv.fw_iol == 1)
 		return true;
 
-	if ((adapter->registrypriv.fw_iol == 2) && (!adapter_to_dvobj(adapter)->ishighspeed))
+	if ((adapter->registrypriv.fw_iol == 2) &&
+	    (!adapter_to_dvobj(adapter)->ishighspeed))
 		return true;
 	return false;
 }
-- 
2.5.0

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable
  2016-02-12 18:05     ` [PATCH v3 4/5] Staging: rtl8188eu/core: Coding style fix, avoid line over 80 characters Colin Vidal
@ 2016-02-12 18:05       ` Colin Vidal
  2016-02-15  0:39         ` Greg Kroah-Hartman
  0 siblings, 1 reply; 8+ messages in thread
From: Colin Vidal @ 2016-02-12 18:05 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Colin Vidal, open list:STAGING SUBSYSTEM, open list

Signed-off-by: Colin Vidal <colin@cvidal.org>
---
 drivers/staging/rtl8188eu/core/rtw_iol.c | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)

diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c b/drivers/staging/rtl8188eu/core/rtw_iol.c
index 2e2145c..ba6c492 100644
--- a/drivers/staging/rtl8188eu/core/rtw_iol.c
+++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
@@ -18,11 +18,7 @@
 
 bool rtw_IOL_applied(struct adapter *adapter)
 {
-	if (adapter->registrypriv.fw_iol == 1)
-		return true;
-
-	if ((adapter->registrypriv.fw_iol == 2) &&
-	    (!adapter_to_dvobj(adapter)->ishighspeed))
-		return true;
-	return false;
+	return adapter->registrypriv.fw_iol == 1 ||
+		(adapter->registrypriv.fw_iol == 2 &&
+		 !adapter_to_dvobj(adapter)->ishighspeed);
 }
-- 
2.5.0

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable
  2016-02-12 18:05       ` [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable Colin Vidal
@ 2016-02-15  0:39         ` Greg Kroah-Hartman
  2016-02-15 16:26           ` Colin Vidal
  0 siblings, 1 reply; 8+ messages in thread
From: Greg Kroah-Hartman @ 2016-02-15  0:39 UTC (permalink / raw)
  To: Colin Vidal; +Cc: open list:STAGING SUBSYSTEM, open list

On Fri, Feb 12, 2016 at 07:05:53PM +0100, Colin Vidal wrote:
> Signed-off-by: Colin Vidal <colin@cvidal.org>
> ---
>  drivers/staging/rtl8188eu/core/rtw_iol.c | 10 +++-------
>  1 file changed, 3 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c b/drivers/staging/rtl8188eu/core/rtw_iol.c
> index 2e2145c..ba6c492 100644
> --- a/drivers/staging/rtl8188eu/core/rtw_iol.c
> +++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
> @@ -18,11 +18,7 @@
>  
>  bool rtw_IOL_applied(struct adapter *adapter)
>  {
> -	if (adapter->registrypriv.fw_iol == 1)
> -		return true;
> -
> -	if ((adapter->registrypriv.fw_iol == 2) &&
> -	    (!adapter_to_dvobj(adapter)->ishighspeed))
> -		return true;
> -	return false;
> +	return adapter->registrypriv.fw_iol == 1 ||
> +		(adapter->registrypriv.fw_iol == 2 &&
> +		 !adapter_to_dvobj(adapter)->ishighspeed);
>  }

I'm sorry, but this patch does not do what you said it does, it's much
harder to read now :(

Also, I can't take a patch without a changelog text :(

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header
  2016-02-12 18:05 [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header Colin Vidal
  2016-02-12 18:05 ` [PATCH v3 2/5] Staging: rtl8188eu/core: Coding style fix, set conform spaces between identifiers Colin Vidal
@ 2016-02-15  0:40 ` Greg Kroah-Hartman
  1 sibling, 0 replies; 8+ messages in thread
From: Greg Kroah-Hartman @ 2016-02-15  0:40 UTC (permalink / raw)
  To: Colin Vidal; +Cc: open list:STAGING SUBSYSTEM, open list

On Fri, Feb 12, 2016 at 07:05:49PM +0100, Colin Vidal wrote:
> Signed-off-by: Colin Vidal <colin@cvidal.org>
> ---

All of these need to be resent with a changelog comment added.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable
  2016-02-15  0:39         ` Greg Kroah-Hartman
@ 2016-02-15 16:26           ` Colin Vidal
  0 siblings, 0 replies; 8+ messages in thread
From: Colin Vidal @ 2016-02-15 16:26 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: open list:STAGING SUBSYSTEM, open list

On Sun, 2016-02-14 at 16:39 -0800, Greg Kroah-Hartman wrote:
> On Fri, Feb 12, 2016 at 07:05:53PM +0100, Colin Vidal wrote:
> > Signed-off-by: Colin Vidal <colin@cvidal.org>
> > ---
> >  drivers/staging/rtl8188eu/core/rtw_iol.c | 10 +++-------
> >  1 file changed, 3 insertions(+), 7 deletions(-)
> > 
> > diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
> > b/drivers/staging/rtl8188eu/core/rtw_iol.c
> > index 2e2145c..ba6c492 100644
> > --- a/drivers/staging/rtl8188eu/core/rtw_iol.c
> > +++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
> > @@ -18,11 +18,7 @@
> >  
> >  bool rtw_IOL_applied(struct adapter *adapter)
> >  {
> > -	if (adapter->registrypriv.fw_iol == 1)
> > -		return true;
> > -
> > -	if ((adapter->registrypriv.fw_iol == 2) &&
> > -	    (!adapter_to_dvobj(adapter)->ishighspeed))
> > -		return true;
> > -	return false;
> > +	return adapter->registrypriv.fw_iol == 1 ||
> > +		(adapter->registrypriv.fw_iol == 2 &&
> > +		 !adapter_to_dvobj(adapter)->ishighspeed);
> >  }
> 
> I'm sorry, but this patch does not do what you said it does, it's
> much
> harder to read now :(
> 
> Also, I can't take a patch without a changelog text :(
> 
> thanks,
> 
> greg k-h

Hi Greg,

Thanks for you replie!

OK, I thought it was a better idea (as suggests Joe Perches) to group
the test in a way to avoid multiples - and maybe confusing - returns.
So, I'll remove this one.

Sorry about the changelot, I missed it while making patch series, I'll
resend it.

Thanks,

Colin

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2016-02-15 16:27 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-02-12 18:05 [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header Colin Vidal
2016-02-12 18:05 ` [PATCH v3 2/5] Staging: rtl8188eu/core: Coding style fix, set conform spaces between identifiers Colin Vidal
2016-02-12 18:05   ` [PATCH v3 3/5] Staging: rtl8188eu/core: Coding style fix, set constant operand on right in tests Colin Vidal
2016-02-12 18:05     ` [PATCH v3 4/5] Staging: rtl8188eu/core: Coding style fix, avoid line over 80 characters Colin Vidal
2016-02-12 18:05       ` [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable Colin Vidal
2016-02-15  0:39         ` Greg Kroah-Hartman
2016-02-15 16:26           ` Colin Vidal
2016-02-15  0:40 ` [PATCH v3 1/5] Staging: rtl8188eu/core: remove paragraph which mention FSF address in comment header Greg Kroah-Hartman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).