linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable
@ 2016-10-25 20:58 frowand.list
  2016-10-25 20:58 ` [RFC PATCH 01/13] of: Remove comments that state the obvious frowand.list
                   ` (13 more replies)
  0 siblings, 14 replies; 34+ messages in thread
From: frowand.list @ 2016-10-25 20:58 UTC (permalink / raw)
  To: Rob Herring, pantelis.antoniou, Pantelis Antoniou
  Cc: devicetree, linux-kernel

From: Frank Rowand <frank.rowand@am.sony.com>

drivers/of/resolve.c is a bit difficult to read.  Clean it up so
that review of future overlay related patches will be easier.

Most of the patches are intended to be reformatting, with no functional
change.  Patches that are expected to have a functional change are:

  Remove comments that state the obvious, to reduce clutter
  Remove excessive printks to reduce clutter.
  Update structure of code to be clearer, also remove BUG_ON()
    Any functional change would reflect undefined behavior on bad overlay.
    Some error message text modified.
    BUG_ON() removed.
  Add back an error message, restructured

The patches are grouped into sets of changes that are intended
to be easy to verify correctness through simple inspection.

Some of the individual patches have checkpatch warnings or errors.
But after all patches are applied, the number of errors and
warnings from running checkpatch against the entire file are
reduced to two line size warnings.

These patches are only tested via the unit tests. I do not have
expansion boards to test with real hardware.


Frank Rowand (13):
  Remove comments that state the obvious, to reduce clutter
  Remove excessive printks to reduce clutter.
  Remove braces around single line blocks.
  Convert comparisons to zero or NULL to simplify logical expressions
  Rename functions to more accurately reflect what they do
  Remove prefix "__of_" and prefix "__" from local function names
  Rename variables to better reflect purpose or follow convention
  Update structure of code to be clearer, also remove BUG_ON()
  Remove redundant size check
  Update comments to reflect changes and increase clarity
  Add back an error message, restructured
  Move setting of pointer to beside test for non-null
  Remove unused variable overlay_symbols

 drivers/of/resolver.c | 349 ++++++++++++++++++++------------------------------
 1 file changed, 141 insertions(+), 208 deletions(-)

-- 
1.9.1

^ permalink raw reply	[flat|nested] 34+ messages in thread

end of thread, other threads:[~2016-10-27 20:21 UTC | newest]

Thread overview: 34+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-10-25 20:58 [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable frowand.list
2016-10-25 20:58 ` [RFC PATCH 01/13] of: Remove comments that state the obvious frowand.list
2016-10-25 21:29   ` Joe Perches
2016-10-27 12:18   ` Rob Herring
2016-10-27 16:02     ` Frank Rowand
2016-10-25 20:58 ` [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter frowand.list
2016-10-27 12:21   ` Rob Herring
2016-10-27 13:51     ` Pantelis Antoniou
2016-10-27 16:09       ` Frank Rowand
2016-10-27 16:04     ` Frank Rowand
2016-10-25 20:58 ` [RFC PATCH 03/13] of: Remove braces around single line blocks frowand.list
2016-10-25 20:58 ` [RFC PATCH 04/13] of: Convert comparisons to zero or NULL to simplify logical expressions frowand.list
2016-10-25 20:58 ` [RFC PATCH 05/13] of: Rename functions to more accurately reflect what they do frowand.list
2016-10-25 20:58 ` [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names frowand.list
2016-10-27 12:47   ` Rob Herring
2016-10-27 16:35     ` Frank Rowand
2016-10-27 16:58       ` Rob Herring
2016-10-27 18:25         ` Frank Rowand
2016-10-27 20:20           ` Rob Herring
2016-10-25 20:59 ` [RFC PATCH 07/13] of: Rename variables to better reflect purpose or follow convention frowand.list
2016-10-25 20:59 ` [RFC PATCH 08/13] of: Update structure of code, remove BUG_ON() frowand.list
2016-10-25 20:59 ` [RFC PATCH 09/13] of: Remove redundant size check frowand.list
2016-10-25 20:59 ` [RFC PATCH 10/13] of: Update comments to reflect changes and increase clarity frowand.list
2016-10-25 20:59 ` [RFC PATCH 11/13] of: Add back an error message, restructured frowand.list
2016-10-25 20:59 ` [RFC PATCH 12/13] of: Move setting of pointer to beside test for non-null frowand.list
2016-10-25 20:59 ` [RFC PATCH 13/13] of: Remove unused variable overlay_symbols frowand.list
2016-10-27 14:41   ` Pantelis Antoniou
2016-10-27 16:27     ` Frank Rowand
2016-10-27 16:53       ` Frank Rowand
2016-10-27 16:57         ` Frank Rowand
2016-10-25 21:02 ` [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable Frank Rowand
2016-10-27 12:03   ` Rob Herring
2016-10-27 16:36     ` Frank Rowand
2016-10-27 13:46   ` Pantelis Antoniou

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).