linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dave Chinner <david@fromorbit.com>
To: Jeff Moyer <jmoyer@redhat.com>
Cc: Jens Axboe <jaxboe@fusionio.com>,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	Zach Brown <zab@redhat.com>
Subject: Re: [patch,v2] bdi: add a user-tunable cpu_list for the bdi flusher threads
Date: Wed, 5 Dec 2012 07:35:39 +1100	[thread overview]
Message-ID: <20121204203539.GA16353@dastard> (raw)
In-Reply-To: <x49liddq3o0.fsf@segfault.boston.devel.redhat.com>

On Tue, Dec 04, 2012 at 09:42:55AM -0500, Jeff Moyer wrote:
> Dave Chinner <david@fromorbit.com> writes:
> 
> > On Mon, Dec 03, 2012 at 01:53:39PM -0500, Jeff Moyer wrote:
> >> +static ssize_t cpu_list_store(struct device *dev,
> >> +		struct device_attribute *attr, const char *buf, size_t count)
> >> +{
> >> +	struct backing_dev_info *bdi = dev_get_drvdata(dev);
> >> +	struct bdi_writeback *wb = &bdi->wb;
> >> +	cpumask_var_t newmask;
> >> +	ssize_t ret;
> >> +	struct task_struct *task;
> >> +
> >> +	if (!alloc_cpumask_var(&newmask, GFP_KERNEL))
> >> +		return -ENOMEM;
> >> +
> >> +	ret = cpulist_parse(buf, newmask);
> >> +	if (!ret) {
> >> +		spin_lock(&bdi->wb_lock);
> >> +		task = wb->task;
> >> +		if (task)
> >> +			get_task_struct(task);
> >> +		spin_unlock(&bdi->wb_lock);
> >> +		if (task) {
> >> +			ret = set_cpus_allowed_ptr(task, newmask);
> >> +			put_task_struct(task);
> >> +		}
> >
> > Why is this set here outside the bdi->flusher_cpumask_mutex?
> 
> The cpumask mutex protects updates to bdi->flusher_cpumask, it has
> nothing to do with the call to set_cpus_allowed.  We are protected from
> concurrent calls to cpu_list_store by the sysfs mutex that is taken on
> entry.  I understand that this is non-obvious, and it wouldn't be wrong
> to hold the mutex here.  If you'd like me to do that for clarity, that
> would be ok with me.

At minimum it needs a comment like this otherwise someone is going
to come along and ask "why is that safe?" like I just did. I'd
prefer the code to be obviously consistent to avoid the need for
commenting about the special case, especially when the obviously
correct code is simpler ;)

Cheers,

Dave.
-- 
Dave Chinner
david@fromorbit.com

  reply	other threads:[~2012-12-04 20:35 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-12-03 18:53 [patch,v2] bdi: add a user-tunable cpu_list for the bdi flusher threads Jeff Moyer
2012-12-04  2:34 ` Dave Chinner
2012-12-04 14:42   ` Jeff Moyer
2012-12-04 20:35     ` Dave Chinner [this message]
2012-12-04 20:14 ` Jens Axboe
2012-12-04 20:23   ` Jeff Moyer
2012-12-04 20:27     ` Jens Axboe
2012-12-04 22:26       ` Jeff Moyer
2012-12-05  7:43         ` Jens Axboe
2012-12-06 18:01         ` Tejun Heo
2012-12-06 18:08           ` Jeff Moyer
2012-12-06 18:13             ` Tejun Heo
2012-12-06 18:19           ` Jens Axboe
2012-12-06 18:22             ` Tejun Heo
2012-12-06 18:33               ` Jeff Moyer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20121204203539.GA16353@dastard \
    --to=david@fromorbit.com \
    --cc=jaxboe@fusionio.com \
    --cc=jmoyer@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=zab@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).