linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] ia64: rename cache_show to topology_cache_show
       [not found] <511e236a.o0ibbB2U8xMoURgd%fengguang.wu@intel.com>
@ 2013-02-15 12:38 ` Michal Hocko
  2013-02-15 13:05   ` Michal Hocko
  2013-02-15 22:46   ` Andrew Morton
  0 siblings, 2 replies; 6+ messages in thread
From: Michal Hocko @ 2013-02-15 12:38 UTC (permalink / raw)
  To: Andrew Morton
  Cc: linux-mm, linux-kernel, Wu Fengguang, Glauber Costa, Tony Luck,
	Fenghua Yu

Fenguang Wu has reported the following compile time issue
arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here

which has been introduced by 749c5415 (memcg: aggregate memcg cache
values in slabinfo). Let's rename ia64 local function to prevent from
the name conflict.

Reported-by: Fenguang Wu <fengguang.wu@intel.com>
Signed-off-by: Michal Hocko <mhocko@suse.cz>
---
 arch/ia64/kernel/topology.c |    5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/arch/ia64/kernel/topology.c b/arch/ia64/kernel/topology.c
index c64460b..d9e2152 100644
--- a/arch/ia64/kernel/topology.c
+++ b/arch/ia64/kernel/topology.c
@@ -275,7 +275,8 @@ static struct attribute * cache_default_attrs[] = {
 #define to_object(k) container_of(k, struct cache_info, kobj)
 #define to_attr(a) container_of(a, struct cache_attr, attr)
 
-static ssize_t cache_show(struct kobject * kobj, struct attribute * attr, char * buf)
+static ssize_t topology_cache_show(struct kobject * kobj,
+		struct attribute * attr, char * buf)
 {
 	struct cache_attr *fattr = to_attr(attr);
 	struct cache_info *this_leaf = to_object(kobj);
@@ -286,7 +287,7 @@ static ssize_t cache_show(struct kobject * kobj, struct attribute * attr, char *
 }
 
 static const struct sysfs_ops cache_sysfs_ops = {
-	.show   = cache_show
+	.show   = topology_cache_show
 };
 
 static struct kobj_type cache_ktype = {
-- 
1.7.10.4


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] ia64: rename cache_show to topology_cache_show
  2013-02-15 12:38 ` [PATCH] ia64: rename cache_show to topology_cache_show Michal Hocko
@ 2013-02-15 13:05   ` Michal Hocko
  2013-02-15 22:46   ` Andrew Morton
  1 sibling, 0 replies; 6+ messages in thread
From: Michal Hocko @ 2013-02-15 13:05 UTC (permalink / raw)
  To: Andrew Morton
  Cc: linux-mm, linux-kernel, Wu Fengguang, Glauber Costa, Tony Luck,
	Fenghua Yu

Scratch that. I should have checked origin/master which already fixed
that by 4fafc8c21487f6b5259d462e9bee98661a02390d

Sorry for the noise.

On Fri 15-02-13 13:38:24, Michal Hocko wrote:
> Fenguang Wu has reported the following compile time issue
> arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> 
> which has been introduced by 749c5415 (memcg: aggregate memcg cache
> values in slabinfo). Let's rename ia64 local function to prevent from
> the name conflict.
> 
> Reported-by: Fenguang Wu <fengguang.wu@intel.com>
> Signed-off-by: Michal Hocko <mhocko@suse.cz>
> ---
>  arch/ia64/kernel/topology.c |    5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/ia64/kernel/topology.c b/arch/ia64/kernel/topology.c
> index c64460b..d9e2152 100644
> --- a/arch/ia64/kernel/topology.c
> +++ b/arch/ia64/kernel/topology.c
> @@ -275,7 +275,8 @@ static struct attribute * cache_default_attrs[] = {
>  #define to_object(k) container_of(k, struct cache_info, kobj)
>  #define to_attr(a) container_of(a, struct cache_attr, attr)
>  
> -static ssize_t cache_show(struct kobject * kobj, struct attribute * attr, char * buf)
> +static ssize_t topology_cache_show(struct kobject * kobj,
> +		struct attribute * attr, char * buf)
>  {
>  	struct cache_attr *fattr = to_attr(attr);
>  	struct cache_info *this_leaf = to_object(kobj);
> @@ -286,7 +287,7 @@ static ssize_t cache_show(struct kobject * kobj, struct attribute * attr, char *
>  }
>  
>  static const struct sysfs_ops cache_sysfs_ops = {
> -	.show   = cache_show
> +	.show   = topology_cache_show
>  };
>  
>  static struct kobj_type cache_ktype = {
> -- 
> 1.7.10.4
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/

-- 
Michal Hocko
SUSE Labs

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] ia64: rename cache_show to topology_cache_show
  2013-02-15 12:38 ` [PATCH] ia64: rename cache_show to topology_cache_show Michal Hocko
  2013-02-15 13:05   ` Michal Hocko
@ 2013-02-15 22:46   ` Andrew Morton
  2013-02-16 12:18     ` Michal Hocko
  1 sibling, 1 reply; 6+ messages in thread
From: Andrew Morton @ 2013-02-15 22:46 UTC (permalink / raw)
  To: Michal Hocko
  Cc: linux-mm, linux-kernel, Wu Fengguang, Glauber Costa, Tony Luck,
	Fenghua Yu

On Fri, 15 Feb 2013 13:38:24 +0100
Michal Hocko <mhocko@suse.cz> wrote:

> Fenguang Wu has reported the following compile time issue
> arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> 
> which has been introduced by 749c5415 (memcg: aggregate memcg cache
> values in slabinfo). Let's rename ia64 local function to prevent from
> the name conflict.

Confused.  Tony fixed this ages ago?

: commit 4fafc8c21487f6b5259d462e9bee98661a02390d
: Author: Tony Luck <tony.luck@intel.com>
: Date:   Wed Nov 7 15:51:04 2012 -0800
: 
:     [IA64] Resolve name space collision for cache_show()
:     
:     We have a local static function named rather generically
:     "cache_show()". Changes in progress in the slab code want
:     to use this same name globally - so they are adding their
:     declaration to <linux/slab.h> which then causes the compiler
:     to choke with:
:     
:     arch/ia64/kernel/topology.c:278: error: conflicting types for 'cache_show'
:     
:     Fix by adding an "ia64_" prefix to our local function.



^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] ia64: rename cache_show to topology_cache_show
  2013-02-15 22:46   ` Andrew Morton
@ 2013-02-16 12:18     ` Michal Hocko
  2013-02-17  1:36       ` Fengguang Wu
  0 siblings, 1 reply; 6+ messages in thread
From: Michal Hocko @ 2013-02-16 12:18 UTC (permalink / raw)
  To: Andrew Morton
  Cc: linux-mm, linux-kernel, Wu Fengguang, Glauber Costa, Tony Luck,
	Fenghua Yu

On Fri 15-02-13 14:46:29, Andrew Morton wrote:
> On Fri, 15 Feb 2013 13:38:24 +0100
> Michal Hocko <mhocko@suse.cz> wrote:
> 
> > Fenguang Wu has reported the following compile time issue
> > arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> > include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> > 
> > which has been introduced by 749c5415 (memcg: aggregate memcg cache
> > values in slabinfo). Let's rename ia64 local function to prevent from
> > the name conflict.
> 
> Confused.  Tony fixed this ages ago?

Yes but it was after 3.7 so I didn't have it in my tree and I found out
only after I sent this email. Sorry about the confusion.
-- 
Michal Hocko
SUSE Labs

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] ia64: rename cache_show to topology_cache_show
  2013-02-16 12:18     ` Michal Hocko
@ 2013-02-17  1:36       ` Fengguang Wu
  2013-02-17  9:54         ` Michal Hocko
  0 siblings, 1 reply; 6+ messages in thread
From: Fengguang Wu @ 2013-02-17  1:36 UTC (permalink / raw)
  To: Michal Hocko
  Cc: Andrew Morton, linux-mm, linux-kernel, Glauber Costa, Tony Luck,
	Fenghua Yu

On Sat, Feb 16, 2013 at 01:18:53PM +0100, Michal Hocko wrote:
> On Fri 15-02-13 14:46:29, Andrew Morton wrote:
> > On Fri, 15 Feb 2013 13:38:24 +0100
> > Michal Hocko <mhocko@suse.cz> wrote:
> > 
> > > Fenguang Wu has reported the following compile time issue
> > > arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> > > include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> > > 
> > > which has been introduced by 749c5415 (memcg: aggregate memcg cache
> > > values in slabinfo). Let's rename ia64 local function to prevent from
> > > the name conflict.
> > 
> > Confused.  Tony fixed this ages ago?
> 
> Yes but it was after 3.7 so I didn't have it in my tree and I found out
> only after I sent this email. Sorry about the confusion.

Michal, sorry about the confusions. Does this indicate anything
improveable in the build test/notification?

Thanks,
Fengguang

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] ia64: rename cache_show to topology_cache_show
  2013-02-17  1:36       ` Fengguang Wu
@ 2013-02-17  9:54         ` Michal Hocko
  0 siblings, 0 replies; 6+ messages in thread
From: Michal Hocko @ 2013-02-17  9:54 UTC (permalink / raw)
  To: Fengguang Wu
  Cc: Andrew Morton, linux-mm, linux-kernel, Glauber Costa, Tony Luck,
	Fenghua Yu

On Sun 17-02-13 09:36:49, Wu Fengguang wrote:
> On Sat, Feb 16, 2013 at 01:18:53PM +0100, Michal Hocko wrote:
> > On Fri 15-02-13 14:46:29, Andrew Morton wrote:
> > > On Fri, 15 Feb 2013 13:38:24 +0100
> > > Michal Hocko <mhocko@suse.cz> wrote:
> > > 
> > > > Fenguang Wu has reported the following compile time issue
> > > > arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> > > > include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> > > > 
> > > > which has been introduced by 749c5415 (memcg: aggregate memcg cache
> > > > values in slabinfo). Let's rename ia64 local function to prevent from
> > > > the name conflict.
> > > 
> > > Confused.  Tony fixed this ages ago?
> > 
> > Yes but it was after 3.7 so I didn't have it in my tree and I found out
> > only after I sent this email. Sorry about the confusion.
> 
> Michal, sorry about the confusions. Does this indicate anything
> improveable in the build test/notification?

No, the message was clear. I should have checked Linus's tree before
posting the fix.

-- 
Michal Hocko
SUSE Labs

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2013-02-17  9:54 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <511e236a.o0ibbB2U8xMoURgd%fengguang.wu@intel.com>
2013-02-15 12:38 ` [PATCH] ia64: rename cache_show to topology_cache_show Michal Hocko
2013-02-15 13:05   ` Michal Hocko
2013-02-15 22:46   ` Andrew Morton
2013-02-16 12:18     ` Michal Hocko
2013-02-17  1:36       ` Fengguang Wu
2013-02-17  9:54         ` Michal Hocko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).