linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/3] drm/i915 / LPSS / mfd: Select correct PWM controller to use based on VBT
@ 2019-11-19 15:18 Hans de Goede
  2019-11-19 15:18 ` [PATCH 1/3] ACPI / LPSS: Rename pwm_backlight pwm-lookup to pwm_soc_backlight Hans de Goede
                   ` (4 more replies)
  0 siblings, 5 replies; 24+ messages in thread
From: Hans de Goede @ 2019-11-19 15:18 UTC (permalink / raw)
  To: Maarten Lankhorst, Jani Nikula, Joonas Lahtinen, Rodrigo Vivi,
	Ville Syrjälä,
	Rafael J . Wysocki, Len Brown, Lee Jones
  Cc: Hans de Goede, Andy Shevchenko, linux-acpi, intel-gfx, dri-devel,
	linux-kernel

Hi All,

This series needs to be merged through a single tree, to keep things
bisectable. I have even considered just squashing all 3 patches into 1,
but having separate commits seems better, but that does lead to an
intermediate state where the backlight sysfs interface will be broken
(and fixed 2 commits later). See below for some background info.

The changes to drivers/acpi/acpi_lpss.c and drivers/mfd/intel_soc_pmic_core.c
are quite small and should not lead to any conflicts, so I believe that
it would be best to merge this entire series through the drm-intel tree.

Lee, may I have your Acked-by for merging the mfd change through the
drm-intel tree?

Rafael, may I have your Acked-by for merging the acpi_lpss change through the
drm-intel tree?

Regards,

Hans

p.s.

The promised background info:

We have this long standing issue where instead of looking in the i915
VBT (Video BIOS Table) to see if we should use the PWM block of the SoC
or of the PMIC to control the backlight of a DSI panel, we rely on
drivers/acpi/acpi_lpss.c and/or drivers/mfd/intel_soc_pmic_core.c
registering a pwm with the generic name of "pwm_backlight" and then the
i915 panel code does a pwm_get(dev, "pwm_backlight").

We have some heuristics in drivers/acpi/acpi_lpss.c to not register the
lookup if a Crystal Cove PMIC is presend and the mfd/intel_soc_pmic_core.c
code simply assumes that since there is a PMIC the PMIC PWM block will
be used. Basically we are winging it.

Recently I've learned about 2 different BYT devices:
Point of View MOBII TAB-P800W
Acer Switch 10 SW5-012

Which use a Crystal Cove PMIC, yet the LCD is connected to the SoC/LPSS
PWM controller (and the VBT correctly indicates this), so here our old
heuristics fail.

This series renams the PWM lookups registered by the LPSS /
intel_soc_pmic_core.c code from "pwm_backlight" to "pwm_soc_backlight" resp.
"pwm_pmic_backlight" and in the LPSS case also dropping the heuristics when
to register the lookup. This combined with teaching the i915 panel to call
pwm_get for the right lookup-name depending on the VBT bits resolves this.


^ permalink raw reply	[flat|nested] 24+ messages in thread

end of thread, other threads:[~2019-12-18  9:39 UTC | newest]

Thread overview: 24+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-11-19 15:18 [PATCH 0/3] drm/i915 / LPSS / mfd: Select correct PWM controller to use based on VBT Hans de Goede
2019-11-19 15:18 ` [PATCH 1/3] ACPI / LPSS: Rename pwm_backlight pwm-lookup to pwm_soc_backlight Hans de Goede
2019-11-29 11:59   ` Rafael J. Wysocki
2019-11-19 15:18 ` [PATCH 2/3] mfd: intel_soc_pmic: Rename pwm_backlight pwm-lookup to pwm_pmic_backlight Hans de Goede
2019-12-10  8:51   ` Lee Jones
2019-12-11 17:29     ` Hans de Goede
2019-12-12  8:45       ` Lee Jones
2019-12-12 14:34         ` Hans de Goede
2019-12-12 15:52           ` Lee Jones
2019-12-12 19:02             ` Hans de Goede
2019-12-13  8:27               ` Lee Jones
2019-12-13 12:40                 ` Hans de Goede
2019-12-16  9:30                   ` Lee Jones
2019-12-16 10:04                     ` Hans de Goede
2019-12-17  8:11                       ` Lee Jones
2019-12-17 13:25                         ` Jani Nikula
2019-12-17 13:51                           ` Lee Jones
2019-12-18  7:14                             ` Jani Nikula
2019-12-18  9:38                               ` Lee Jones
2019-11-19 15:18 ` [PATCH 3/3] drm/i915: DSI: select correct PWM controller to use based on the VBT Hans de Goede
2019-11-19 15:47   ` Ville Syrjälä
2019-11-19 16:48     ` Hans de Goede
2019-11-19 15:43 ` [PATCH 0/3] drm/i915 / LPSS / mfd: Select correct PWM controller to use based on VBT Jani Nikula
2019-11-19 16:32 ` Andy Shevchenko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).