linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC][PATCH 0/3] objtool: Support implicit addend relocations
@ 2020-05-27 16:42 Matt Helsley
  2020-05-27 16:42 ` [RFC][PATCH 1/3] objtool: Rename rela to reloc Matt Helsley
                   ` (2 more replies)
  0 siblings, 3 replies; 12+ messages in thread
From: Matt Helsley @ 2020-05-27 16:42 UTC (permalink / raw)
  To: linux-kernel; +Cc: Josh Poimboeuf, Peter Zijlstra, Steven Rostedt, Matt Helsley

Future tools that use objtool to process ELF object files may require
reading or even modifying relocations with implicit addends. This
series cleans up the naming of the relocation struct in objtool,
variable names, and function names to be consistent with a more
generic use rather than being specific to those applying explicit
addends.

From there we switch to the specification compliant method of
finding the section the relocations apply to and fall back to the
old naming-heuristic basis if that's not available.

Finally, add support for implicit addends. Note that we don't
completely convert the orc tools to work with both kinds of
relocations. I'm hoping to get feedback on whether it makes more
sense to convert it or leave it as-is.

Matt Helsley (3):
  objtool: Rename rela to reloc
  objtool: Find relocation base section using sh_info
  objtool: Add support for relocations without addends

 tools/objtool/arch.h            |   2 +-
 tools/objtool/arch/x86/decode.c |   2 +-
 tools/objtool/check.c           | 196 +++++++++++++-------------
 tools/objtool/check.h           |   2 +-
 tools/objtool/elf.c             | 237 +++++++++++++++++++++-----------
 tools/objtool/elf.h             |  27 ++--
 tools/objtool/orc_gen.c         |  46 +++----
 tools/objtool/special.c         |  28 ++--
 8 files changed, 311 insertions(+), 229 deletions(-)


base-commit: 7c0577f4e609f7278ebd6d21e2de82b42f110944
prerequisite-patch-id: 387905b1da8b1293e7736b28fcc1585583e3e7cf
prerequisite-patch-id: 2fd7ac6c4dfd717ab117fc771623c01040188b4e
prerequisite-patch-id: bfeefd995e3f80d6fa0edfa2205d98be31fbee4e
prerequisite-patch-id: abcb5732607ad17f4c99c06b8bb83c9db1b15c42
prerequisite-patch-id: 5179e659d828bed48051d365f669a8ba3a36c206
-- 
2.20.1


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2020-05-28 19:15 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-27 16:42 [RFC][PATCH 0/3] objtool: Support implicit addend relocations Matt Helsley
2020-05-27 16:42 ` [RFC][PATCH 1/3] objtool: Rename rela to reloc Matt Helsley
2020-05-28 14:04   ` Josh Poimboeuf
2020-05-28 16:00     ` Matt Helsley
2020-05-27 16:42 ` [RFC][PATCH 2/3] objtool: Find relocation base section using sh_info Matt Helsley
2020-05-28 14:09   ` Josh Poimboeuf
2020-05-28 16:02     ` Matt Helsley
2020-05-28 17:00       ` Josh Poimboeuf
2020-05-28 19:15         ` Matt Helsley
2020-05-27 16:42 ` [RFC][PATCH 3/3] objtool: Add support for relocations without addends Matt Helsley
2020-05-28 14:24   ` Josh Poimboeuf
2020-05-28 16:05     ` Matt Helsley

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).