archive mirror
 help / color / mirror / Atom feed
* [2.4.23] IPv6 creates errors on my ethernet device
@ 2003-11-30 18:22 Marcello
  0 siblings, 0 replies; only message in thread
From: Marcello @ 2003-11-30 18:22 UTC (permalink / raw)
  To: Linux Kernel

Hi all ,

I have an ethernet card with a Realtek 8139C chip , and I've enabled 
IPv6 in my kernel  (2.4.23)

My ethernet card is connected to an ADSL Modem , an Ericsson HM220dp, 
and every (appoximatly)  50000 packets transmitted/recived by the 
devices ,if IPv6 is enabled , ifconfig reports an error in RX packages :

bash-2.05b# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:E0:7D:D5:0C:ED
          inet6 addr: fe80::2e0:7dff:fed5:ced/64 Scope:Link
          RX packets:95734 errors:1 dropped:0 overruns:0 frame:0
          TX packets:101956 errors:0 dropped:0 overruns:0 carrier:0
          collisions:465 txqueuelen:1000
          RX bytes:24717818 (23.5 Mb)  TX bytes:52543424 (50.1 Mb)
          Interrupt:17 Base address:0x5f00
The modem is connected at 10Mbps speed Half-Duplex .

If I disable IPv6 I don't see errors on the ethernet device , I've tried 
until 1500000 packets without errors .

What cause those errors? The only solution is disable IPv6?? I've found 
this problem on 2.4.22 too (I haven't tried IPv6 on previous kernels)



^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2003-11-30 18:17 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-11-30 18:22 [2.4.23] IPv6 creates errors on my ethernet device Marcello

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).