linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Marco Stornelli <marco.stornelli@gmail.com>
To: Anton Vorontsov <anton.vorontsov@linaro.org>
Cc: Bryan Freed <bfreed@chromium.org>,
	John Stultz <john.stultz@linaro.org>,
	linux-kernel@vger.kernel.org, keescook@chromium.org,
	sboyd@codeaurora.org, gregkh@linuxfoundation.org,
	Colin Cross <ccross@android.com>, Tony Luck <tony.luck@intel.com>,
	devicetree-discuss@lists.ozlabs.org
Subject: Re: [PATCH v6] pstore/ram: Add ramoops support for the Flattened Device Tree.
Date: Sat, 08 Sep 2012 09:23:40 +0200	[thread overview]
Message-ID: <504AF27C.9090601@gmail.com> (raw)
In-Reply-To: <20120908052907.GA4724@lizard>

Il 08/09/2012 07:29, Anton Vorontsov ha scritto:
> On Fri, Sep 07, 2012 at 11:29:36AM -0700, Bryan Freed wrote:
>> When called with a non-zero of_node, fill out a new ramoops_platform_data
>> with data from the specified Flattened Device Tree node.
>> Update ramoops documentation with the new FDT interface.
>> Update devicetree/binding documentation with pstore/ramoops.txt.
>
> Thanks for your work, Bryan! There were a few issues, I fixed
> them myself but I need your confirmation if you're OK w/ all
> the changes.
>
> First of, the Signed-off-by tag is missing, but I see it in v5.
> I also see that v5 had an Ack from Kees Cook, you did not preserve it,
> but generally it's a good idea to do so (if vX -> v(X+1) changes
> aren't drastic).
>
> [...]
>> +Optional properties:
>> +- record-size: Specifies the size of each record in preserved memory.
>> +- console-size: Specifies the size of the console log.
>> +- ftrace-size: Specifies the size of the ftrace log.
>> +- ecc-size: Specifies the size of each record's ECC buffer.
>> +- dump-oops: Specifies to dump oops in addition to panics.
>
> Personally, I don't see how this fits into device tree. It doesn't
> describe hardware, instead it's more a configuration stuff, which
> usually we try to not put into the device tree.
>
> It would be better to have a sane defaults in ramoops, instead of
> introducing more "virtual" stuff in the device tree. That is, feel
> free to change defaults if they seem to be not enough for most your
> setups.
>
> The only property that I see which is truly hardware-specific is
> ecc-size. E.g. if we're pretty sure that a specific hw does not
> need ecc, it's OK to avoid it. And some hw setups might require
> bigger ECC sizes, so it's OK to have it in the device-tree.
>
>> static struct ramoops_platform_data * __init
>> of_ramoops_platform_data(struct device *dev)
>
> You call this function from __devinit section, so using __init
> is an error.
>
> WARNING: fs/pstore/ramoops.o(.devinit.text+0x37): Section mismatch in reference from the function ramoops_probe() to the function .init.text:of_ramoops_platform_data()
> The function __devinit ramoops_probe() references
>
> I changed this to __devnit.
>
> [...]
>> +	pdata = devm_kzalloc(dev, sizeof(*pdata), GFP_KERNEL);
>> +	if (pdata == NULL)
>
> I wonder why people prefer to not write !pdata, which is more
> natural when reading the code.. :-)
>

I think it's the same for sizeof, it's much more readable
sizeof(struct ramoops_platform_data).

Marco

  reply	other threads:[~2012-09-08  7:30 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-09-07 18:29 [PATCH v6] pstore/ram: Add ramoops support for the Flattened Device Tree Bryan Freed
2012-09-08  5:29 ` Anton Vorontsov
2012-09-08  7:23   ` Marco Stornelli [this message]
2012-09-08  8:06     ` Anton Vorontsov
2012-09-08  8:27       ` Marco Stornelli
2012-09-17  6:23   ` Anton Vorontsov
2013-04-05  2:03     ` Rob Herring
2013-04-07 17:43       ` Anton Vorontsov
2013-04-08 19:54         ` Bryan Freed
2013-04-08 22:43           ` Rob Herring
2013-04-14 14:24           ` Anton Vorontsov
2016-01-06  1:04             ` Kees Cook
2016-01-06  1:06               ` Kees Cook
2016-01-06  1:42                 ` Rob Herring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=504AF27C.9090601@gmail.com \
    --to=marco.stornelli@gmail.com \
    --cc=anton.vorontsov@linaro.org \
    --cc=bfreed@chromium.org \
    --cc=ccross@android.com \
    --cc=devicetree-discuss@lists.ozlabs.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=john.stultz@linaro.org \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sboyd@codeaurora.org \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).