linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0269/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:55 Baole Ni
  2016-08-02 15:14 ` Bart Van Assche
  0 siblings, 1 reply; 4+ messages in thread
From: Baole Ni @ 2016-08-02 10:55 UTC (permalink / raw)
  To: dledford, sean.hefty, hal.rosenstock, bp
  Cc: linux-rdma, linux-kernel, leon, cl, erezsh, haggaie, markb,
	matanb, eli, guysh, ogerlitz, chuansheng.liu, baolex.ni

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/infiniband/ulp/ipoib/ipoib_main.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/infiniband/ulp/ipoib/ipoib_main.c b/drivers/infiniband/ulp/ipoib/ipoib_main.c
index 5f58c41..eed3e3c 100644
--- a/drivers/infiniband/ulp/ipoib/ipoib_main.c
+++ b/drivers/infiniband/ulp/ipoib/ipoib_main.c
@@ -65,15 +65,15 @@ MODULE_VERSION(DRV_VERSION);
 int ipoib_sendq_size __read_mostly = IPOIB_TX_RING_SIZE;
 int ipoib_recvq_size __read_mostly = IPOIB_RX_RING_SIZE;
 
-module_param_named(send_queue_size, ipoib_sendq_size, int, 0444);
+module_param_named(send_queue_size, ipoib_sendq_size, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(send_queue_size, "Number of descriptors in send queue");
-module_param_named(recv_queue_size, ipoib_recvq_size, int, 0444);
+module_param_named(recv_queue_size, ipoib_recvq_size, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(recv_queue_size, "Number of descriptors in receive queue");
 
 #ifdef CONFIG_INFINIBAND_IPOIB_DEBUG
 int ipoib_debug_level;
 
-module_param_named(debug_level, ipoib_debug_level, int, 0644);
+module_param_named(debug_level, ipoib_debug_level, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(debug_level, "Enable debug tracing if > 0");
 #endif
 
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 0269/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 10:55 [PATCH 0269/1285] Replace numeric parameter like 0444 with macro Baole Ni
@ 2016-08-02 15:14 ` Bart Van Assche
  2016-08-02 19:30   ` Steven Rostedt
  0 siblings, 1 reply; 4+ messages in thread
From: Bart Van Assche @ 2016-08-02 15:14 UTC (permalink / raw)
  To: Baole Ni, dledford, sean.hefty, hal.rosenstock, bp
  Cc: linux-rdma, linux-kernel, leon, cl, erezsh, haggaie, markb,
	matanb, eli, guysh, ogerlitz, chuansheng.liu

On 08/02/2016 03:55 AM, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
>  drivers/infiniband/ulp/ipoib/ipoib_main.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/infiniband/ulp/ipoib/ipoib_main.c b/drivers/infiniband/ulp/ipoib/ipoib_main.c
> index 5f58c41..eed3e3c 100644
> --- a/drivers/infiniband/ulp/ipoib/ipoib_main.c
> +++ b/drivers/infiniband/ulp/ipoib/ipoib_main.c
> @@ -65,15 +65,15 @@ MODULE_VERSION(DRV_VERSION);
>  int ipoib_sendq_size __read_mostly = IPOIB_TX_RING_SIZE;
>  int ipoib_recvq_size __read_mostly = IPOIB_RX_RING_SIZE;
>
> -module_param_named(send_queue_size, ipoib_sendq_size, int, 0444);
> +module_param_named(send_queue_size, ipoib_sendq_size, int, S_IRUSR | S_IRGRP | S_IROTH);
>  MODULE_PARM_DESC(send_queue_size, "Number of descriptors in send queue");
> -module_param_named(recv_queue_size, ipoib_recvq_size, int, 0444);
> +module_param_named(recv_queue_size, ipoib_recvq_size, int, S_IRUSR | S_IRGRP | S_IROTH);
>  MODULE_PARM_DESC(recv_queue_size, "Number of descriptors in receive queue");
>
>  #ifdef CONFIG_INFINIBAND_IPOIB_DEBUG
>  int ipoib_debug_level;
>
> -module_param_named(debug_level, ipoib_debug_level, int, 0644);
> +module_param_named(debug_level, ipoib_debug_level, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
>  MODULE_PARM_DESC(debug_level, "Enable debug tracing if > 0");
>  #endif

Hello Baole,

Please change 0444 into S_IRUGO and 0644 into S_IRUGO | S_IWUSR. The 
latter form is more compact and hence makes the code easier to read.

Thanks,

Bart.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 0269/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 15:14 ` Bart Van Assche
@ 2016-08-02 19:30   ` Steven Rostedt
  2016-08-02 20:04     ` Bart Van Assche
  0 siblings, 1 reply; 4+ messages in thread
From: Steven Rostedt @ 2016-08-02 19:30 UTC (permalink / raw)
  To: Bart Van Assche; +Cc: Baole Ni, linux-kernel, chuansheng.liu

[ removed most the Cc list ]

On Tue, Aug 02, 2016 at 08:14:10AM -0700, Bart Van Assche wrote:
> 
> Hello Baole,
> 
> Please change 0444 into S_IRUGO and 0644 into S_IRUGO | S_IWUSR. The latter
> form is more compact and hence makes the code easier to read.
> 

FYI, Linus already NACKed the entire thread.

-- Steve

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 0269/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 19:30   ` Steven Rostedt
@ 2016-08-02 20:04     ` Bart Van Assche
  0 siblings, 0 replies; 4+ messages in thread
From: Bart Van Assche @ 2016-08-02 20:04 UTC (permalink / raw)
  To: Steven Rostedt; +Cc: Baole Ni, linux-kernel, chuansheng.liu

On 08/02/2016 12:30 PM, Steven Rostedt wrote:
> [ removed most the Cc list ]
> On Tue, Aug 02, 2016 at 08:14:10AM -0700, Bart Van Assche wrote:
>> Please change 0444 into S_IRUGO and 0644 into S_IRUGO | S_IWUSR. The latter
>> form is more compact and hence makes the code easier to read.
>
> FYI, Linus already NACKed the entire thread.

Hello Steven,

Thanks for letting me know. I didn't consider these patches as very 
valuable anyway.

Bart.

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2016-08-02 20:40 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:55 [PATCH 0269/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-02 15:14 ` Bart Van Assche
2016-08-02 19:30   ` Steven Rostedt
2016-08-02 20:04     ` Bart Van Assche

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).