archive mirror
 help / color / mirror / Atom feed
* severe FS corruption with 2.4.6-pre2 + IBM jfs 0.3.4 patch
@ 2001-06-12 20:39 David Mansfield
  2001-06-14 18:18 ` Alan Cox
  0 siblings, 1 reply; 5+ messages in thread
From: David Mansfield @ 2001-06-12 20:39 UTC (permalink / raw)
  To: lkml, jfs-discussion

It's probably a JFS issue, but I thought I'd report this in case someone
is collecting and correlating filesystem corruption messages (Alan?). 
Here is my sad story.

I have an Athlon 700MHZ, 256mb ram, AIC7XXX w 2/U2W drives system.  I've
been running JFS on a small partition for a few weeks, JFS 0.3.1 under
2.4.5, 0.3.3 with 2.4.6-pre1 and yesterday I tried 2.4.6-pre2 with jfs

I rebooted into the new kernel, and noticed one of those Red Hat [FAIL]
messages that pops up during the rc/init stages.  It's a config problem
I've had for months, nothing new, but I decided I'd take care of it.  I
logged into the console, ran emacs and it segfaulted.  I ran 'dmesg' but
there was nothing (I was expecting to see an oops).  I ran emacs again,
segfault.  I tried logging in to another console, hang.  

At this point I hit sysrq-T, and of everything that spewed by, I noticed
one process (which had scrolled to far off the screen to see the PID)
with a whole lot of
<dbdbdbdb> <dbdbdbdb> <dbdbdbdb> in the stack trace.

At this point I did sysrq-S-U-B and rebooted.  End of story.

My filesystems were severely f***ed at this point.  A total of about 60
seconds running this kernel and I was dead.  My OS partition was
trashed, about 1/2 of it was unrecoverable.  My home partition fared
better (good luck) but still had plenty of trashed inodes.

I've never had problems with any kernels before this...

That's my story,

David Mansfield                                           (718) 963-2020
Ultramaster Group, LLC                     

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2001-06-15  9:09 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2001-06-12 20:39 severe FS corruption with 2.4.6-pre2 + IBM jfs 0.3.4 patch David Mansfield
2001-06-14 18:18 ` Alan Cox
2001-06-14 18:25   ` Jeff Garzik
2001-06-15  6:55     ` [Jfs-discussion] " Andi Kleen
2001-06-15  9:08       ` Luigi Genoni

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).