linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v8 00/22] Introduce the Counter character device interface
@ 2021-02-12 12:13 William Breathitt Gray
  2021-02-12 12:13 ` [PATCH v8 01/22] docs: counter: Consolidate Counter sysfs attributes documentation William Breathitt Gray
                   ` (21 more replies)
  0 siblings, 22 replies; 70+ messages in thread
From: William Breathitt Gray @ 2021-02-12 12:13 UTC (permalink / raw)
  To: jic23
  Cc: kernel, linux-stm32, a.fatoum, kamel.bouhara, gwendal,
	alexandre.belloni, david, linux-iio, linux-kernel,
	linux-arm-kernel, syednwaris, patrick.havelange, fabrice.gasnier,
	mcoquelin.stm32, alexandre.torgue, o.rempel,
	William Breathitt Gray

Changes in v8:
 - Consolidated Counter sysfs ABI documentation to single file
 - Added events_queue_size sysfs attribute to allow users to dynamically
   resize the events queue
 - Fixed markup syntax and typos in generic-counter.rst
 - Improved documentation in include/uapi/linux/counter.h and friends
 - Renamed COUNTER_LOAD_WATCHES_IOCTL to COUNTER_ENABLE_EVENTS_IOCTL;
   Renamed COUNTER_CLEAR_WATCHES_IOCTL to COUNTER_DISABLE_EVENTS_IOCTL
 - Renamed the struct counter_event "errno" member to "status"
 - Dropped the "irq_trigger" 104-QUAD-8 sysfs attribute; this
   functionality now occurs implicitly via the Counter chrdev interface
 - Return -ERANGE where appropriate instead of -EINVAL
 - Simplified switch exit paths; return early when possible
 - Call devm_request_irq() before devm_counter_register() for 104-quad-8
 - Renamed devm_counter_unregister() to more apt devm_counter_release()
 - Use enum counter_scope for scope values in counter-sysfs.c
 - Use sysfs_emit() instead of sprintf() where appropriate
 - Renamed find_in_string_array() to more apt counter_find_enum()
 - Renamed *_action_get() and *_action_write() to *_action_read() and
   *_action_write() to match new naming convention of Counter callbacks
 - Use "Counter function" naming convention instead of "Counter count
   function" to avoid confusion about scope

I pulled out a lot of bits and pieces to their own patches; hopefully
that makes reviewing this patchset much simpler than before. This
patchset is also available on my personal public git repo for anyone who
wants a quick way to clone:
https://gitlab.com/vilhelmgray/iio/-/tree/counter_chrdev_v8

The patches preceding "counter: Internalize sysfs interface code" are
primarily cleanup and fixes that can be picked up and applied now to the
IIO tree if so desired. The "counter: Internalize sysfs interface code"
patch as well may be considered for pickup because it is relatively safe
and makes no changes to the userspace interface.

To summarize the main points of this patchset: there are no changes to
the existing Counter sysfs userspace interface; a Counter character
device interface is introduced that allows Counter events and associated
data to be read() by userspace; the events_configure() and
watch_validate() driver callbacks are introduced to support Counter
events; and IRQ support is added to the 104-QUAD-8 driver, serving as an
example of how to support the new Counter events functionality.

Something that should still be discussed: should the struct
counter_event "status" member be 8 bits or 32 bits wide? This member
will provide the return status (system error number) of an event
operation.

William Breathitt Gray (22):
  docs: counter: Consolidate Counter sysfs attributes documentation
  docs: counter: Fix spelling
  counter: 104-quad-8: Return error when invalid mode during
    ceiling_write
  counter: 104-quad-8: Annotate hardware config module parameter
  counter: 104-quad-8: Add const qualifiers for
    quad8_preset_register_set
  counter: 104-quad-8: Add const qualifier for functions_list array
  counter: 104-quad-8: Add const qualifier for actions_list array
  counter: ftm-quaddec: Add const qualifier for actions_list array
  counter: Return error code on invalid modes
  counter: Standardize to ERANGE for limit exceeded errors
  counter: Rename counter_signal_value to counter_signal_level
  counter: Rename counter_count_function to counter_function
  counter: Internalize sysfs interface code
  counter: Update counter.h comments to reflect sysfs internalization
  docs: counter: Update to reflect sysfs internalization
  counter: Move counter enums to uapi header
  counter: Add character device interface
  docs: counter: Document character device interface
  counter: Implement extension*_name sysfs attributes
  counter: Implement events_queue_size sysfs attribute
  counter: 104-quad-8: Replace mutex with spinlock
  counter: 104-quad-8: Add IRQ support for the ACCES 104-QUAD-8

 Documentation/ABI/testing/sysfs-bus-counter   |  100 +-
 .../ABI/testing/sysfs-bus-counter-104-quad-8  |   61 -
 .../ABI/testing/sysfs-bus-counter-ftm-quaddec |   16 -
 Documentation/driver-api/generic-counter.rst  |  426 ++++-
 .../userspace-api/ioctl/ioctl-number.rst      |    1 +
 MAINTAINERS                                   |    6 +-
 drivers/counter/104-quad-8.c                  |  751 +++++----
 drivers/counter/Kconfig                       |    6 +-
 drivers/counter/Makefile                      |    1 +
 drivers/counter/counter-chrdev.c              |  519 ++++++
 drivers/counter/counter-chrdev.h              |   18 +
 drivers/counter/counter-core.c                |  185 ++
 drivers/counter/counter-sysfs.c               |  889 ++++++++++
 drivers/counter/counter-sysfs.h               |   13 +
 drivers/counter/counter.c                     | 1496 -----------------
 drivers/counter/ftm-quaddec.c                 |   69 +-
 drivers/counter/microchip-tcb-capture.c       |  105 +-
 drivers/counter/stm32-lptimer-cnt.c           |  186 +-
 drivers/counter/stm32-timer-cnt.c             |  187 +--
 drivers/counter/ti-eqep.c                     |  226 ++-
 include/linux/counter.h                       |  716 ++++----
 include/linux/counter_enum.h                  |   45 -
 include/uapi/linux/counter.h                  |  126 ++
 23 files changed, 3363 insertions(+), 2785 deletions(-)
 delete mode 100644 Documentation/ABI/testing/sysfs-bus-counter-104-quad-8
 delete mode 100644 Documentation/ABI/testing/sysfs-bus-counter-ftm-quaddec
 create mode 100644 drivers/counter/counter-chrdev.c
 create mode 100644 drivers/counter/counter-chrdev.h
 create mode 100644 drivers/counter/counter-core.c
 create mode 100644 drivers/counter/counter-sysfs.c
 create mode 100644 drivers/counter/counter-sysfs.h
 delete mode 100644 drivers/counter/counter.c
 delete mode 100644 include/linux/counter_enum.h
 create mode 100644 include/uapi/linux/counter.h


base-commit: b72d4f6a5122a78941ce5a3147685d6a44939a75
-- 
2.30.0


^ permalink raw reply	[flat|nested] 70+ messages in thread

end of thread, other threads:[~2021-02-28  2:47 UTC | newest]

Thread overview: 70+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-12 12:13 [PATCH v8 00/22] Introduce the Counter character device interface William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 01/22] docs: counter: Consolidate Counter sysfs attributes documentation William Breathitt Gray
2021-02-14 16:57   ` Jonathan Cameron
2021-02-15 11:05     ` William Breathitt Gray
2021-02-20 16:25   ` David Lechner
2021-02-12 12:13 ` [PATCH v8 02/22] docs: counter: Fix spelling William Breathitt Gray
2021-02-20 16:26   ` David Lechner
2021-02-12 12:13 ` [PATCH v8 03/22] counter: 104-quad-8: Return error when invalid mode during ceiling_write William Breathitt Gray
2021-02-20 16:30   ` David Lechner
2021-02-22  2:06     ` William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 04/22] counter: 104-quad-8: Annotate hardware config module parameter William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 05/22] counter: 104-quad-8: Add const qualifiers for quad8_preset_register_set William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 06/22] counter: 104-quad-8: Add const qualifier for functions_list array William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 07/22] counter: 104-quad-8: Add const qualifier for actions_list array William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 08/22] counter: ftm-quaddec: " William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 09/22] counter: Return error code on invalid modes William Breathitt Gray
2021-02-14 17:07   ` Jonathan Cameron
2021-02-20 16:43   ` David Lechner
2021-02-22  4:42     ` William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 10/22] counter: Standardize to ERANGE for limit exceeded errors William Breathitt Gray
2021-02-14 17:10   ` Jonathan Cameron
2021-02-16  1:26     ` William Breathitt Gray
2021-02-21 14:03       ` Jonathan Cameron
2021-02-20 16:48   ` David Lechner
2021-02-12 12:13 ` [PATCH v8 11/22] counter: Rename counter_signal_value to counter_signal_level William Breathitt Gray
2021-02-20 16:52   ` David Lechner
2021-02-12 12:13 ` [PATCH v8 12/22] counter: Rename counter_count_function to counter_function William Breathitt Gray
2021-02-14 17:13   ` Jonathan Cameron
2021-02-20 16:56     ` David Lechner
2021-02-23  5:14       ` William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 13/22] counter: Internalize sysfs interface code William Breathitt Gray
2021-02-14 17:32   ` Jonathan Cameron
2021-02-20 17:50   ` David Lechner
2021-02-12 12:13 ` [PATCH v8 14/22] counter: Update counter.h comments to reflect sysfs internalization William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 15/22] docs: counter: Update " William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 16/22] counter: Move counter enums to uapi header William Breathitt Gray
2021-02-20 23:55   ` David Lechner
2021-02-12 12:13 ` [PATCH v8 17/22] counter: Add character device interface William Breathitt Gray
2021-02-14 18:06   ` Jonathan Cameron
2021-02-24  5:34     ` William Breathitt Gray
2021-02-15  9:24   ` Oleksij Rempel
2021-02-16  1:53     ` William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 18/22] docs: counter: Document " William Breathitt Gray
2021-02-14 17:48   ` Jonathan Cameron
2021-02-22 10:11     ` Pavel Machek
2021-02-26  0:27       ` William Breathitt Gray
2021-02-26  0:22     ` William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 19/22] counter: Implement extension*_name sysfs attributes William Breathitt Gray
2021-02-14 18:09   ` Jonathan Cameron
2021-02-19  8:51     ` William Breathitt Gray
2021-02-21 14:05       ` Jonathan Cameron
2021-02-25 23:32         ` William Breathitt Gray
2021-02-27 15:14           ` Jonathan Cameron
2021-02-12 12:13 ` [PATCH v8 20/22] counter: Implement events_queue_size sysfs attribute William Breathitt Gray
2021-02-14 18:11   ` Jonathan Cameron
2021-02-18 10:32     ` William Breathitt Gray
2021-02-21 15:51       ` Jonathan Cameron
2021-02-26  0:03         ` William Breathitt Gray
2021-02-27  0:14           ` David Lechner
2021-02-27  0:20             ` William Breathitt Gray
2021-02-27 15:18           ` Jonathan Cameron
2021-02-28  2:46             ` William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 21/22] counter: 104-quad-8: Replace mutex with spinlock William Breathitt Gray
2021-02-14 18:19   ` Jonathan Cameron
2021-02-16  2:16     ` William Breathitt Gray
2021-02-16 19:27       ` Jonathan Cameron
2021-02-18 10:16         ` William Breathitt Gray
2021-02-12 12:13 ` [PATCH v8 22/22] counter: 104-quad-8: Add IRQ support for the ACCES 104-QUAD-8 William Breathitt Gray
2021-02-14 18:24   ` Jonathan Cameron
2021-02-19  9:21     ` William Breathitt Gray

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).