linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC PATCH v3 0/6] x86/entry/64: interrupt entry size reduction
@ 2018-02-20 21:01 Dominik Brodowski
  2018-02-20 21:01 ` [RFC PATCH v3 1/6] x86/entry/64: move PUSH_AND_CLEAR_REGS from interrupt macro to helper function Dominik Brodowski
                   ` (5 more replies)
  0 siblings, 6 replies; 23+ messages in thread
From: Dominik Brodowski @ 2018-02-20 21:01 UTC (permalink / raw)
  To: linux-kernel, mingo, x86, brgerst, luto, jpoimboe
  Cc: torvalds, ak, tglx, dan.j.williams

Here is another re-spin of the interrupt entry size reduction patchset,
which applies on top of tip/pti and tries to implement what Linus
suggested a few days ago.[*]

Patch 1/5 provides the most significant cuttings (-3k) and gets us below
the text size of entry_64.o (by about 2k) compared to before I started
meddling with it. This patch is the most evolved of the set, yet saw the
helper function being renamed since v2.

The other five patches still need more discussion on whether each
additional step and the code complexity it adds is really worth it. And
stringent review, of course.

Overall, these patches provide for a sizeable cutting of up to 4.5k compared
to tip/pti:

   text	   data	    bss	    dec	    hex	filename
  19500	      0	      0	  19500	   4c2c	entry_64.o-orig (before 2e3f0098bc45)
  21088	      0	      0	  21088	   5260	entry_64.o-pti (as of ced5d0bf603f)
  18006	      0	      0	  18006	   4656	entry_64.o (patch 1/6)
  16623	      0	      0	  16623	   40ef	entry_64.o (patch 6/6)

Changes for v3:
- patch 1:
	- rename interrupt_helper to interrupt_entry (suggested by Josh
	  Poimboeuf)
	- do not add cld to interrupt_entry yet
- patch 2 (follow-up changes only)
- patch 3:
	- move cld from interrupt macro to interrupt_entry (suggestion
	  by Linus Torvalds to make this more explicit)
	- do not add cld to switch_to_thread_stack wrapper function, but
	  keep cld where it is entry_INT80_compat.
- patch 4: (follow-up changes only)
- patch 5 (NEW):
	- move ASM_CLAC to interrupt helper (suggested by Brian Gerst)
- patch 6 (was patch 5/5 in v2):
	- update commentary (suggested by Josh Poimboeuf)
	- remove unused UNWIND hint from entry_64_compat.S (suggested by
	  Josh Poimboeuf)

Changes for v2:
- patch 1 (unchanged)
- patch 2:
	- use leaq 8() instead of mov+addq in ENTER_IRQ_STACK (suggested
	  by Brian Gerst)
	- add UNWIND_HINT_REGS indirect=1 after call to interrupt_helper;
	  update size information accordingly
- patch 3:
	- add cld to switch_to_thread_stack wrapper function
	- improve commit message
	- update size information
- patch 4:
	- add UNWIND_HINT_REGS indirect=1 to the now-removed interrupt
	  macro
- patch 5 (NEW):
	- open-code the DO_SWITCH_TO_THREAD_STACK macro (suggested by
	  Brian Gerst)
	- improve (?) UNWIND hints

[*] http://lkml.kernel.org/r/CA+55aFwLTF3EtaQ4OpDv2UM41J=EU7gfemv=eVq+uQi31-usSg@mail.gmail.com

Dominik Brodowski (6):
  x86/entry/64: move PUSH_AND_CLEAR_REGS from interrupt macro to helper
    function
  x86/entry/64: move ENTER_IRQ_STACK from interrupt macro to
    interrupt_entry
  x86/entry/64: move switch_to_thread_stack to interrupt_entry
  x86/entry/64: remove interrupt macro
  x86/entry/64: move ASM_CLAC to interrupt_entry
  x86/entry/64: open-code switch_to_thread_stack

 arch/x86/entry/entry_64.S        | 132 ++++++++++++++++++++++++---------------
 arch/x86/entry/entry_64_compat.S |  17 ++++-
 2 files changed, 98 insertions(+), 51 deletions(-)

-- 
2.16.2

^ permalink raw reply	[flat|nested] 23+ messages in thread

end of thread, other threads:[~2018-02-21 17:03 UTC | newest]

Thread overview: 23+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-02-20 21:01 [RFC PATCH v3 0/6] x86/entry/64: interrupt entry size reduction Dominik Brodowski
2018-02-20 21:01 ` [RFC PATCH v3 1/6] x86/entry/64: move PUSH_AND_CLEAR_REGS from interrupt macro to helper function Dominik Brodowski
2018-02-20 22:25   ` Linus Torvalds
2018-02-21  2:42     ` [PATCH] x86/entry/64: Simplify ENCODE_FRAME_POINTER Josh Poimboeuf
2018-02-21 10:50       ` [tip:x86/pti] " tip-bot for Josh Poimboeuf
2018-02-21 17:03       ` tip-bot for Josh Poimboeuf
2018-02-21 10:45   ` [tip:x86/pti] x86/entry/64: Move PUSH_AND_CLEAR_REGS from interrupt macro to helper function tip-bot for Dominik Brodowski
2018-02-21 16:58   ` tip-bot for Dominik Brodowski
2018-02-20 21:01 ` [RFC PATCH v3 2/6] x86/entry/64: move ENTER_IRQ_STACK from interrupt macro to interrupt_entry Dominik Brodowski
2018-02-21 10:46   ` [tip:x86/pti] x86/entry/64: Move " tip-bot for Dominik Brodowski
2018-02-21 16:59   ` tip-bot for Dominik Brodowski
2018-02-20 21:01 ` [RFC PATCH v3 3/6] x86/entry/64: move switch_to_thread_stack " Dominik Brodowski
2018-02-21 10:46   ` [tip:x86/pti] x86/entry/64: Move the switch_to_thread_stack() call to interrupt_entry() tip-bot for Dominik Brodowski
2018-02-21 16:59   ` tip-bot for Dominik Brodowski
2018-02-20 21:01 ` [RFC PATCH v3 4/6] x86/entry/64: remove interrupt macro Dominik Brodowski
2018-02-21 10:47   ` [tip:x86/pti] x86/entry/64: Remove 'interrupt' macro tip-bot for Dominik Brodowski
2018-02-21 17:00   ` tip-bot for Dominik Brodowski
2018-02-20 21:01 ` [RFC PATCH v3 5/6] x86/entry/64: move ASM_CLAC to interrupt_entry Dominik Brodowski
2018-02-21 10:47   ` [tip:x86/pti] x86/entry/64: Move ASM_CLAC to interrupt_entry() tip-bot for Dominik Brodowski
2018-02-21 17:00   ` tip-bot for Dominik Brodowski
2018-02-20 21:01 ` [RFC PATCH v3 6/6] x86/entry/64: open-code switch_to_thread_stack Dominik Brodowski
2018-02-21 10:48   ` [tip:x86/pti] x86/entry/64: Open-code switch_to_thread_stack() tip-bot for Dominik Brodowski
2018-02-21 17:01   ` tip-bot for Dominik Brodowski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).