netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC PATCH v3 00/12] Generic zcopy_* functions
@ 2020-12-30 19:12 Jonathan Lemon
  2020-12-30 19:12 ` [RFC PATCH v3 01/12] skbuff: remove unused skb_zcopy_abort function Jonathan Lemon
                   ` (12 more replies)
  0 siblings, 13 replies; 17+ messages in thread
From: Jonathan Lemon @ 2020-12-30 19:12 UTC (permalink / raw)
  To: netdev, willemdebruijn.kernel, edumazet, dsahern; +Cc: kernel-team

From: Jonathan Lemon <bsd@fb.com>

This is set of cleanup patches for zerocopy which are intended
to allow a introduction of a different zerocopy implementation.

The top level API will use the skb_zcopy_*() functions, while
the current TCP specific zerocopy ends up using msg_zerocopy_*()
calls.

There should be no functional changes from these patches.

v2->v3:
 Rename zc_flags to 'flags'.  Use SKBFL_xxx naming, similar
 to the SKBTX_xx naming.  Leave zerocopy_success naming alone.
 Reorder patches.

v1->v2:
 Break changes to skb_zcopy_put into 3 patches, in order to
 make it easier to follow the changes.  Add Willem's suggestion
 about renaming sock_zerocopy_

Patch 1: remove dead function
Patch 2: simplify sock_zerocopy_put
Patch 3: push status/refcounts into sock_zerocopy_callback
Patch 4: replace sock_zerocopy_put with skb_zcopy_put
Patch 5: rename sock_zerocopy_get
Patch 6:
  Add an optional skb parameter to callback, allowing access to
  the attached skb from the callback.
Patch 7:
  Add skb_zcopy_put_abort, and move zerocopy logic into the
  callback function.  There unfortunately is still a check
  against the callback type here.
Patch 8: Relocate skb_zcopy_clear() in skb_release_data()
Patch 9: rename sock_zerocopy_ to msg_zerocopy_
Patch 10:
  Move zerocopy bits from tx_flags into flags for clarity.
  These bits will be used in the RX path in the future.
Patch 11:
  Set the skb flags from the ubuf being attached, instead
  of a fixed value, allowing different initialization types.
Patch 12: Replace open-coded assignments with skb_zcopy_init()

Jonathan Lemon (12):
  skbuff: remove unused skb_zcopy_abort function
  skbuff: simplify sock_zerocopy_put
  skbuff: Push status and refcounts into sock_zerocopy_callback
  skbuff: replace sock_zerocopy_put() with skb_zcopy_put()
  skbuff: replace sock_zerocopy_get with skb_zcopy_get
  skbuff: Add skb parameter to the ubuf zerocopy callback
  skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort
  skbuff: Call skb_zcopy_clear() before unref'ing fragments
  skbuff: rename sock_zerocopy_* to msg_zerocopy_*
  net: group skb_shinfo zerocopy related bits together.
  skbuff: add flags to ubuf_info for ubuf setup
  tap/tun: add skb_zcopy_init() helper for initialization.

 drivers/net/tap.c                   |   6 +-
 drivers/net/tun.c                   |   6 +-
 drivers/net/xen-netback/common.h    |   3 +-
 drivers/net/xen-netback/interface.c |   4 +-
 drivers/net/xen-netback/netback.c   |   5 +-
 drivers/vhost/net.c                 |   4 +-
 include/linux/skbuff.h              | 106 +++++++++++++++-------------
 net/core/skbuff.c                   |  65 ++++++++---------
 net/ipv4/ip_output.c                |   5 +-
 net/ipv4/tcp.c                      |   8 +--
 net/ipv6/ip6_output.c               |   5 +-
 net/kcm/kcmsock.c                   |   4 +-
 12 files changed, 113 insertions(+), 108 deletions(-)

-- 
2.24.1


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2021-01-05  5:39 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-30 19:12 [RFC PATCH v3 00/12] Generic zcopy_* functions Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 01/12] skbuff: remove unused skb_zcopy_abort function Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 02/12] skbuff: simplify sock_zerocopy_put Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 03/12] skbuff: Push status and refcounts into sock_zerocopy_callback Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 04/12] skbuff: replace sock_zerocopy_put() with skb_zcopy_put() Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 05/12] skbuff: replace sock_zerocopy_get with skb_zcopy_get Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 06/12] skbuff: Add skb parameter to the ubuf zerocopy callback Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 07/12] skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 08/12] skbuff: Call skb_zcopy_clear() before unref'ing fragments Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 09/12] skbuff: rename sock_zerocopy_* to msg_zerocopy_* Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 10/12] net: group skb_shinfo zerocopy related bits together Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 11/12] skbuff: add flags to ubuf_info for ubuf setup Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 12/12] tap/tun: add skb_zcopy_init() helper for initialization Jonathan Lemon
2021-01-04 17:39 ` [RFC PATCH v3 00/12] Generic zcopy_* functions Willem de Bruijn
2021-01-05  4:17   ` Jonathan Lemon
2021-01-05  4:22     ` Willem de Bruijn
2021-01-05  5:38       ` Jonathan Lemon

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).