ntfs3.lists.linux.dev archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/4] Introduce bitmap_size()
@ 2022-07-02 18:28 Christophe JAILLET
  2022-07-02 18:29 ` [PATCH 1/4] s390/cio: Rename bitmap_size() as idset_bitmap_size() Christophe JAILLET
                   ` (4 more replies)
  0 siblings, 5 replies; 21+ messages in thread
From: Christophe JAILLET @ 2022-07-02 18:28 UTC (permalink / raw)
  To: agk, snitzer, dm-devel, vneethv, oberpar, hca, gor, agordeev,
	borntraeger, svens, almaz.alexandrovich, yury.norov,
	andriy.shevchenko, linux
  Cc: linux-s390, ntfs3, linux-kernel, kernel-janitors, Christophe JAILLET

This serie introduces bitmap_size() which returns the size, in bytes, of a
bitmap. Such a function is useful to simplify some drivers that use vmalloc() or
other functions to allocate some butmaps.
It also hides some implementation details about how bitmaps are stored (array of
longs)

Before introducing this function in patch 3, patch 1 and 2 rename some functions
with the same name but with different meaning.

Finaly, patch 4 makes use of the new function in bitmap.h.


Other follow-up patches to simplify some drivers will be proposed later if/when
this serie is merged.

Christophe JAILLET (4):
  s390/cio: Rename bitmap_size() as idset_bitmap_size()
  fs/ntfs3: Rename bitmap_size() as ntfs3_bitmap_size()
  bitmap: Introduce bitmap_size()
  bitmap: Use bitmap_size()

 drivers/md/dm-clone-metadata.c |  5 -----
 drivers/s390/cio/idset.c       |  8 ++++----
 fs/ntfs3/bitmap.c              |  4 ++--
 fs/ntfs3/fsntfs.c              |  2 +-
 fs/ntfs3/index.c               |  6 +++---
 fs/ntfs3/ntfs_fs.h             |  2 +-
 fs/ntfs3/super.c               |  2 +-
 include/linux/bitmap.h         | 15 +++++++++------
 lib/math/prime_numbers.c       |  2 --
 9 files changed, 21 insertions(+), 25 deletions(-)

-- 
2.34.1


^ permalink raw reply	[flat|nested] 21+ messages in thread

end of thread, other threads:[~2022-07-04  4:28 UTC | newest]

Thread overview: 21+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-07-02 18:28 [PATCH 0/4] Introduce bitmap_size() Christophe JAILLET
2022-07-02 18:29 ` [PATCH 1/4] s390/cio: Rename bitmap_size() as idset_bitmap_size() Christophe JAILLET
2022-07-02 18:54   ` Andy Shevchenko
2022-07-02 19:24     ` Christophe JAILLET
2022-07-02 19:32       ` Andy Shevchenko
2022-07-02 19:42         ` Christophe JAILLET
2022-07-02 20:46   ` Yury Norov
2022-07-04  4:28   ` Vineeth Vijayan
2022-07-02 18:29 ` [PATCH 2/4] fs/ntfs3: Rename bitmap_size() as ntfs3_bitmap_size() Christophe JAILLET
2022-07-02 18:58   ` Andy Shevchenko
2022-07-02 19:37     ` Christophe JAILLET
2022-07-02 20:57   ` Yury Norov
2022-07-02 18:29 ` [PATCH 3/4] bitmap: Introduce bitmap_size() Christophe JAILLET
2022-07-02 18:59   ` Andy Shevchenko
2022-07-02 21:09   ` Yury Norov
2022-07-03  6:50     ` Christophe JAILLET
2022-07-03 15:20       ` Andy Shevchenko
2022-07-03 19:13         ` Yury Norov
2022-07-03 20:41           ` Christophe JAILLET
2022-07-02 18:29 ` [PATCH 4/4] bitmap: Use bitmap_size() Christophe JAILLET
2022-07-02 20:44 ` [PATCH 0/4] Introduce bitmap_size() Yury Norov

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).