qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: Connor Kuehl <ckuehl@redhat.com>
To: Vivek Goyal <vgoyal@redhat.com>,
	qemu-devel@nongnu.org, virtio-fs@redhat.com
Subject: Re: [Virtio-fs] [PATCH 7/7] virtiofsd: Set req->reply_sent right after sending reply
Date: Thu, 13 May 2021 15:50:13 -0500	[thread overview]
Message-ID: <5ad6f5e9-0a12-54ce-163a-532f916cc8e8@redhat.com> (raw)
In-Reply-To: <20210511213736.281016-8-vgoyal@redhat.com>

On 5/11/21 4:37 PM, Vivek Goyal wrote:
> There is no reason to set it in label "err". We should be able to set
> it right after sending reply. It is easier to read.
> 
> Signed-off-by: Vivek Goyal <vgoyal@redhat.com>
> ---
>  tools/virtiofsd/fuse_virtio.c | 5 +----
>  1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/tools/virtiofsd/fuse_virtio.c b/tools/virtiofsd/fuse_virtio.c
> index aa53808ef9..b1767dd5b9 100644
> --- a/tools/virtiofsd/fuse_virtio.c
> +++ b/tools/virtiofsd/fuse_virtio.c
> @@ -446,12 +446,9 @@ int virtio_send_data_iov(struct fuse_session *se, struct fuse_chan *ch,
>      vu_queue_notify(dev, q);
>      pthread_mutex_unlock(&qi->vq_lock);
>      vu_dispatch_unlock(qi->virtio_dev);
> +    req->reply_sent = true;
>  
>  err:

Just a really minor comment: after all these changes, I would venture
that "out" is a more appropriate label name than "err" at this point.

> -    if (ret == 0) {
> -        req->reply_sent = true;
> -    }
> -
>      return ret;
>  }
>  
> 



  reply	other threads:[~2021-05-13 20:51 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-11 21:37 [PATCH 0/7] virtiofsd: Few cleanups in virtio_send_data_iov() Vivek Goyal
2021-05-11 21:37 ` [PATCH 1/7] virtiofsd: Check for EINTR in preadv() and retry Vivek Goyal
2021-05-18 11:59   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 2/7] virtiofsd: Get rid of unreachable code in read Vivek Goyal
2021-05-18 12:01   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 3/7] virtiofsd: Use iov_discard_front() to skip bytes Vivek Goyal
2021-05-18 12:10   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 4/7] virtiofsd: get rid of in_sg_left variable Vivek Goyal
2021-05-18 12:19   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 5/7] virtiofsd: Simplify skip byte logic Vivek Goyal
2021-05-18 12:26   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 6/7] virtiofsd: Check EOF before short read Vivek Goyal
2021-05-18 12:31   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 7/7] virtiofsd: Set req->reply_sent right after sending reply Vivek Goyal
2021-05-13 20:50   ` Connor Kuehl [this message]
2021-05-17 13:08     ` [Virtio-fs] " Vivek Goyal
2021-05-18 12:34       ` Dr. David Alan Gilbert
2021-05-18 12:32   ` Dr. David Alan Gilbert
2021-05-11 21:48 ` [PATCH 0/7] virtiofsd: Few cleanups in virtio_send_data_iov() no-reply
2021-05-13 20:50 ` [Virtio-fs] " Connor Kuehl
2021-05-17 13:08   ` Vivek Goyal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5ad6f5e9-0a12-54ce-163a-532f916cc8e8@redhat.com \
    --to=ckuehl@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=vgoyal@redhat.com \
    --cc=virtio-fs@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).