qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: "Dr. David Alan Gilbert" <dgilbert@redhat.com>
To: Vivek Goyal <vgoyal@redhat.com>
Cc: Connor Kuehl <ckuehl@redhat.com>,
	virtio-fs@redhat.com, qemu-devel@nongnu.org
Subject: Re: [Virtio-fs] [PATCH 7/7] virtiofsd: Set req->reply_sent right after sending reply
Date: Tue, 18 May 2021 13:34:06 +0100	[thread overview]
Message-ID: <YKO0PnCCO7jMBmBB@work-vm> (raw)
In-Reply-To: <20210517130816.GC546943@horse.lan>

* Vivek Goyal (vgoyal@redhat.com) wrote:
> On Thu, May 13, 2021 at 03:50:13PM -0500, Connor Kuehl wrote:
> > On 5/11/21 4:37 PM, Vivek Goyal wrote:
> > > There is no reason to set it in label "err". We should be able to set
> > > it right after sending reply. It is easier to read.
> > > 
> > > Signed-off-by: Vivek Goyal <vgoyal@redhat.com>
> > > ---
> > >  tools/virtiofsd/fuse_virtio.c | 5 +----
> > >  1 file changed, 1 insertion(+), 4 deletions(-)
> > > 
> > > diff --git a/tools/virtiofsd/fuse_virtio.c b/tools/virtiofsd/fuse_virtio.c
> > > index aa53808ef9..b1767dd5b9 100644
> > > --- a/tools/virtiofsd/fuse_virtio.c
> > > +++ b/tools/virtiofsd/fuse_virtio.c
> > > @@ -446,12 +446,9 @@ int virtio_send_data_iov(struct fuse_session *se, struct fuse_chan *ch,
> > >      vu_queue_notify(dev, q);
> > >      pthread_mutex_unlock(&qi->vq_lock);
> > >      vu_dispatch_unlock(qi->virtio_dev);
> > > +    req->reply_sent = true;
> > >  
> > >  err:
> > 
> > Just a really minor comment: after all these changes, I would venture
> > that "out" is a more appropriate label name than "err" at this point.
> 
> May be. This path is used both by error path as well as success path. Just
> that value of "ret" changes. I am not particular about it. So I will
> change this to "out".

Well, if it only does 'return ret' we can get rid of the
label and just do return's at the places that did the goto's.

Dave

> Thanks
> Vivek
> > 
> > > -    if (ret == 0) {
> > > -        req->reply_sent = true;
> > > -    }
> > > -
> > >      return ret;
> > >  }
> > >  
> > > 
> > 
> 
> _______________________________________________
> Virtio-fs mailing list
> Virtio-fs@redhat.com
> https://listman.redhat.com/mailman/listinfo/virtio-fs
-- 
Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK



  reply	other threads:[~2021-05-18 12:50 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-11 21:37 [PATCH 0/7] virtiofsd: Few cleanups in virtio_send_data_iov() Vivek Goyal
2021-05-11 21:37 ` [PATCH 1/7] virtiofsd: Check for EINTR in preadv() and retry Vivek Goyal
2021-05-18 11:59   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 2/7] virtiofsd: Get rid of unreachable code in read Vivek Goyal
2021-05-18 12:01   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 3/7] virtiofsd: Use iov_discard_front() to skip bytes Vivek Goyal
2021-05-18 12:10   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 4/7] virtiofsd: get rid of in_sg_left variable Vivek Goyal
2021-05-18 12:19   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 5/7] virtiofsd: Simplify skip byte logic Vivek Goyal
2021-05-18 12:26   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 6/7] virtiofsd: Check EOF before short read Vivek Goyal
2021-05-18 12:31   ` Dr. David Alan Gilbert
2021-05-11 21:37 ` [PATCH 7/7] virtiofsd: Set req->reply_sent right after sending reply Vivek Goyal
2021-05-13 20:50   ` [Virtio-fs] " Connor Kuehl
2021-05-17 13:08     ` Vivek Goyal
2021-05-18 12:34       ` Dr. David Alan Gilbert [this message]
2021-05-18 12:32   ` Dr. David Alan Gilbert
2021-05-11 21:48 ` [PATCH 0/7] virtiofsd: Few cleanups in virtio_send_data_iov() no-reply
2021-05-13 20:50 ` [Virtio-fs] " Connor Kuehl
2021-05-17 13:08   ` Vivek Goyal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YKO0PnCCO7jMBmBB@work-vm \
    --to=dgilbert@redhat.com \
    --cc=ckuehl@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=vgoyal@redhat.com \
    --cc=virtio-fs@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).