WireGuard Archive on lore.kernel.org
 help / color / Atom feed
* Re: WireGuard on macOS: config self-deletes
@ 2019-10-14 14:58 Chase Lau
  2019-10-16 20:17 ` Jason A. Donenfeld
  0 siblings, 1 reply; 3+ messages in thread
From: Chase Lau @ 2019-10-14 14:58 UTC (permalink / raw)
  To: wireguard

At Tue Sep 3 17:18:57 CEST 2019, Nadim Kobeissi said he was having a problem with WireGuard configurations being purged, seemingly over night, while on macOS 10.15. I have also been having this issue since the first beta of macOS 10.15.

There’s no logs indicating a problem within the WireGuard app, but it goes seem to happen around the time of a WireGuard update. Perhaps it has something to do with the WireGuard container being overwritten on upgrade?

Chase Lau
chase9@mac.com

_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: WireGuard on macOS: config self-deletes
  2019-10-14 14:58 WireGuard on macOS: config self-deletes Chase Lau
@ 2019-10-16 20:17 ` Jason A. Donenfeld
  0 siblings, 0 replies; 3+ messages in thread
From: Jason A. Donenfeld @ 2019-10-16 20:17 UTC (permalink / raw)
  To: Chase Lau; +Cc: WireGuard mailing list

This appears to be a bug in macOS 10.15. I've informed Apple, and
they're looking into it.

Jason
_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] 3+ messages in thread

* WireGuard on macOS: config self-deletes
@ 2019-09-03 15:18 Nadim Kobeissi
  0 siblings, 0 replies; 3+ messages in thread
From: Nadim Kobeissi @ 2019-09-03 15:18 UTC (permalink / raw)
  To: wireguard

Hello,

On macOS 10.15 Beta 7 (19A546d), the latest version of WireGuard (as downloaded from the App Store) exhibits strange behavior: overnight, the configuration for my tunnel vanishes. This has so far happened twice.

This does not occur on my other macOS machine, which runs macOS 10.14.

I am happy to help diagnose this problem as necessary.

Nadim Kobeissi
Symbolic Software • https://symbolic.software

_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-14 14:58 WireGuard on macOS: config self-deletes Chase Lau
2019-10-16 20:17 ` Jason A. Donenfeld
  -- strict thread matches above, loose matches on Subject: below --
2019-09-03 15:18 Nadim Kobeissi

WireGuard Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/wireguard/0 wireguard/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 wireguard wireguard/ https://lore.kernel.org/wireguard \
		wireguard@lists.zx2c4.com
	public-inbox-index wireguard

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/com.zx2c4.lists.wireguard


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git