All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lukasz Luba <l.luba@partner.samsung.com>
To: Chanwoo Choi <cw00.choi@samsung.com>,
	linux-arm-kernel@lists.infradead.org,
	linux-samsung-soc@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-pm@vger.kernel.org, devicetree@vger.kernel.org
Cc: tjakobi@math.uni-bielefeld.de, myungjoo.ham@samsung.com,
	kyungmin.park@samsung.com, rjw@rjwysocki.net,
	len.brown@intel.com, pavel@ucw.cz, gregkh@linuxfoundation.org,
	keescook@chromium.org, anton@enomsg.org, ccross@android.com,
	tony.luck@intel.com, robh+dt@kernel.org, mark.rutland@arm.com,
	kgene@kernel.org, krzk@kernel.org, m.szyprowski@samsung.com,
	b.zolnierkie@samsung.com
Subject: Re: [PATCH 2/6] devfreq: refactor set_target frequency function
Date: Fri, 23 Nov 2018 10:58:35 +0100	[thread overview]
Message-ID: <1c3a4aad-99cb-9295-3a5e-ff7a3c5245a3@partner.samsung.com> (raw)
In-Reply-To: <5BF73FA9.7010402@samsung.com>

Hi Chanwoo Choi,

On 11/23/18 12:45 AM, Chanwoo Choi wrote:
> Hi Lukasz,
> 
> On 2018년 11월 22일 19:40, Lukasz Luba wrote:
>> Hi Chanwoo Choi
>>
>> On 11/22/18 3:52 AM, Chanwoo Choi wrote:
>>> On 2018년 11월 22일 03:01, Lukasz Luba wrote:
>>>> The refactoring is needed for the new client in devfreq: suspend.
>>>> To avoid code duplication, move it to the new local function
>>>> devfreq_set_target.
>>>>
>>>> The patch draws on Tobias Jakobi's work posted ~2 years ago, who tried to
>>>> solve issue with devfreq device's frequency during suspend/resume.
>>>> During the discussion on LKML some corner cases and comments appeared
>>>> related to the design. This patch address them keeping in mind suggestions
>>>> from Chanwoo Choi.
>>>
>>> As I commented on patch1, please remove it.
>> OK
>>>
>>>>
>>>> Suggested-by: Tobias Jakobi <tjakobi@math.uni-bielefeld.de>
>>>> Suggested-by: Chanwoo Choi <cw00.choi@samsung.com>
>>>> Signed-off-by: Lukasz Luba <l.luba@partner.samsung.com>
>>>> ---
>>>>    drivers/devfreq/devfreq.c | 62 ++++++++++++++++++++++++++++-------------------
>>>>    1 file changed, 37 insertions(+), 25 deletions(-)
>>>>
>>>> diff --git a/drivers/devfreq/devfreq.c b/drivers/devfreq/devfreq.c
>>>> index e20e7e4..cf9c643 100644
>>>> --- a/drivers/devfreq/devfreq.c
>>>> +++ b/drivers/devfreq/devfreq.c
>>>> @@ -285,6 +285,42 @@ static int devfreq_notify_transition(struct devfreq *devfreq,
>>>>    	return 0;
>>>>    }
>>>>    
>>>> +static int devfreq_set_target(struct devfreq *devfreq, unsigned long new_freq,
>>>> +			      unsigned long *prev_freq, u32 flags)
>>>
>>> Please remove the unused space in front of 'unsigned long *prev_freq'.
>>> Use tab only for indentation.
>> OK
>>>
>>>> +{
>>>> +	struct devfreq_freqs freqs;
>>>> +	unsigned long cur_freq;
>>>> +	int err = 0;
>>>> +
>>>> +	if (devfreq->profile->get_cur_freq)
>>>> +		devfreq->profile->get_cur_freq(devfreq->dev.parent, &cur_freq);
>>>> +	else
>>>> +		cur_freq = devfreq->previous_freq;
>>>> +
>>>> +	freqs.old = cur_freq;
>>>> +	freqs.new = new_freq;
>>>> +	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_PRECHANGE);
>>>> +
>>>> +	err = devfreq->profile->target(devfreq->dev.parent, &new_freq, flags);
>>>> +	if (err) {
>>>> +		freqs.new = cur_freq;
>>>> +		devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> +		return err;
>>>> +	}
>>>> +
>>>> +	freqs.new = new_freq;
>>>> +	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> +
>>>> +	if (devfreq_update_status(devfreq, new_freq))
>>>> +		dev_err(&devfreq->dev,
>>>> +			"Couldn't update frequency transition information.\n");
>>>> +
>>>> +	devfreq->previous_freq = new_freq;
>>>> +	*prev_freq = cur_freq;
>>>> +
>>>> +	return err;
>>>> +}
>>>> +
>>>>    /* Load monitoring helper functions for governors use */
>>>>    
>>>>    /**
>>>> @@ -296,7 +332,6 @@ static int devfreq_notify_transition(struct devfreq *devfreq,
>>>>     */
>>>>    int update_devfreq(struct devfreq *devfreq)
>>>>    {
>>>> -	struct devfreq_freqs freqs;
>>>>    	unsigned long freq, cur_freq, min_freq, max_freq;
>>>
>>>
>>> cur_freq is not used after modification. Remove it.
>>>
>>>>    	int err = 0;
>>>>    	u32 flags = 0;
>>>> @@ -333,31 +368,8 @@ int update_devfreq(struct devfreq *devfreq)
>>>>    		flags |= DEVFREQ_FLAG_LEAST_UPPER_BOUND; /* Use LUB */
>>>>    	}
>>>>    
>>>> -	if (devfreq->profile->get_cur_freq)
>>>> -		devfreq->profile->get_cur_freq(devfreq->dev.parent, &cur_freq);
>>>> -	else
>>>> -		cur_freq = devfreq->previous_freq;
>>>> -
>>>> -	freqs.old = cur_freq;
>>>> -	freqs.new = freq;
>>>> -	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_PRECHANGE);
>>>> +	return devfreq_set_target(devfreq, freq, &cur_freq, flags);
>>>
>>> You get the 'cur_freq' from devfreq_set_taget() for devfreq_suspend_device() on patch3.
>>> But, update_devfreq() and devfreq_resume_device() don't use the 'cur_freq' value
>>> from devfreq_set_target().
>>>
>>> Instead, getting 'cur_freq' for 'devfreq->resume_freq' in the devfreq_set_target().
>>> Please remove the 'cur_freq' parameter from devfreq_set_target.
>>
>> I can remove the 3rd parameter from devfreq_set_target(),
>> but it implies that patch 1 and 3 cannot be merged. The function
>> devfreq_set_target will use 'devfreq->resume_freq' so it must be in
>> devfreq struct.
>> So, in v2 version there will be still 6 patches, with the 1st patch
>> defining needed fields in devfreq struct.
>> Do you agree for that?
> 
> So, I replied again as following on my other reply[1] of patch2:
> [1] https://lkml.org/lkml/2018/11/22/507
> 
> But, you have to add following new code on patch3 instead of patch2.
> patch2 doesn't contain the following codes and then
> patch3 adds 'resume_freq' variable and adds the following code on patch3.
> 
> +
> +       if (devfreq->suspend_freq)
> +               devfreq->resume_freq = cur_freq;
> 
OK, I will add that change to patch 3.

Regards,
Lukasz
>>
>>>
>>>>    
>>>> -	err = devfreq->profile->target(devfreq->dev.parent, &freq, flags);
>>>> -	if (err) {
>>>> -		freqs.new = cur_freq;
>>>> -		devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> -		return err;
>>>> -	}
>>>> -
>>>> -	freqs.new = freq;
>>>> -	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> -
>>>> -	if (devfreq_update_status(devfreq, freq))
>>>> -		dev_err(&devfreq->dev,
>>>> -			"Couldn't update frequency transition information.\n");
>>>> -
>>>> -	devfreq->previous_freq = freq;
>>>> -	return err;
>>>>    }
>>>>    EXPORT_SYMBOL(update_devfreq);
>>>>    
>>>>
>>>
>>>
>>
>> Regards,
>> Lukasz Luba
>>
>>
> 
> 


WARNING: multiple messages have this Message-ID (diff)
From: l.luba@partner.samsung.com (Lukasz Luba)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 2/6] devfreq: refactor set_target frequency function
Date: Fri, 23 Nov 2018 10:58:35 +0100	[thread overview]
Message-ID: <1c3a4aad-99cb-9295-3a5e-ff7a3c5245a3@partner.samsung.com> (raw)
In-Reply-To: <5BF73FA9.7010402@samsung.com>

Hi Chanwoo Choi,

On 11/23/18 12:45 AM, Chanwoo Choi wrote:
> Hi Lukasz,
> 
> On 2018? 11? 22? 19:40, Lukasz Luba wrote:
>> Hi Chanwoo Choi
>>
>> On 11/22/18 3:52 AM, Chanwoo Choi wrote:
>>> On 2018? 11? 22? 03:01, Lukasz Luba wrote:
>>>> The refactoring is needed for the new client in devfreq: suspend.
>>>> To avoid code duplication, move it to the new local function
>>>> devfreq_set_target.
>>>>
>>>> The patch draws on Tobias Jakobi's work posted ~2 years ago, who tried to
>>>> solve issue with devfreq device's frequency during suspend/resume.
>>>> During the discussion on LKML some corner cases and comments appeared
>>>> related to the design. This patch address them keeping in mind suggestions
>>>> from Chanwoo Choi.
>>>
>>> As I commented on patch1, please remove it.
>> OK
>>>
>>>>
>>>> Suggested-by: Tobias Jakobi <tjakobi@math.uni-bielefeld.de>
>>>> Suggested-by: Chanwoo Choi <cw00.choi@samsung.com>
>>>> Signed-off-by: Lukasz Luba <l.luba@partner.samsung.com>
>>>> ---
>>>>    drivers/devfreq/devfreq.c | 62 ++++++++++++++++++++++++++++-------------------
>>>>    1 file changed, 37 insertions(+), 25 deletions(-)
>>>>
>>>> diff --git a/drivers/devfreq/devfreq.c b/drivers/devfreq/devfreq.c
>>>> index e20e7e4..cf9c643 100644
>>>> --- a/drivers/devfreq/devfreq.c
>>>> +++ b/drivers/devfreq/devfreq.c
>>>> @@ -285,6 +285,42 @@ static int devfreq_notify_transition(struct devfreq *devfreq,
>>>>    	return 0;
>>>>    }
>>>>    
>>>> +static int devfreq_set_target(struct devfreq *devfreq, unsigned long new_freq,
>>>> +			      unsigned long *prev_freq, u32 flags)
>>>
>>> Please remove the unused space in front of 'unsigned long *prev_freq'.
>>> Use tab only for indentation.
>> OK
>>>
>>>> +{
>>>> +	struct devfreq_freqs freqs;
>>>> +	unsigned long cur_freq;
>>>> +	int err = 0;
>>>> +
>>>> +	if (devfreq->profile->get_cur_freq)
>>>> +		devfreq->profile->get_cur_freq(devfreq->dev.parent, &cur_freq);
>>>> +	else
>>>> +		cur_freq = devfreq->previous_freq;
>>>> +
>>>> +	freqs.old = cur_freq;
>>>> +	freqs.new = new_freq;
>>>> +	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_PRECHANGE);
>>>> +
>>>> +	err = devfreq->profile->target(devfreq->dev.parent, &new_freq, flags);
>>>> +	if (err) {
>>>> +		freqs.new = cur_freq;
>>>> +		devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> +		return err;
>>>> +	}
>>>> +
>>>> +	freqs.new = new_freq;
>>>> +	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> +
>>>> +	if (devfreq_update_status(devfreq, new_freq))
>>>> +		dev_err(&devfreq->dev,
>>>> +			"Couldn't update frequency transition information.\n");
>>>> +
>>>> +	devfreq->previous_freq = new_freq;
>>>> +	*prev_freq = cur_freq;
>>>> +
>>>> +	return err;
>>>> +}
>>>> +
>>>>    /* Load monitoring helper functions for governors use */
>>>>    
>>>>    /**
>>>> @@ -296,7 +332,6 @@ static int devfreq_notify_transition(struct devfreq *devfreq,
>>>>     */
>>>>    int update_devfreq(struct devfreq *devfreq)
>>>>    {
>>>> -	struct devfreq_freqs freqs;
>>>>    	unsigned long freq, cur_freq, min_freq, max_freq;
>>>
>>>
>>> cur_freq is not used after modification. Remove it.
>>>
>>>>    	int err = 0;
>>>>    	u32 flags = 0;
>>>> @@ -333,31 +368,8 @@ int update_devfreq(struct devfreq *devfreq)
>>>>    		flags |= DEVFREQ_FLAG_LEAST_UPPER_BOUND; /* Use LUB */
>>>>    	}
>>>>    
>>>> -	if (devfreq->profile->get_cur_freq)
>>>> -		devfreq->profile->get_cur_freq(devfreq->dev.parent, &cur_freq);
>>>> -	else
>>>> -		cur_freq = devfreq->previous_freq;
>>>> -
>>>> -	freqs.old = cur_freq;
>>>> -	freqs.new = freq;
>>>> -	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_PRECHANGE);
>>>> +	return devfreq_set_target(devfreq, freq, &cur_freq, flags);
>>>
>>> You get the 'cur_freq' from devfreq_set_taget() for devfreq_suspend_device() on patch3.
>>> But, update_devfreq() and devfreq_resume_device() don't use the 'cur_freq' value
>>> from devfreq_set_target().
>>>
>>> Instead, getting 'cur_freq' for 'devfreq->resume_freq' in the devfreq_set_target().
>>> Please remove the 'cur_freq' parameter from devfreq_set_target.
>>
>> I can remove the 3rd parameter from devfreq_set_target(),
>> but it implies that patch 1 and 3 cannot be merged. The function
>> devfreq_set_target will use 'devfreq->resume_freq' so it must be in
>> devfreq struct.
>> So, in v2 version there will be still 6 patches, with the 1st patch
>> defining needed fields in devfreq struct.
>> Do you agree for that?
> 
> So, I replied again as following on my other reply[1] of patch2:
> [1] https://lkml.org/lkml/2018/11/22/507
> 
> But, you have to add following new code on patch3 instead of patch2.
> patch2 doesn't contain the following codes and then
> patch3 adds 'resume_freq' variable and adds the following code on patch3.
> 
> +
> +       if (devfreq->suspend_freq)
> +               devfreq->resume_freq = cur_freq;
> 
OK, I will add that change to patch 3.

Regards,
Lukasz
>>
>>>
>>>>    
>>>> -	err = devfreq->profile->target(devfreq->dev.parent, &freq, flags);
>>>> -	if (err) {
>>>> -		freqs.new = cur_freq;
>>>> -		devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> -		return err;
>>>> -	}
>>>> -
>>>> -	freqs.new = freq;
>>>> -	devfreq_notify_transition(devfreq, &freqs, DEVFREQ_POSTCHANGE);
>>>> -
>>>> -	if (devfreq_update_status(devfreq, freq))
>>>> -		dev_err(&devfreq->dev,
>>>> -			"Couldn't update frequency transition information.\n");
>>>> -
>>>> -	devfreq->previous_freq = freq;
>>>> -	return err;
>>>>    }
>>>>    EXPORT_SYMBOL(update_devfreq);
>>>>    
>>>>
>>>
>>>
>>
>> Regards,
>> Lukasz Luba
>>
>>
> 
> 

  reply	other threads:[~2018-11-23  9:58 UTC|newest]

Thread overview: 59+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20181121180156eucas1p225af7f4341a039264ff26f2a9ad9bb12@eucas1p2.samsung.com>
2018-11-21 18:01 ` [PATCH 0/6] devfreq: handle suspend/resume Lukasz Luba
2018-11-21 18:01   ` Lukasz Luba
     [not found]   ` <CGME20181121180201eucas1p1f1f96941c3d16a96722e65d5c21bfe80@eucas1p1.samsung.com>
2018-11-21 18:01     ` [PATCH 1/6] devfreq: add basic fileds supporting suspend functionality Lukasz Luba
2018-11-21 18:01       ` Lukasz Luba
2018-11-22  2:37       ` Chanwoo Choi
2018-11-22  2:37         ` Chanwoo Choi
     [not found]   ` <CGME20181121180202eucas1p27d3aa58411abeae03181c38b91fc67de@eucas1p2.samsung.com>
2018-11-21 18:01     ` [PATCH 2/6] devfreq: refactor set_target frequency function Lukasz Luba
2018-11-21 18:01       ` Lukasz Luba
2018-11-22  2:52       ` Chanwoo Choi
2018-11-22  2:52         ` Chanwoo Choi
2018-11-22  2:54         ` Chanwoo Choi
2018-11-22  2:54           ` Chanwoo Choi
2018-11-22 10:40         ` Lukasz Luba
2018-11-22 10:40           ` Lukasz Luba
2018-11-22 23:45           ` Chanwoo Choi
2018-11-22 23:45             ` Chanwoo Choi
2018-11-23  9:58             ` Lukasz Luba [this message]
2018-11-23  9:58               ` Lukasz Luba
     [not found]   ` <CGME20181121180204eucas1p1c5891d498aa59c0e10dd3ba4727a4382@eucas1p1.samsung.com>
2018-11-21 18:01     ` [PATCH 3/6] devfreq: add support for suspend/resume of a devfreq device Lukasz Luba
2018-11-21 18:01       ` Lukasz Luba
2018-11-21 18:01       ` Lukasz Luba
2018-11-22  2:58       ` Chanwoo Choi
2018-11-22  2:58         ` Chanwoo Choi
2018-11-22 11:00         ` Lukasz Luba
2018-11-22 11:00           ` Lukasz Luba
2018-11-22 23:54           ` Chanwoo Choi
2018-11-22 23:54             ` Chanwoo Choi
2018-11-23 10:01             ` Lukasz Luba
2018-11-23 10:01               ` Lukasz Luba
2018-11-26  0:19               ` Chanwoo Choi
2018-11-26  0:19                 ` Chanwoo Choi
2018-12-03 14:05                 ` Lukasz Luba
2018-12-03 14:05                   ` Lukasz Luba
     [not found]   ` <CGME20181121180205eucas1p1dc52369476400cd07058d232bd8dbcd7@eucas1p1.samsung.com>
2018-11-21 18:01     ` [PATCH 4/6] devfreq: add devfreq_suspend/resume() functions Lukasz Luba
2018-11-21 18:01       ` Lukasz Luba
2018-11-22  3:07       ` Chanwoo Choi
2018-11-22  3:07         ` Chanwoo Choi
2018-11-22 11:02         ` Lukasz Luba
2018-11-22 11:02           ` Lukasz Luba
     [not found]   ` <CGME20181121180206eucas1p265865226e3938a28e842e8367233dc2e@eucas1p2.samsung.com>
2018-11-21 18:01     ` [PATCH 5/6] drivers: power: suspend: call devfreq suspend/resume Lukasz Luba
2018-11-21 18:01       ` Lukasz Luba
2018-11-22  3:08       ` Chanwoo Choi
2018-11-22  3:08         ` Chanwoo Choi
     [not found]   ` <CGME20181121180208eucas1p11482a783ab1b1bceb8c9f6a1f50682c3@eucas1p1.samsung.com>
2018-11-21 18:01     ` [PATCH 6/6] arm: dts: exynos4: set opp-suspend for DMC and leftbus Lukasz Luba
2018-11-21 18:01       ` Lukasz Luba
2018-11-22  3:09       ` Chanwoo Choi
2018-11-22  3:09         ` Chanwoo Choi
2018-11-22 11:04         ` Lukasz Luba
2018-11-22 11:04           ` Lukasz Luba
2018-11-22 17:24   ` [PATCH 0/6] devfreq: handle suspend/resume Tobias Jakobi
2018-11-22 17:24     ` Tobias Jakobi
2018-11-22 17:44     ` Lukasz Luba
2018-11-22 17:44       ` Lukasz Luba
     [not found]   ` <CGME20181121180201eucas1p1f1f96941c3d16a96722e65d5c21bfe80@epcms1p8>
2018-11-26  8:14     ` [PATCH 1/6] devfreq: add basic fileds supporting suspend functionality MyungJoo Ham
2018-11-26  8:14       ` MyungJoo Ham
2018-11-26  8:14       ` MyungJoo Ham
2018-12-03 14:03       ` Lukasz Luba
2018-12-03 14:03         ` Lukasz Luba
2018-12-03 14:03         ` Lukasz Luba

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1c3a4aad-99cb-9295-3a5e-ff7a3c5245a3@partner.samsung.com \
    --to=l.luba@partner.samsung.com \
    --cc=anton@enomsg.org \
    --cc=b.zolnierkie@samsung.com \
    --cc=ccross@android.com \
    --cc=cw00.choi@samsung.com \
    --cc=devicetree@vger.kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=keescook@chromium.org \
    --cc=kgene@kernel.org \
    --cc=krzk@kernel.org \
    --cc=kyungmin.park@samsung.com \
    --cc=len.brown@intel.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linux-samsung-soc@vger.kernel.org \
    --cc=m.szyprowski@samsung.com \
    --cc=mark.rutland@arm.com \
    --cc=myungjoo.ham@samsung.com \
    --cc=pavel@ucw.cz \
    --cc=rjw@rjwysocki.net \
    --cc=robh+dt@kernel.org \
    --cc=tjakobi@math.uni-bielefeld.de \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.