All of lore.kernel.org
 help / color / mirror / Atom feed
From: Tony Lindgren <tony@atomide.com>
To: linux-arm-kernel@lists.infradead.org
Cc: linux-omap@vger.kernel.org
Subject: [PATCH 10/10] omap2+: Rename timer-gp.c into timer.c to combine timer init functions
Date: Mon, 20 Jun 2011 02:23:50 -0700	[thread overview]
Message-ID: <20110620092350.357.24851.stgit@kaulin> (raw)
In-Reply-To: <20110620091754.357.56441.stgit@kaulin>

We can keep everything sys_timer and gptimer.c related code in
timer.c as the code will be very minimal.

Later on we can also remove timer-mpu.c, as it can be called from
omap4_timer_init function.

This allows us to get rid of confusing existing files. We currently
have timer-gp.c, timer-mpu.c, and patches have been posted to add
dmtimer.c. There's no need to have these multiple files, we can
put everything into timer.c.

Signed-off-by: Tony Lindgren <tony@atomide.com>
---
 arch/arm/mach-omap2/Makefile   |    2 +-
 arch/arm/mach-omap2/timer.c    |    4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)
 rename arch/arm/mach-omap2/{timer-gp.c => timer.c} (99%)

diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile
index b148077..adbe82d 100644
--- a/arch/arm/mach-omap2/Makefile
+++ b/arch/arm/mach-omap2/Makefile
@@ -3,7 +3,7 @@
 #
 
 # Common support
-obj-y := id.o io.o control.o mux.o devices.o serial.o gpmc.o timer-gp.o pm.o \
+obj-y := id.o io.o control.o mux.o devices.o serial.o gpmc.o timer.o pm.o \
 	 common.o gpio.o dma.o wd_timer.o
 
 omap-2-3-common				= irq.o sdrc.o
diff --git a/arch/arm/mach-omap2/timer-gp.c b/arch/arm/mach-omap2/timer.c
similarity index 99%
rename from arch/arm/mach-omap2/timer-gp.c
rename to arch/arm/mach-omap2/timer.c
index 08cbb34..796b935 100644
--- a/arch/arm/mach-omap2/timer-gp.c
+++ b/arch/arm/mach-omap2/timer.c
@@ -1,5 +1,5 @@
 /*
- * linux/arch/arm/mach-omap2/timer-gp.c
+ * linux/arch/arm/mach-omap2/timer.c
  *
  * OMAP2 GP timer support.
  *
@@ -230,7 +230,7 @@ static void __init omap2_gp_clockevent_init(int gptimer_id,
 /* Clocksource code */
 
 #ifdef CONFIG_OMAP_32K_TIMER
-/* 
+/*
  * When 32k-timer is enabled, don't use GPTimer for clocksource
  * instead, just leave default clocksource which uses the 32k
  * sync counter.  See clocksource setup in plat-omap/counter_32k.c


WARNING: multiple messages have this Message-ID (diff)
From: tony@atomide.com (Tony Lindgren)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 10/10] omap2+: Rename timer-gp.c into timer.c to combine timer init functions
Date: Mon, 20 Jun 2011 02:23:50 -0700	[thread overview]
Message-ID: <20110620092350.357.24851.stgit@kaulin> (raw)
In-Reply-To: <20110620091754.357.56441.stgit@kaulin>

We can keep everything sys_timer and gptimer.c related code in
timer.c as the code will be very minimal.

Later on we can also remove timer-mpu.c, as it can be called from
omap4_timer_init function.

This allows us to get rid of confusing existing files. We currently
have timer-gp.c, timer-mpu.c, and patches have been posted to add
dmtimer.c. There's no need to have these multiple files, we can
put everything into timer.c.

Signed-off-by: Tony Lindgren <tony@atomide.com>
---
 arch/arm/mach-omap2/Makefile   |    2 +-
 arch/arm/mach-omap2/timer.c    |    4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)
 rename arch/arm/mach-omap2/{timer-gp.c => timer.c} (99%)

diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile
index b148077..adbe82d 100644
--- a/arch/arm/mach-omap2/Makefile
+++ b/arch/arm/mach-omap2/Makefile
@@ -3,7 +3,7 @@
 #
 
 # Common support
-obj-y := id.o io.o control.o mux.o devices.o serial.o gpmc.o timer-gp.o pm.o \
+obj-y := id.o io.o control.o mux.o devices.o serial.o gpmc.o timer.o pm.o \
 	 common.o gpio.o dma.o wd_timer.o
 
 omap-2-3-common				= irq.o sdrc.o
diff --git a/arch/arm/mach-omap2/timer-gp.c b/arch/arm/mach-omap2/timer.c
similarity index 99%
rename from arch/arm/mach-omap2/timer-gp.c
rename to arch/arm/mach-omap2/timer.c
index 08cbb34..796b935 100644
--- a/arch/arm/mach-omap2/timer-gp.c
+++ b/arch/arm/mach-omap2/timer.c
@@ -1,5 +1,5 @@
 /*
- * linux/arch/arm/mach-omap2/timer-gp.c
+ * linux/arch/arm/mach-omap2/timer.c
  *
  * OMAP2 GP timer support.
  *
@@ -230,7 +230,7 @@ static void __init omap2_gp_clockevent_init(int gptimer_id,
 /* Clocksource code */
 
 #ifdef CONFIG_OMAP_32K_TIMER
-/* 
+/*
  * When 32k-timer is enabled, don't use GPTimer for clocksource
  * instead, just leave default clocksource which uses the 32k
  * sync counter.  See clocksource setup in plat-omap/counter_32k.c

  parent reply	other threads:[~2011-06-20  9:23 UTC|newest]

Thread overview: 82+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-06-20  9:23 [PATCH 00/10] init_early cleanup for omap init_irq and init_timer Tony Lindgren
2011-06-20  9:23 ` Tony Lindgren
2011-06-20  9:23 ` [PATCH 01/10] omap: Use separate init_irq functions to avoid cpu_is_omap tests early Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-20  9:54   ` Russell King - ARM Linux
2011-06-20  9:54     ` Russell King - ARM Linux
2011-06-20 10:14     ` Tony Lindgren
2011-06-20 10:14       ` Tony Lindgren
2011-06-27 17:08   ` Kevin Hilman
2011-06-27 17:08     ` Kevin Hilman
2011-06-20  9:23 ` [PATCH 02/10] omap: Set separate timer init functions to avoid cpu_is_omap tests Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-20  9:23 ` [PATCH 03/10] omap: Move dmtimer defines to dmtimer.h Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-20  9:56   ` Russell King - ARM Linux
2011-06-20  9:56     ` Russell King - ARM Linux
2011-06-20 10:17     ` Tony Lindgren
2011-06-20 10:17       ` Tony Lindgren
2011-06-20  9:23 ` [PATCH 04/10] omap: Make a subset of dmtimer functions into inline functions Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-20  9:23 ` [PATCH 05/10] omap2+: Use dmtimer macros for clockevent Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-23 17:07   ` Kevin Hilman
2011-06-23 17:07     ` Kevin Hilman
2011-06-27  7:39     ` Tony Lindgren
2011-06-27  7:39       ` Tony Lindgren
2011-06-20  9:23 ` [PATCH 06/10] omap2+: Remove gptimer_wakeup for now Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-20  9:39   ` Santosh Shilimkar
2011-06-20  9:39     ` Santosh Shilimkar
2011-06-20  9:48     ` Tony Lindgren
2011-06-20  9:48       ` Tony Lindgren
2011-06-23 15:05       ` Kevin Hilman
2011-06-23 15:05         ` Kevin Hilman
2011-06-23 15:13         ` Santosh Shilimkar
2011-06-23 15:13           ` Santosh Shilimkar
2011-06-27  8:08           ` Tony Lindgren
2011-06-27  8:08             ` Tony Lindgren
2011-06-27 16:30             ` Kevin Hilman
2011-06-27 16:30               ` Kevin Hilman
2011-06-27 18:16               ` Tony Lindgren
2011-06-27 18:16                 ` Tony Lindgren
2011-06-27 17:32   ` Kevin Hilman
2011-06-27 17:32     ` Kevin Hilman
2011-06-27 19:19     ` Tony Lindgren
2011-06-27 19:19       ` Tony Lindgren
2011-06-27 21:16       ` Kevin Hilman
2011-06-27 21:16         ` Kevin Hilman
2011-06-20  9:23 ` [PATCH 07/10] omap2+: Reserve clocksource and timesource and initialize dmtimer later Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-23 17:01   ` Kevin Hilman
2011-06-23 17:01     ` Kevin Hilman
2011-06-27  7:48     ` Tony Lindgren
2011-06-27  7:48       ` Tony Lindgren
2011-06-27 16:41       ` Kevin Hilman
2011-06-27 16:41         ` Kevin Hilman
2011-06-23 17:13   ` Kevin Hilman
2011-06-23 17:13     ` Kevin Hilman
2011-06-27  7:51     ` Tony Lindgren
2011-06-27  7:51       ` Tony Lindgren
2011-06-27 10:44       ` Tony Lindgren
2011-06-27 10:44         ` Tony Lindgren
2011-06-20  9:23 ` [PATCH 08/10] omap2+: Use dmtimer macros for clocksource Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-23 15:28   ` Kevin Hilman
2011-06-23 15:28     ` Kevin Hilman
2011-06-23 16:47     ` Kevin Hilman
2011-06-23 16:47       ` Kevin Hilman
2011-06-23 17:10   ` Kevin Hilman
2011-06-23 17:10     ` Kevin Hilman
2011-06-27  7:54     ` Tony Lindgren
2011-06-27  7:54       ` Tony Lindgren
2011-06-27 10:48       ` Tony Lindgren
2011-06-27 10:48         ` Tony Lindgren
2011-06-27 16:41         ` Kevin Hilman
2011-06-27 16:41           ` Kevin Hilman
2011-06-20  9:23 ` [PATCH 09/10] omap2+: Remove omap2_gp_clockevent_set_gptimer Tony Lindgren
2011-06-20  9:23   ` Tony Lindgren
2011-06-20  9:23 ` Tony Lindgren [this message]
2011-06-20  9:23   ` [PATCH 10/10] omap2+: Rename timer-gp.c into timer.c to combine timer init functions Tony Lindgren
  -- strict thread matches above, loose matches on Subject: below --
2011-03-28 22:21 [PATCH 00/10] omap init_early changes for irq and timer init Tony Lindgren
2011-03-28 22:21 ` [PATCH 10/10] omap2+: Rename timer-gp.c into timer.c to combine timer init functions Tony Lindgren
2011-03-28 22:21   ` Tony Lindgren

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110620092350.357.24851.stgit@kaulin \
    --to=tony@atomide.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-omap@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.