All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
To: "Winkler, Tomas" <tomas.winkler@intel.com>
Cc: Peter Huewe <peterhuewe@gmx.de>,
	"moderated list:TPM DEVICE DRIVER" 
	<tpmdd-devel@lists.sourceforge.net>,
	open list <linux-kernel@vger.kernel.org>
Subject: Re: [tpmdd-devel] [PATCH 2/3] tpm_crb: encapsulate crb_wait_for_reg_32
Date: Tue, 11 Oct 2016 14:29:16 +0300	[thread overview]
Message-ID: <20161011112916.GD21688@intel.com> (raw)
In-Reply-To: <5B8DA87D05A7694D9FA63FD143655C1B542F7FD8@hasmsx108.ger.corp.intel.com>

On Tue, Oct 11, 2016 at 10:21:03AM +0000, Winkler, Tomas wrote:
> > Encapsulated crb_wait_for_reg32() so that state changes in other CRB registers
> > than TPM_CRB_CTRL_REQ_x can be waited.
> > 
> > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
> > ---
> >  drivers/char/tpm/tpm_crb.c | 40 +++++++++++++++++++++++-----------------
> >  1 file changed, 23 insertions(+), 17 deletions(-)
> > 
> > diff --git a/drivers/char/tpm/tpm_crb.c b/drivers/char/tpm/tpm_crb.c index
> > c34318b..45f53c2 100644
> > --- a/drivers/char/tpm/tpm_crb.c
> > +++ b/drivers/char/tpm/tpm_crb.c
> > @@ -121,6 +121,25 @@ static int __maybe_unused crb_go_idle(struct device
> > *dev, struct crb_priv *priv)
> >  	return 0;
> >  }
> > 
> > +static bool crb_wait_for_reg_32(u32 __iomem *reg, u32 mask, u32 value,
> > +				unsigned long timeout)
> This is a boiler plate register polling function  I would call it _poll_ rather the _wait_
> 
> > +{
> > +	ktime_t start;
> > +	ktime_t stop;
> > +
> > +	start = ktime_get();
> > +	stop = ktime_add(start, ms_to_ktime(timeout));
> > +
> > +	do {
> > +		if ((ioread32(reg) & mask) == value)
> I prefer the register value is synced to  variable, this inlining is
> harder to add adhoc debug prints.  Also you removed the debug print
> out that I know when this settled which is important for catching
> bugs. 

I can add it but can you just briefly explain why the warning
is not enough?

> > +			return true;
> > +
> > +		usleep_range(50, 100);
> How do you know this is correct sleep time, I've tuned that for power
> gating I'm not sure you this fits also for locality. 

Does it matter as long as it is less than for the timeout?

/Jarkko

WARNING: multiple messages have this Message-ID (diff)
From: Jarkko Sakkinen <jarkko.sakkinen-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>
To: "Winkler, Tomas" <tomas.winkler-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>
Cc: "moderated list:TPM DEVICE DRIVER"
	<tpmdd-devel-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org>,
	open list <linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>
Subject: Re: [PATCH 2/3] tpm_crb: encapsulate crb_wait_for_reg_32
Date: Tue, 11 Oct 2016 14:29:16 +0300	[thread overview]
Message-ID: <20161011112916.GD21688@intel.com> (raw)
In-Reply-To: <5B8DA87D05A7694D9FA63FD143655C1B542F7FD8-Jy8z56yoSI8MvF1YICWikbfspsVTdybXVpNB7YpNyf8@public.gmane.org>

On Tue, Oct 11, 2016 at 10:21:03AM +0000, Winkler, Tomas wrote:
> > Encapsulated crb_wait_for_reg32() so that state changes in other CRB registers
> > than TPM_CRB_CTRL_REQ_x can be waited.
> > 
> > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>
> > ---
> >  drivers/char/tpm/tpm_crb.c | 40 +++++++++++++++++++++++-----------------
> >  1 file changed, 23 insertions(+), 17 deletions(-)
> > 
> > diff --git a/drivers/char/tpm/tpm_crb.c b/drivers/char/tpm/tpm_crb.c index
> > c34318b..45f53c2 100644
> > --- a/drivers/char/tpm/tpm_crb.c
> > +++ b/drivers/char/tpm/tpm_crb.c
> > @@ -121,6 +121,25 @@ static int __maybe_unused crb_go_idle(struct device
> > *dev, struct crb_priv *priv)
> >  	return 0;
> >  }
> > 
> > +static bool crb_wait_for_reg_32(u32 __iomem *reg, u32 mask, u32 value,
> > +				unsigned long timeout)
> This is a boiler plate register polling function  I would call it _poll_ rather the _wait_
> 
> > +{
> > +	ktime_t start;
> > +	ktime_t stop;
> > +
> > +	start = ktime_get();
> > +	stop = ktime_add(start, ms_to_ktime(timeout));
> > +
> > +	do {
> > +		if ((ioread32(reg) & mask) == value)
> I prefer the register value is synced to  variable, this inlining is
> harder to add adhoc debug prints.  Also you removed the debug print
> out that I know when this settled which is important for catching
> bugs. 

I can add it but can you just briefly explain why the warning
is not enough?

> > +			return true;
> > +
> > +		usleep_range(50, 100);
> How do you know this is correct sleep time, I've tuned that for power
> gating I'm not sure you this fits also for locality. 

Does it matter as long as it is less than for the timeout?

/Jarkko

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot

  reply	other threads:[~2016-10-11 11:29 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-11  9:23 [PATCH 0/3] Locality support for the CRB driver Jarkko Sakkinen
2016-10-11  9:23 ` Jarkko Sakkinen
2016-10-11  9:23 ` [PATCH RFC 1/3] tpm_crb: expand struct crb_control_area to struct crb_regs Jarkko Sakkinen
2016-10-11  9:23   ` Jarkko Sakkinen
2016-10-11  9:23 ` [PATCH 1/3] tpm_crb: map locality registers Jarkko Sakkinen
2016-10-11  9:23   ` Jarkko Sakkinen
2016-10-11 11:25   ` Jarkko Sakkinen
2016-10-11 11:25     ` Jarkko Sakkinen
2016-10-11 17:01   ` Jason Gunthorpe
2016-10-11 17:01     ` Jason Gunthorpe
2016-10-11 18:21     ` Jarkko Sakkinen
2016-10-11 18:21       ` Jarkko Sakkinen
2016-10-11 18:29       ` Jason Gunthorpe
2016-10-11 18:29         ` Jason Gunthorpe
2016-10-11 19:48         ` Jarkko Sakkinen
2016-10-11 19:48           ` Jarkko Sakkinen
2016-10-11  9:23 ` [PATCH 2/3] tpm_crb: encapsulate crb_wait_for_reg_32 Jarkko Sakkinen
2016-10-11  9:23   ` Jarkko Sakkinen
2016-10-11 10:21   ` [tpmdd-devel] " Winkler, Tomas
2016-10-11 10:21     ` Winkler, Tomas
2016-10-11 11:29     ` Jarkko Sakkinen [this message]
2016-10-11 11:29       ` Jarkko Sakkinen
2016-10-11  9:23 ` [PATCH 3/3] tpm_crb: request and relinquish locality 0 Jarkko Sakkinen
2016-10-11  9:23   ` Jarkko Sakkinen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161011112916.GD21688@intel.com \
    --to=jarkko.sakkinen@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peterhuewe@gmx.de \
    --cc=tomas.winkler@intel.com \
    --cc=tpmdd-devel@lists.sourceforge.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.