All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ulf Hansson <ulf.hansson@linaro.org>
To: Viresh Kumar <viresh.kumar@linaro.org>
Cc: Sudeep Holla <sudeep.holla@arm.com>,
	Cristian Marussi <cristian.marussi@arm.com>,
	Viresh Kumar <vireshk@kernel.org>, Nishanth Menon <nm@ti.com>,
	Stephen Boyd <sboyd@kernel.org>, Nikunj Kela <nkela@quicinc.com>,
	Prasad Sodagudi <psodagud@quicinc.com>,
	Alexandre Torgue <alexandre.torgue@foss.st.com>,
	linux-pm@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 11/16] OPP: Add dev_pm_opp_add_dynamic() to allow more flexibility
Date: Thu, 8 Jun 2023 10:59:51 +0200	[thread overview]
Message-ID: <CAPDyKFodvtRE5DHeMSSG5o4iJw07TjFHSeAoTuugH9OAmE8bMQ@mail.gmail.com> (raw)
In-Reply-To: <20230608052953.l44dwb6n62kx4umk@vireshk-i7>

On Thu, 8 Jun 2023 at 07:29, Viresh Kumar <viresh.kumar@linaro.org> wrote:
>
> On 07-06-23, 14:46, Ulf Hansson wrote:
> > diff --git a/drivers/opp/core.c b/drivers/opp/core.c
> > index 954c94865cf5..0e6ee2980f88 100644
> > --- a/drivers/opp/core.c
> > +++ b/drivers/opp/core.c
> > @@ -1921,8 +1921,7 @@ int _opp_add(struct device *dev, struct dev_pm_opp *new_opp,
> >   * _opp_add_v1() - Allocate a OPP based on v1 bindings.
> >   * @opp_table:       OPP table
> >   * @dev:     device for which we do this operation
> > - * @freq:    Frequency in Hz for this OPP
> > - * @u_volt:  Voltage in uVolts for this OPP
> > + * @opp:     The OPP to add
> >   * @dynamic: Dynamically added OPPs.
> >   *
> >   * This function adds an opp definition to the opp table and returns status.
> > @@ -1940,10 +1939,10 @@ int _opp_add(struct device *dev, struct dev_pm_opp *new_opp,
> >   * -ENOMEM   Memory allocation failure
> >   */
> >  int _opp_add_v1(struct opp_table *opp_table, struct device *dev,
> > -             unsigned long freq, long u_volt, bool dynamic)
> > +             struct dev_pm_opp_data *opp, bool dynamic)
>
> The name `opp` is mostly used for instances of `struct dev_pm_opp`. Can we use a
> different name here please for the data ?

Certainly, what do you suggest?

>
> > +/**
> > + * dev_pm_opp_add()  - Add an OPP table from a table definitions
> > + * @dev:     device for which we do this operation
> > + * @freq:    Frequency in Hz for this OPP
> > + * @u_volt:  Voltage in uVolts for this OPP
> > + *
> > + * This function adds an opp definition to the opp table and returns status.
> > + * The opp is made available by default and it can be controlled using
> > + * dev_pm_opp_enable/disable functions.
> > + *
> > + * Return:
> > + * 0         On success OR
> > + *           Duplicate OPPs (both freq and volt are same) and opp->available
> > + * -EEXIST   Freq are same and volt are different OR
> > + *           Duplicate OPPs (both freq and volt are same) and !opp->available
> > + * -ENOMEM   Memory allocation failure
> > + */
> > +int dev_pm_opp_add(struct device *dev, unsigned long freq, unsigned long u_volt)
>
> Maybe move this to include/linux/pm_opp.h and mark it static inline and get rid
> of documentation too.

Good idea!

>
> > +{
> > +     struct dev_pm_opp_data opp;
> > +
> > +     memset(&opp, 0, sizeof(opp));
>
> What about
>         struct dev_pm_opp_data data = {0};
>
> I think it is guaranteed that all the fields will be 0 now, not the padding of
> course, but we don't care about that here.
>
> > +     opp.freq = freq;
> > +     opp.u_volt = u_volt;
>
> Or maybe just
>
>         struct dev_pm_opp_data data = {
>                 .freq = freq,
>                 .u_volt = u_volt,
>         };
>
> Rest must be 0.

Good suggestions both, I will change to whatever is best suitable!

Thanks for reviewing!

Kind regards
Uffe

WARNING: multiple messages have this Message-ID (diff)
From: Ulf Hansson <ulf.hansson@linaro.org>
To: Viresh Kumar <viresh.kumar@linaro.org>
Cc: Sudeep Holla <sudeep.holla@arm.com>,
	Cristian Marussi <cristian.marussi@arm.com>,
	 Viresh Kumar <vireshk@kernel.org>, Nishanth Menon <nm@ti.com>,
	Stephen Boyd <sboyd@kernel.org>,  Nikunj Kela <nkela@quicinc.com>,
	Prasad Sodagudi <psodagud@quicinc.com>,
	 Alexandre Torgue <alexandre.torgue@foss.st.com>,
	linux-pm@vger.kernel.org,  linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 11/16] OPP: Add dev_pm_opp_add_dynamic() to allow more flexibility
Date: Thu, 8 Jun 2023 10:59:51 +0200	[thread overview]
Message-ID: <CAPDyKFodvtRE5DHeMSSG5o4iJw07TjFHSeAoTuugH9OAmE8bMQ@mail.gmail.com> (raw)
In-Reply-To: <20230608052953.l44dwb6n62kx4umk@vireshk-i7>

On Thu, 8 Jun 2023 at 07:29, Viresh Kumar <viresh.kumar@linaro.org> wrote:
>
> On 07-06-23, 14:46, Ulf Hansson wrote:
> > diff --git a/drivers/opp/core.c b/drivers/opp/core.c
> > index 954c94865cf5..0e6ee2980f88 100644
> > --- a/drivers/opp/core.c
> > +++ b/drivers/opp/core.c
> > @@ -1921,8 +1921,7 @@ int _opp_add(struct device *dev, struct dev_pm_opp *new_opp,
> >   * _opp_add_v1() - Allocate a OPP based on v1 bindings.
> >   * @opp_table:       OPP table
> >   * @dev:     device for which we do this operation
> > - * @freq:    Frequency in Hz for this OPP
> > - * @u_volt:  Voltage in uVolts for this OPP
> > + * @opp:     The OPP to add
> >   * @dynamic: Dynamically added OPPs.
> >   *
> >   * This function adds an opp definition to the opp table and returns status.
> > @@ -1940,10 +1939,10 @@ int _opp_add(struct device *dev, struct dev_pm_opp *new_opp,
> >   * -ENOMEM   Memory allocation failure
> >   */
> >  int _opp_add_v1(struct opp_table *opp_table, struct device *dev,
> > -             unsigned long freq, long u_volt, bool dynamic)
> > +             struct dev_pm_opp_data *opp, bool dynamic)
>
> The name `opp` is mostly used for instances of `struct dev_pm_opp`. Can we use a
> different name here please for the data ?

Certainly, what do you suggest?

>
> > +/**
> > + * dev_pm_opp_add()  - Add an OPP table from a table definitions
> > + * @dev:     device for which we do this operation
> > + * @freq:    Frequency in Hz for this OPP
> > + * @u_volt:  Voltage in uVolts for this OPP
> > + *
> > + * This function adds an opp definition to the opp table and returns status.
> > + * The opp is made available by default and it can be controlled using
> > + * dev_pm_opp_enable/disable functions.
> > + *
> > + * Return:
> > + * 0         On success OR
> > + *           Duplicate OPPs (both freq and volt are same) and opp->available
> > + * -EEXIST   Freq are same and volt are different OR
> > + *           Duplicate OPPs (both freq and volt are same) and !opp->available
> > + * -ENOMEM   Memory allocation failure
> > + */
> > +int dev_pm_opp_add(struct device *dev, unsigned long freq, unsigned long u_volt)
>
> Maybe move this to include/linux/pm_opp.h and mark it static inline and get rid
> of documentation too.

Good idea!

>
> > +{
> > +     struct dev_pm_opp_data opp;
> > +
> > +     memset(&opp, 0, sizeof(opp));
>
> What about
>         struct dev_pm_opp_data data = {0};
>
> I think it is guaranteed that all the fields will be 0 now, not the padding of
> course, but we don't care about that here.
>
> > +     opp.freq = freq;
> > +     opp.u_volt = u_volt;
>
> Or maybe just
>
>         struct dev_pm_opp_data data = {
>                 .freq = freq,
>                 .u_volt = u_volt,
>         };
>
> Rest must be 0.

Good suggestions both, I will change to whatever is best suitable!

Thanks for reviewing!

Kind regards
Uffe

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2023-06-08  9:00 UTC|newest]

Thread overview: 74+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-06-07 12:46 [PATCH 00/16] arm_scmi/opp/dvfs: Add generic performance scaling support Ulf Hansson
2023-06-07 12:46 ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 01/16] firmware: arm_scmi: Extend perf protocol ops to get number of domains Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 02/16] firmware: arm_scmi: Extend perf protocol ops to get the name of a domain Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 03/16] firmware: arm_scmi: Extend perf protocol ops to inform of set level support Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 04/16] cpufreq: scmi: Prepare to move OF parsing of domain-id to cpufreq Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 05/16] firmware: arm_scmi: Align perf ops to use domain-id as in-parameter Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 06/16] firmware: arm_scmi: Drop redundant ->device_domain_id() from perf ops Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 07/16] cpufreq: scmi: Avoid one OF parsing in scmi_get_sharing_cpus() Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 08/16] PM: domains: Allow genpd providers to manage OPP tables directly by its FW Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 09/16] dt-bindings: firmware: arm,scmi: Extend bindings for protocol@13 Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-14 23:00   ` Rob Herring
2023-06-14 23:00     ` Rob Herring
2023-06-15  9:10     ` Ulf Hansson
2023-06-15  9:10       ` Ulf Hansson
2023-07-14 17:14       ` Rob Herring
2023-07-14 17:14         ` Rob Herring
2023-07-15 12:35         ` Ulf Hansson
2023-07-15 12:35           ` Ulf Hansson
2023-06-15  8:44   ` Sudeep Holla
2023-06-15  8:44     ` Sudeep Holla
2023-06-15  9:39     ` Ulf Hansson
2023-06-15  9:39       ` Ulf Hansson
2023-06-15 13:30       ` Sudeep Holla
2023-06-15 13:30         ` Sudeep Holla
2023-06-16 11:48         ` Ulf Hansson
2023-06-16 11:48           ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 10/16] firmware: arm_scmi: Add the SCMI performance domain Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 11/16] OPP: Add dev_pm_opp_add_dynamic() to allow more flexibility Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-08  5:29   ` Viresh Kumar
2023-06-08  5:29     ` Viresh Kumar
2023-06-08  8:59     ` Ulf Hansson [this message]
2023-06-08  8:59       ` Ulf Hansson
2023-06-08  9:22       ` Viresh Kumar
2023-06-08  9:22         ` Viresh Kumar
2023-06-08  9:40         ` Ulf Hansson
2023-06-08  9:40           ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 12/16] OPP: Extend dev_pm_opp_data with performance level Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 13/16] OPP: Extend dev_pm_opp_data with OPP provider support Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-08  5:34   ` Viresh Kumar
2023-06-08  5:34     ` Viresh Kumar
2023-06-08  9:37     ` Ulf Hansson
2023-06-08  9:37       ` Ulf Hansson
2023-06-08 10:45       ` Viresh Kumar
2023-06-08 10:45         ` Viresh Kumar
2023-06-08 11:45         ` Ulf Hansson
2023-06-08 11:45           ` Ulf Hansson
2023-06-09  5:10           ` Viresh Kumar
2023-06-09  5:10             ` Viresh Kumar
2023-06-09 10:59             ` Ulf Hansson
2023-06-09 10:59               ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 14/16] firmware: arm_scmi: Simplify error path in scmi_dvfs_device_opps_add() Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 15/16] firmware: arm_scmi: Extend perf support with OPP from genpd providers Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 12:46 ` [PATCH 16/16] firmware: arm_scmi: Add generic OPP support to the SCMI performance domain Ulf Hansson
2023-06-07 12:46   ` Ulf Hansson
2023-06-07 14:43 ` [PATCH 00/16] arm_scmi/opp/dvfs: Add generic performance scaling support Cristian Marussi
2023-06-07 14:43   ` Cristian Marussi
2023-06-08  9:53   ` Ulf Hansson
2023-06-08  9:53     ` Ulf Hansson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAPDyKFodvtRE5DHeMSSG5o4iJw07TjFHSeAoTuugH9OAmE8bMQ@mail.gmail.com \
    --to=ulf.hansson@linaro.org \
    --cc=alexandre.torgue@foss.st.com \
    --cc=cristian.marussi@arm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=nkela@quicinc.com \
    --cc=nm@ti.com \
    --cc=psodagud@quicinc.com \
    --cc=sboyd@kernel.org \
    --cc=sudeep.holla@arm.com \
    --cc=viresh.kumar@linaro.org \
    --cc=vireshk@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.