All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 00/11] drm/i915: Separate RC6, RPS, LLC ring Frequency management
@ 2017-10-06 12:13 Sagar Arun Kamble
  2017-10-06 12:13 ` [PATCH v2 01/11] drm/i915: Separate RPS and RC6 handling for gen6+ Sagar Arun Kamble
                   ` (12 more replies)
  0 siblings, 13 replies; 22+ messages in thread
From: Sagar Arun Kamble @ 2017-10-06 12:13 UTC (permalink / raw)
  To: intel-gfx; +Cc: Beuchat, Marc

With GuC based SLPC, frequency control will be moved to GuC and Host will
continue to control RC6 and LLC ring frequency setup. This needs separate
handling of RPS, RC6 and LLC ring frequencies in i915 flows. We still
continue use the *gt_powersave routines with separate status variables
for RPS, RC6, ring frequency as pm.rps.enabled, pm.rc6.enabled and
pm.llc_pstate.configured respectively in dev_priv.
Post this, with SLPC changes integrated we can just skip the Host RPS path
in i915 PM flows.

v2: Added new patch 2. Addressed review comments. Pending review for last
3 patches and patch 2 currently.

Cc: Chris Wilson <chris@chris-wilson.co.uk>
Cc: Imre Deak <imre.deak@intel.com>
Cc: Radoslaw Szwichtenberg <radoslaw.szwichtenberg@intel.com>
Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Cc: Beuchat, Marc <marc.beuchat@intel.com>

Sagar Arun Kamble (11):
  drm/i915: Separate RPS and RC6 handling for gen6+
  drm/i915: Remove superfluous IS_BDW checks and non-BDW changes from
    gen8_enable_rps
  drm/i915: Separate RPS and RC6 handling for BDW
  drm/i915: Separate RPS and RC6 handling for VLV
  drm/i915: Separate RPS and RC6 handling for CHV
  drm/i915: Name i915_runtime_pm structure in dev_priv as "rpm"
  drm/i915: Name structure in dev_priv that contains RPS/RC6 state as
    "pm"
  drm/i915: Rename intel_enable_rc6 to intel_rc6_enabled
  drm/i915: Create generic function to setup LLC ring frequency table
  drm/i915: Create generic functions to control RC6, RPS
  drm/i915: Introduce separate status variable for RC6 and LLC ring
    frequency setup

 drivers/gpu/drm/i915/i915_debugfs.c        | 158 +++----
 drivers/gpu/drm/i915/i915_drv.c            |  10 +-
 drivers/gpu/drm/i915/i915_drv.h            |  24 +-
 drivers/gpu/drm/i915/i915_gem_request.c    |   2 +-
 drivers/gpu/drm/i915/i915_gpu_error.c      |   4 +-
 drivers/gpu/drm/i915/i915_guc_submission.c |   8 +-
 drivers/gpu/drm/i915/i915_irq.c            |  94 +++--
 drivers/gpu/drm/i915/i915_sysfs.c          |  72 ++--
 drivers/gpu/drm/i915/intel_cdclk.c         |  40 +-
 drivers/gpu/drm/i915/intel_display.c       |  12 +-
 drivers/gpu/drm/i915/intel_drv.h           |  14 +-
 drivers/gpu/drm/i915/intel_guc.c           |   3 +-
 drivers/gpu/drm/i915/intel_pm.c            | 637 +++++++++++++++++------------
 drivers/gpu/drm/i915/intel_runtime_pm.c    |  26 +-
 drivers/gpu/drm/i915/intel_sideband.c      |   6 +-
 15 files changed, 626 insertions(+), 484 deletions(-)

-- 
1.9.1

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2017-10-06 18:06 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-10-06 12:13 [PATCH v2 00/11] drm/i915: Separate RC6, RPS, LLC ring Frequency management Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 01/11] drm/i915: Separate RPS and RC6 handling for gen6+ Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 02/11] drm/i915: Remove superfluous IS_BDW checks and non-BDW changes from gen8_enable_rps Sagar Arun Kamble
2017-10-06 12:24   ` Chris Wilson
2017-10-06 12:13 ` [PATCH v2 03/11] drm/i915: Separate RPS and RC6 handling for BDW Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 04/11] drm/i915: Separate RPS and RC6 handling for VLV Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 05/11] drm/i915: Separate RPS and RC6 handling for CHV Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 06/11] drm/i915: Name i915_runtime_pm structure in dev_priv as "rpm" Sagar Arun Kamble
2017-10-06 12:40   ` Chris Wilson
2017-10-06 15:00     ` Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 07/11] drm/i915: Name structure in dev_priv that contains RPS/RC6 state as "pm" Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 08/11] drm/i915: Rename intel_enable_rc6 to intel_rc6_enabled Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 09/11] drm/i915: Create generic function to setup LLC ring frequency table Sagar Arun Kamble
2017-10-06 12:43   ` Chris Wilson
2017-10-06 12:13 ` [PATCH v2 10/11] drm/i915: Create generic functions to control RC6, RPS Sagar Arun Kamble
2017-10-06 12:46   ` Chris Wilson
2017-10-06 15:02     ` Sagar Arun Kamble
2017-10-06 12:13 ` [PATCH v2 11/11] drm/i915: Introduce separate status variable for RC6 and LLC ring frequency setup Sagar Arun Kamble
2017-10-06 12:55   ` Chris Wilson
2017-10-06 15:08     ` Sagar Arun Kamble
2017-10-06 14:10 ` ✓ Fi.CI.BAT: success for drm/i915: Separate RC6, RPS, LLC ring Frequency management Patchwork
2017-10-06 18:06 ` ✓ Fi.CI.IGT: " Patchwork

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.