All of lore.kernel.org
 help / color / mirror / Atom feed
From: Yury Norov <ynorov@caviumnetworks.com>
To: Arnd Bergmann <arnd@arndb.de>
Cc: <linux-arm-kernel@lists.infradead.org>, <pinskia@gmail.com>,
	<Prasun.Kapoor@caviumnetworks.com>, <catalin.marinas@arm.com>,
	<Nathan_Lynch@mentor.com>, <linux-kernel@vger.kernel.org>,
	<agraf@suse.de>, <klimov.linux@gmail.com>, <broonie@kernel.org>,
	<jan.dakinevich@gmail.com>, <joseph@codesourcery.com>,
	<ddaney.cavm@gmail.com>, <schwab@suse.de>,
	<bamvor.zhangjian@huawei.com>,
	<philipp.tomsich@theobroma-systems.com>,
	<andrey.konovalov@linaro.org>,
	<christoph.muellner@theobroma-systems.com>
Subject: Re: [PATCH v6 14/19] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it
Date: Wed, 2 Dec 2015 12:15:03 +0300	[thread overview]
Message-ID: <20151202091503.GA15980@yury-N73SV> (raw)
In-Reply-To: <1712431.VUth4NvudT@wuerfel>

On Wed, Dec 02, 2015 at 09:37:05AM +0100, Arnd Bergmann wrote:
> On Wednesday 02 December 2015 02:35:03 Yury Norov wrote:
> > On Tue, Dec 01, 2015 at 11:39:42PM +0100, Arnd Bergmann wrote:
> > > On Wednesday 02 December 2015 00:29:04 Yury Norov wrote:
> > > I'm not sure I understand this part. What changes specifically do we need?
> > > 
> > 
> > For kernel:
> > 
> >         diff --git a/arch/arm64/include/asm/shmparam.h b/arch/arm64/include/asm/shmparam.h
> >         index 4df608a..e368a55 100644
> >         --- a/arch/arm64/include/asm/shmparam.h
> >         +++ b/arch/arm64/include/asm/shmparam.h
> >         @@ -21,7 +21,7 @@
> >           * alignment value. Since we don't have aliasing D-caches, the rest of
> >           * the time we can safely use PAGE_SIZE.
> >           */
> >         -#define COMPAT_SHMLBA	0x4000
> >         +#define COMPAT_SHMLBA	(4 * PAGE_SIZE)
> >          
> >          #include <asm-generic/shmparam.h>
> >          
> >         diff --git a/arch/arm64/kernel/sys_ilp32.c b/arch/arm64/kernel/sys_ilp32.c
> >         index c5bc712..877bedf 100644
> >         --- a/arch/arm64/kernel/sys_ilp32.c
> >         +++ b/arch/arm64/kernel/sys_ilp32.c
> >         @@ -42,15 +42,12 @@ asmlinkage long sys_rt_sigreturn_wrapper(void);
> >          #define compat_sys_pwrite64            sys_pwrite64
> >          #define compat_sys_readahead           sys_readahead
> >          #define compat_sys_rt_sigaction        sys_rt_sigaction
> >         -#define compat_sys_shmat               sys_shmat
> >          #define compat_sys_sync_file_range     sys_sync_file_range
> >          #define compat_sys_truncate64          sys_truncate
> >          #define compat_sys_sigaltstack         sys_sigaltstack
> >  
> > For library - just create a header in ilp32 directory that defines
> > SHMLBA exactly as arm: __getpagesize () << 2
> 
> I think we both reversed our positions here ;-)
> 
> The 4*PAGE_SIZE on ARM is an architecture specific oddity, I believe
> to work around aliasing caches on ARMv6. As no other architecture does
> this, we're probably better off not duplicating it for aarch64-ilp32
> and just use sys_shmat as your v6 patch does.
> 
> > > It sounds like shmat is one of the cases we an override makes sense
> > > and we should use sys_shmat with PAGE_SIZE for aarch64 ilp32 mode.
> > > 
> > 
> > [...]
> > 
> > > We normally assume that the page size on ARM is fixed to 4K, so
> > > there might be user space that just hardcodes 16K SHMLBA 
> > 
> > It means that we should use compat_sys_shmat because hardcoded
> > userspace may have a chance to work for 4K pages. If we'll use
> > sys_shmat (and so 4K SHMLBA), we'll definitely make hardcoded
> > userspace broken. Non-hardcoded userspace will work anyway.
> > 
> > We can describe in documentation that 4k pages are prefferable.
> 
> The hardcoded user space would only apply to old source code that
> specifically tries to adapt to what ARM does, but gets it wrong,
> If we have source code that is converted from x86 or mips and
> hardcodes anything, it's more likely to be the normal __getpagesize().
> 
> 	Arnd

Hmm... OK. Let's have non-compat shmat here...

WARNING: multiple messages have this Message-ID (diff)
From: ynorov@caviumnetworks.com (Yury Norov)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v6 14/19] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it
Date: Wed, 2 Dec 2015 12:15:03 +0300	[thread overview]
Message-ID: <20151202091503.GA15980@yury-N73SV> (raw)
In-Reply-To: <1712431.VUth4NvudT@wuerfel>

On Wed, Dec 02, 2015 at 09:37:05AM +0100, Arnd Bergmann wrote:
> On Wednesday 02 December 2015 02:35:03 Yury Norov wrote:
> > On Tue, Dec 01, 2015 at 11:39:42PM +0100, Arnd Bergmann wrote:
> > > On Wednesday 02 December 2015 00:29:04 Yury Norov wrote:
> > > I'm not sure I understand this part. What changes specifically do we need?
> > > 
> > 
> > For kernel:
> > 
> >         diff --git a/arch/arm64/include/asm/shmparam.h b/arch/arm64/include/asm/shmparam.h
> >         index 4df608a..e368a55 100644
> >         --- a/arch/arm64/include/asm/shmparam.h
> >         +++ b/arch/arm64/include/asm/shmparam.h
> >         @@ -21,7 +21,7 @@
> >           * alignment value. Since we don't have aliasing D-caches, the rest of
> >           * the time we can safely use PAGE_SIZE.
> >           */
> >         -#define COMPAT_SHMLBA	0x4000
> >         +#define COMPAT_SHMLBA	(4 * PAGE_SIZE)
> >          
> >          #include <asm-generic/shmparam.h>
> >          
> >         diff --git a/arch/arm64/kernel/sys_ilp32.c b/arch/arm64/kernel/sys_ilp32.c
> >         index c5bc712..877bedf 100644
> >         --- a/arch/arm64/kernel/sys_ilp32.c
> >         +++ b/arch/arm64/kernel/sys_ilp32.c
> >         @@ -42,15 +42,12 @@ asmlinkage long sys_rt_sigreturn_wrapper(void);
> >          #define compat_sys_pwrite64            sys_pwrite64
> >          #define compat_sys_readahead           sys_readahead
> >          #define compat_sys_rt_sigaction        sys_rt_sigaction
> >         -#define compat_sys_shmat               sys_shmat
> >          #define compat_sys_sync_file_range     sys_sync_file_range
> >          #define compat_sys_truncate64          sys_truncate
> >          #define compat_sys_sigaltstack         sys_sigaltstack
> >  
> > For library - just create a header in ilp32 directory that defines
> > SHMLBA exactly as arm: __getpagesize () << 2
> 
> I think we both reversed our positions here ;-)
> 
> The 4*PAGE_SIZE on ARM is an architecture specific oddity, I believe
> to work around aliasing caches on ARMv6. As no other architecture does
> this, we're probably better off not duplicating it for aarch64-ilp32
> and just use sys_shmat as your v6 patch does.
> 
> > > It sounds like shmat is one of the cases we an override makes sense
> > > and we should use sys_shmat with PAGE_SIZE for aarch64 ilp32 mode.
> > > 
> > 
> > [...]
> > 
> > > We normally assume that the page size on ARM is fixed to 4K, so
> > > there might be user space that just hardcodes 16K SHMLBA 
> > 
> > It means that we should use compat_sys_shmat because hardcoded
> > userspace may have a chance to work for 4K pages. If we'll use
> > sys_shmat (and so 4K SHMLBA), we'll definitely make hardcoded
> > userspace broken. Non-hardcoded userspace will work anyway.
> > 
> > We can describe in documentation that 4k pages are prefferable.
> 
> The hardcoded user space would only apply to old source code that
> specifically tries to adapt to what ARM does, but gets it wrong,
> If we have source code that is converted from x86 or mips and
> hardcodes anything, it's more likely to be the normal __getpagesize().
> 
> 	Arnd

Hmm... OK. Let's have non-compat shmat here...

  reply	other threads:[~2015-12-02  9:16 UTC|newest]

Thread overview: 158+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-17 21:16 [RFC2 PATCH v6 00/19] ILP32 for ARM64 Yury Norov
2015-11-17 21:16 ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 01/19] arm64:ilp32: add documentation on the ILP32 ABI " Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-18  8:09   ` Zhangjian (Bamvor)
2015-11-18  8:09     ` Zhangjian (Bamvor)
2015-11-17 21:16 ` [PATCH v6 02/19] arm64: ensure the kernel is compiled for LP64 Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 03/19] arm64: rename COMPAT to AARCH32_EL0 in Kconfig Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 04/19] arm64: change some CONFIG_COMPAT over to use CONFIG_AARCH32_EL0 instead Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-12-03 12:02   ` Catalin Marinas
2015-12-03 12:02     ` Catalin Marinas
2015-12-04 21:58     ` Yury Norov
2015-12-04 21:58       ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 05/19] arm64:uapi: set __BITS_PER_LONG correctly for ILP32 and LP64 Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-12-03 11:31   ` Catalin Marinas
2015-12-03 11:31     ` Catalin Marinas
2015-12-03 11:36     ` Dr. Philipp Tomsich
2015-12-03 11:36       ` Dr. Philipp Tomsich
2015-11-17 21:16 ` [PATCH v6 06/19] arm64:ilp32: share signal structures between ILP32 and LP64 ABIs Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 22:14   ` Arnd Bergmann
2015-11-17 22:14     ` Arnd Bergmann
2015-11-17 21:16 ` [PATCH v6 07/19] arm64: introduce is_a32_task and is_a32_thread (for AArch32 compat) Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-12-03 12:13   ` Catalin Marinas
2015-12-03 12:13     ` Catalin Marinas
2015-12-04 17:05     ` Yury Norov
2015-12-04 17:05       ` Yury Norov
2015-12-05 11:00       ` Catalin Marinas
2015-12-05 11:00         ` Catalin Marinas
2015-11-17 21:16 ` [PATCH v6 08/19] arm64:ilp32: add is_ilp32_compat_{task,thread} and TIF_32BIT_AARCH64 Yury Norov
2015-11-17 21:16   ` [PATCH v6 08/19] arm64:ilp32: add is_ilp32_compat_{task, thread} " Yury Norov
2015-11-17 21:16 ` [PATCH v6 09/19] arm64:ilp32: share HWCAP between LP64 and ILP32 Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 10/19] arm64:ilp32 use the native LP64 'start_thread' for ILP32 threads Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-12-03 12:20   ` Catalin Marinas
2015-12-03 12:20     ` Catalin Marinas
2015-11-17 21:16 ` [PATCH v6 11/19] arm64:ilp32: support core dump generation for ILP32 Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-12-03 16:39   ` Catalin Marinas
2015-12-03 16:39     ` Catalin Marinas
2015-11-17 21:16 ` [PATCH v6 12/19] ptrace: Allow compat to use the native siginfo Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 13/19] arm64: ilp32: common 32-bit wrappers Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 14/19] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 21:57   ` Arnd Bergmann
2015-11-17 21:57     ` Arnd Bergmann
2015-11-18  8:14     ` Arnd Bergmann
2015-11-18  8:14       ` Arnd Bergmann
2015-11-19 13:21     ` Andreas Schwab
2015-11-19 13:21       ` Andreas Schwab
2015-11-19 13:32       ` Arnd Bergmann
2015-11-19 13:32         ` Arnd Bergmann
2015-11-30 15:34     ` Arnd Bergmann
2015-11-30 15:34       ` Arnd Bergmann
2015-11-30 20:21       ` Yury Norov
2015-11-30 20:21         ` Yury Norov
2015-11-30 21:49         ` Arnd Bergmann
2015-11-30 21:49           ` Arnd Bergmann
2015-12-01  0:20           ` Andrew Pinski
2015-12-01  0:20             ` Andrew Pinski
2015-12-01  0:40           ` Yury Norov
2015-12-01  0:40             ` Yury Norov
2015-12-01 10:26             ` Arnd Bergmann
2015-12-01 10:26               ` Arnd Bergmann
2015-12-01  9:20         ` Andreas Schwab
2015-12-01  9:20           ` Andreas Schwab
2015-12-01 10:22           ` Arnd Bergmann
2015-12-01 10:22             ` Arnd Bergmann
2015-12-01 11:01             ` Andreas Schwab
2015-12-01 11:01               ` Andreas Schwab
2015-12-01 11:30               ` Arnd Bergmann
2015-12-01 11:30                 ` Arnd Bergmann
2015-12-02  0:24                 ` Yury Norov
2015-12-02  0:24                   ` Yury Norov
2015-12-02 10:03                   ` Arnd Bergmann
2015-12-02 10:03                     ` Arnd Bergmann
2015-12-03 17:17                   ` Catalin Marinas
2015-12-03 17:17                     ` Catalin Marinas
2015-12-01 21:29     ` Yury Norov
2015-12-01 21:29       ` Yury Norov
2015-12-01 22:39       ` Arnd Bergmann
2015-12-01 22:39         ` Arnd Bergmann
2015-12-01 23:35         ` Yury Norov
2015-12-01 23:35           ` Yury Norov
2015-12-02  8:37           ` Arnd Bergmann
2015-12-02  8:37             ` Arnd Bergmann
2015-12-02  9:15             ` Yury Norov [this message]
2015-12-02  9:15               ` Yury Norov
2015-12-02 10:35             ` Yury Norov
2015-12-02 10:35               ` Yury Norov
2015-12-02 13:46               ` Arnd Bergmann
2015-12-02 13:46                 ` Arnd Bergmann
2015-12-02 13:54                 ` Arnd Bergmann
2015-12-02 13:54                   ` Arnd Bergmann
2015-12-02 13:57                   ` Will Deacon
2015-12-02 13:57                     ` Will Deacon
2015-12-03 17:47       ` Catalin Marinas
2015-12-03 17:47         ` Catalin Marinas
2015-12-03 18:14         ` Yury Norov
2015-12-03 18:14           ` Yury Norov
2015-12-03 20:42           ` Arnd Bergmann
2015-12-03 20:42             ` Arnd Bergmann
2015-12-02 10:01     ` Yury Norov
2015-12-02 10:01       ` Yury Norov
2015-12-02 11:03       ` Arnd Bergmann
2015-12-02 11:03         ` Arnd Bergmann
2015-11-17 21:16 ` [PATCH v6 15/19] arm64: ilp32: force IPC_64 in msgctl, shmctl, semctl Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 22:07   ` Arnd Bergmann
2015-11-17 22:07     ` Arnd Bergmann
2015-11-18  8:25     ` Andreas Schwab
2015-11-18  8:25       ` Andreas Schwab
2015-11-18  9:23       ` Arnd Bergmann
2015-11-18  9:23         ` Arnd Bergmann
2015-11-18 10:07         ` Geert Uytterhoeven
2015-11-18 10:07           ` Geert Uytterhoeven
2015-11-18 12:04           ` Arnd Bergmann
2015-11-18 12:04             ` Arnd Bergmann
2015-11-17 21:16 ` [PATCH v6 16/19] aarch64: ilp32: use generic stat64 structure Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 22:09   ` Arnd Bergmann
2015-11-17 22:09     ` Arnd Bergmann
2015-11-18 20:36     ` Yury Norov
2015-11-18 20:36       ` Yury Norov
2015-11-18 20:45       ` Arnd Bergmann
2015-11-18 20:45         ` Arnd Bergmann
2015-11-17 21:16 ` [PATCH v6 17/19] arm64:ilp32: use the native siginfo instead of the compat siginfo Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-17 21:16 ` [PATCH v6 18/19] arm64:ilp32: change COMPAT_ELF_PLATFORM to report a a subplatform for ILP32 Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-18  8:11   ` Zhangjian (Bamvor)
2015-11-18  8:11     ` Zhangjian (Bamvor)
2015-11-18 11:21     ` pinskia
2015-11-18 11:21       ` pinskia at gmail.com
2015-11-18 20:25       ` Yury Norov
2015-11-18 20:25         ` Yury Norov
2015-11-18 21:47         ` Dr. Philipp Tomsich
2015-11-18 21:47           ` Dr. Philipp Tomsich
2015-11-17 21:16 ` [PATCH v6 19/19] arm64:ilp32: add ARM64_ILP32 to Kconfig Yury Norov
2015-11-17 21:16   ` Yury Norov
2015-11-18  8:00 ` [RFC2 PATCH v6 00/19] ILP32 for ARM64 Zhangjian (Bamvor)
2015-11-18  8:00   ` Zhangjian (Bamvor)
2015-11-23 16:49 ` Andreas Schwab
2015-11-23 16:49   ` Andreas Schwab
2015-12-03 17:59 ` Catalin Marinas
2015-12-03 17:59   ` Catalin Marinas
2015-12-04 15:35   ` Yury Norov
2015-12-04 15:35     ` Yury Norov
2015-12-04 17:18     ` Catalin Marinas
2015-12-04 17:18       ` Catalin Marinas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20151202091503.GA15980@yury-N73SV \
    --to=ynorov@caviumnetworks.com \
    --cc=Nathan_Lynch@mentor.com \
    --cc=Prasun.Kapoor@caviumnetworks.com \
    --cc=agraf@suse.de \
    --cc=andrey.konovalov@linaro.org \
    --cc=arnd@arndb.de \
    --cc=bamvor.zhangjian@huawei.com \
    --cc=broonie@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=christoph.muellner@theobroma-systems.com \
    --cc=ddaney.cavm@gmail.com \
    --cc=jan.dakinevich@gmail.com \
    --cc=joseph@codesourcery.com \
    --cc=klimov.linux@gmail.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=philipp.tomsich@theobroma-systems.com \
    --cc=pinskia@gmail.com \
    --cc=schwab@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.