All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: "Andrew F. Davis" <afd@ti.com>
Cc: Jonathan Cameron <jic23@kernel.org>,
	Hartmut Knaack <knaack.h@gmx.de>,
	Lars-Peter Clausen <lars@metafoo.de>,
	Peter Meerwald-Stadler <pmeerw@pmeerw.net>,
	Lee Jones <lee.jones@linaro.org>, Dave Gerlach <d-gerlach@ti.com>,
	linux-iio@vger.kernel.org, linux-input@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator
Date: Wed, 1 Jun 2016 11:35:19 -0700	[thread overview]
Message-ID: <20160601183519.GG4114@dtor-ws> (raw)
In-Reply-To: <20160531170013.2649-9-afd@ti.com>

On Tue, May 31, 2016 at 12:00:13PM -0500, Andrew F. Davis wrote:
> Fix the code formatting to use the kernel preferred style
> of using the actual variables to determize the size using
> the sizeof() operator.
> 
> Signed-off-by: Andrew F. Davis <afd@ti.com>

Applied, thank you.

> ---
>  drivers/input/touchscreen/ti_am335x_tsc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/touchscreen/ti_am335x_tsc.c b/drivers/input/touchscreen/ti_am335x_tsc.c
> index 8b3f15c..7953381 100644
> --- a/drivers/input/touchscreen/ti_am335x_tsc.c
> +++ b/drivers/input/touchscreen/ti_am335x_tsc.c
> @@ -406,7 +406,7 @@ static int titsc_probe(struct platform_device *pdev)
>  	int err;
>  
>  	/* Allocate memory for device */
> -	ts_dev = kzalloc(sizeof(struct titsc), GFP_KERNEL);
> +	ts_dev = kzalloc(sizeof(*ts_dev), GFP_KERNEL);
>  	input_dev = input_allocate_device();
>  	if (!ts_dev || !input_dev) {
>  		dev_err(&pdev->dev, "failed to allocate memory.\n");
> -- 
> 2.8.3
> 

-- 
Dmitry

WARNING: multiple messages have this Message-ID (diff)
From: Dmitry Torokhov <dmitry.torokhov-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
To: "Andrew F. Davis" <afd-l0cyMroinI0@public.gmane.org>
Cc: Jonathan Cameron <jic23-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org>,
	Hartmut Knaack <knaack.h-Mmb7MZpHnFY@public.gmane.org>,
	Lars-Peter Clausen <lars-Qo5EllUWu/uELgA04lAiVw@public.gmane.org>,
	Peter Meerwald-Stadler
	<pmeerw-jW+XmwGofnusTnJN9+BGXg@public.gmane.org>,
	Lee Jones <lee.jones-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>,
	Dave Gerlach <d-gerlach-l0cyMroinI0@public.gmane.org>,
	linux-iio-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-input-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
Subject: Re: [PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator
Date: Wed, 1 Jun 2016 11:35:19 -0700	[thread overview]
Message-ID: <20160601183519.GG4114@dtor-ws> (raw)
In-Reply-To: <20160531170013.2649-9-afd-l0cyMroinI0@public.gmane.org>

On Tue, May 31, 2016 at 12:00:13PM -0500, Andrew F. Davis wrote:
> Fix the code formatting to use the kernel preferred style
> of using the actual variables to determize the size using
> the sizeof() operator.
> 
> Signed-off-by: Andrew F. Davis <afd-l0cyMroinI0@public.gmane.org>

Applied, thank you.

> ---
>  drivers/input/touchscreen/ti_am335x_tsc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/touchscreen/ti_am335x_tsc.c b/drivers/input/touchscreen/ti_am335x_tsc.c
> index 8b3f15c..7953381 100644
> --- a/drivers/input/touchscreen/ti_am335x_tsc.c
> +++ b/drivers/input/touchscreen/ti_am335x_tsc.c
> @@ -406,7 +406,7 @@ static int titsc_probe(struct platform_device *pdev)
>  	int err;
>  
>  	/* Allocate memory for device */
> -	ts_dev = kzalloc(sizeof(struct titsc), GFP_KERNEL);
> +	ts_dev = kzalloc(sizeof(*ts_dev), GFP_KERNEL);
>  	input_dev = input_allocate_device();
>  	if (!ts_dev || !input_dev) {
>  		dev_err(&pdev->dev, "failed to allocate memory.\n");
> -- 
> 2.8.3
> 

-- 
Dmitry

  reply	other threads:[~2016-06-01 18:35 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-05-31 17:00 [PATCH 0/8] TI AM335x TSC/ADC cleanup Andrew F. Davis
2016-05-31 17:00 ` Andrew F. Davis
2016-05-31 17:00 ` [PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-06-08 15:35   ` Lee Jones
2016-06-08 15:35     ` Lee Jones
2016-05-31 17:00 ` [PATCH 2/8] iio: adc: ti_am335x_adc: use " Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-06-03 12:16   ` Jonathan Cameron
2016-06-03 12:16     ` Jonathan Cameron
2016-05-31 17:00 ` [PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-06-08 15:35   ` Lee Jones
2016-06-08 15:35     ` Lee Jones
2016-05-31 17:00 ` [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-05-31 17:53   ` Dave Gerlach
2016-05-31 17:53     ` Dave Gerlach
2016-06-08 15:34   ` Lee Jones
2016-05-31 17:00 ` [PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-06-08 15:33   ` Lee Jones
2016-05-31 17:00 ` [PATCH 6/8] mfd: ti_am335x_tscadc: use variable name for sizeof() operator Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-06-08 15:35   ` Lee Jones
2016-05-31 17:00 ` [PATCH 7/8] iio: adc: ti_am335x_adc: use variable names " Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-06-03 12:15   ` Jonathan Cameron
2016-05-31 17:00 ` [PATCH 8/8] Input: ti_am335x_tsc - use variable name " Andrew F. Davis
2016-05-31 17:00   ` Andrew F. Davis
2016-06-01 18:35   ` Dmitry Torokhov [this message]
2016-06-01 18:35     ` Dmitry Torokhov
2016-06-08 15:36 ` [PATCH 0/8] TI AM335x TSC/ADC cleanup Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160601183519.GG4114@dtor-ws \
    --to=dmitry.torokhov@gmail.com \
    --cc=afd@ti.com \
    --cc=d-gerlach@ti.com \
    --cc=jic23@kernel.org \
    --cc=knaack.h@gmx.de \
    --cc=lars@metafoo.de \
    --cc=lee.jones@linaro.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pmeerw@pmeerw.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.