All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v5 00/10] GuC Scrub vol. 1
@ 2017-02-24 15:39 Arkadiusz Hiler
  2017-02-24 15:39 ` [PATCH 01/10] drm/i915/uc: Rename intel_?uc_{setup, load}() to _init_hw() Arkadiusz Hiler
                   ` (11 more replies)
  0 siblings, 12 replies; 30+ messages in thread
From: Arkadiusz Hiler @ 2017-02-24 15:39 UTC (permalink / raw)
  To: intel-gfx

General GuC/HuC cleanup simplifying logic, and moving chunks around as the area
got pretty rusty.

A lot of logic were extracted from intel_guc_load() to other functions - it did
not only handle the actual loading but had WA implementations and the code
that enabled submission baked into it.

This is the first part of effort to clean it up.

v2: rebase after HuC merge + feedback
v3: even more renaming that aims to make things more semantic
v4: some naming improvements, some bikeshedding
v5: coding style, some cleanup
    module params for huc and guc firmware path,
    separate fw select step from actual prepare

Arkadiusz Hiler (10):
  drm/i915/uc: Rename intel_?uc_{setup,load}() to _init_hw()
  drm/i915/uc: Drop superfluous externs in intel_uc.h
  drm/i915/huc: Add huc_to_i915
  drm/i915/uc: Move intel_uc_fw_fetch() to intel_uc.c
  drm/i915/uc: Introduce intel_uc_init_fw()
  drm/i915/guc: Extract param logic form guc_init_fw()
  drm/i915/guc: Simplify intel_guc_init_hw()
  drm/i915/uc: Simplify firmware path handling
  drm/i915/uc: Separate firmware selection and preparation
  drm/i915/uc: Add params for specifying firmware

 drivers/gpu/drm/i915/i915_drv.c         |   5 +-
 drivers/gpu/drm/i915/i915_drv.h         |   5 +
 drivers/gpu/drm/i915/i915_gem.c         |   2 +-
 drivers/gpu/drm/i915/i915_params.c      |  10 +
 drivers/gpu/drm/i915/i915_params.h      |   2 +
 drivers/gpu/drm/i915/intel_guc_loader.c | 364 ++++----------------------------
 drivers/gpu/drm/i915/intel_huc.c        |  69 +++---
 drivers/gpu/drm/i915/intel_uc.c         | 288 +++++++++++++++++++++++++
 drivers/gpu/drm/i915/intel_uc.h         |  27 ++-
 9 files changed, 394 insertions(+), 378 deletions(-)

-- 
2.9.3

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 30+ messages in thread
* [PATCH v6 00/10] GuC Scrub vol. 1
@ 2017-03-02 16:03 Arkadiusz Hiler
  2017-03-02 16:03 ` [PATCH 03/10] drm/i915/huc: Add huc_to_i915 Arkadiusz Hiler
  0 siblings, 1 reply; 30+ messages in thread
From: Arkadiusz Hiler @ 2017-03-02 16:03 UTC (permalink / raw)
  To: intel-gfx

General GuC/HuC cleanup simplifying logic, and moving chunks around as the area
got pretty rusty.

A lot of logic were extracted from intel_guc_load() to other functions - it did
not only handle the actual loading but had WA implementations and the code
that enabled submission baked into it.

This is the first part of effort to clean it up.

v2: rebase after HuC merge + feedback
v3: even more renaming that aims to make things more semantic
v4: some naming improvements, some bikeshedding
v5: coding style, some cleanup
    module params for huc and guc firmware path,
    separate fw select step from actual prepare
v6: feedback + pushed a couple of patches with r-b down the stack

Arkadiusz Hiler (10):
  drm/i915/uc: Rename intel_?uc_{setup,load}() to _init_hw()
  drm/i915/uc: Drop superfluous externs in intel_uc.h
  drm/i915/huc: Add huc_to_i915
  drm/i915/uc: Move intel_uc_fw_fetch() to intel_uc.c
  drm/i915/uc: Introduce intel_uc_init_fw()
  drm/i915/guc: Extract param logic form guc_init_fw()
  drm/i915/guc: Simplify intel_guc_init_hw()
  drm/i915/uc: Simplify firmware path handling
  drm/i915/uc: Separate firmware selection and preparation
  drm/i915/uc: Add params for specifying firmware

 drivers/gpu/drm/i915/i915_drv.c         |   5 +-
 drivers/gpu/drm/i915/i915_drv.h         |   5 +
 drivers/gpu/drm/i915/i915_gem.c         |   2 +-
 drivers/gpu/drm/i915/i915_params.c      |  10 +
 drivers/gpu/drm/i915/i915_params.h      |   2 +
 drivers/gpu/drm/i915/intel_guc_loader.c | 367 ++++----------------------------
 drivers/gpu/drm/i915/intel_huc.c        |  69 +++---
 drivers/gpu/drm/i915/intel_uc.c         | 291 +++++++++++++++++++++++++
 drivers/gpu/drm/i915/intel_uc.h         |  25 ++-
 9 files changed, 395 insertions(+), 381 deletions(-)

-- 
2.9.3

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 30+ messages in thread

end of thread, other threads:[~2017-03-02 16:04 UTC | newest]

Thread overview: 30+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-02-24 15:39 [PATCH v5 00/10] GuC Scrub vol. 1 Arkadiusz Hiler
2017-02-24 15:39 ` [PATCH 01/10] drm/i915/uc: Rename intel_?uc_{setup, load}() to _init_hw() Arkadiusz Hiler
2017-02-24 15:39 ` [PATCH 02/10] drm/i915/uc: Drop superfluous externs in intel_uc.h Arkadiusz Hiler
2017-02-24 15:39 ` [PATCH 03/10] drm/i915/huc: Add huc_to_i915 Arkadiusz Hiler
2017-02-24 15:39 ` [PATCH 04/10] drm/i915/uc: Move intel_uc_fw_fetch() to intel_uc.c Arkadiusz Hiler
2017-02-24 16:28   ` Michal Wajdeczko
2017-02-27 12:36     ` [PATCH v2] " Arkadiusz Hiler
2017-02-24 15:39 ` [PATCH 05/10] drm/i915/uc: Introduce intel_uc_init_fw() Arkadiusz Hiler
2017-02-24 16:39   ` Michal Wajdeczko
2017-02-27 12:09   ` Joonas Lahtinen
2017-02-24 15:40 ` [PATCH 06/10] drm/i915/guc: Extract param logic form guc_init_fw() Arkadiusz Hiler
2017-02-24 16:55   ` Michal Wajdeczko
2017-02-27 12:50     ` [PATCH v5] " Arkadiusz Hiler
2017-03-01 12:18       ` Joonas Lahtinen
2017-02-24 15:40 ` [PATCH 07/10] drm/i915/guc: Simplify intel_guc_init_hw() Arkadiusz Hiler
2017-02-24 17:26   ` Michal Wajdeczko
2017-02-27 15:48     ` Arkadiusz Hiler
2017-02-24 15:40 ` [PATCH 08/10] drm/i915/uc: Simplify firmware path handling Arkadiusz Hiler
2017-02-24 17:46   ` Michal Wajdeczko
2017-02-24 15:40 ` [PATCH 09/10] drm/i915/uc: Separate firmware selection and preparation Arkadiusz Hiler
2017-02-24 18:29   ` Michal Wajdeczko
2017-03-02 11:53     ` Arkadiusz Hiler
2017-02-27 12:23   ` Joonas Lahtinen
2017-02-24 15:40 ` [PATCH 10/10] drm/i915/uc: Add params for specifying firmware Arkadiusz Hiler
2017-02-24 18:44   ` Michal Wajdeczko
2017-02-27 12:39   ` Joonas Lahtinen
2017-02-27 13:30     ` Jani Nikula
2017-02-24 16:02 ` ✗ Fi.CI.BAT: failure for GuC Scrub vol. 1 (rev5) Patchwork
2017-02-27 14:02 ` ✗ Fi.CI.BAT: failure for GuC Scrub vol. 1 (rev7) Patchwork
2017-03-02 16:03 [PATCH v6 00/10] GuC Scrub vol. 1 Arkadiusz Hiler
2017-03-02 16:03 ` [PATCH 03/10] drm/i915/huc: Add huc_to_i915 Arkadiusz Hiler

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.