All of lore.kernel.org
 help / color / mirror / Atom feed
From: Nicolin Chen <nicolinc@nvidia.com>
To: Dmitry Osipenko <digetx@gmail.com>
Cc: <thierry.reding@gmail.com>, <joro@8bytes.org>, <will@kernel.org>,
	<vdumpa@nvidia.com>, <jonathanh@nvidia.com>,
	<linux-tegra@vger.kernel.org>, <iommu@lists.linux-foundation.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v8 6/6] iommu/tegra-smmu: Add pagetable mappings to debugfs
Date: Thu, 9 Dec 2021 11:54:51 -0800	[thread overview]
Message-ID: <20211209195450.GB35526@Asurada-Nvidia> (raw)
In-Reply-To: <fab11209-a579-bbfb-a701-e613cecabd56@gmail.com>

On Thu, Dec 09, 2021 at 10:44:25PM +0300, Dmitry Osipenko wrote:
> External email: Use caution opening links or attachments
> 
> 
> 09.12.2021 22:24, Nicolin Chen пишет:
> > On Thu, Dec 09, 2021 at 05:49:09PM +0300, Dmitry Osipenko wrote:
> >> External email: Use caution opening links or attachments
> >>
> >>
> >> 09.12.2021 10:38, Nicolin Chen пишет:
> >>> +static unsigned long pd_pt_index_iova(unsigned int pd_index, unsigned int pt_index)
> >>> +{
> >>> +     return (pd_index & (SMMU_NUM_PDE - 1)) << SMMU_PDE_SHIFT |
> >>> +            (pt_index & (SMMU_NUM_PTE - 1)) << SMMU_PTE_SHIFT;
> >>> +}
> >>
> >> I'd change the return type to u32 here, for consistency.
> >
> > The whole file defines iova using "unsigned long", which I see
> > as the consistency... If we change it to u32, it'd be probably
> > necessary to change all iova types to u32 too... So I'd rather
> > keep it "unsigned long" here. If you see a big necessity to do
> > that, an additional patch would be nicer IMHO.
> >
> 
> In general IOVA is "unsigned long", of course. But in case of Tegra
> SMMU, we know that is always u32.
> 
> Alright, I see now that there are other places in the driver code that
> use "unsigned long", so need to change it in this patch.

I think we should do that in a separate patch that changes the iova
type in the entire tegra-smmu file. I can add one in this series, if
this makes you happy...

WARNING: multiple messages have this Message-ID (diff)
From: Nicolin Chen via iommu <iommu@lists.linux-foundation.org>
To: Dmitry Osipenko <digetx@gmail.com>
Cc: linux-kernel@vger.kernel.org, iommu@lists.linux-foundation.org,
	jonathanh@nvidia.com, thierry.reding@gmail.com,
	linux-tegra@vger.kernel.org, will@kernel.org
Subject: Re: [PATCH v8 6/6] iommu/tegra-smmu: Add pagetable mappings to debugfs
Date: Thu, 9 Dec 2021 11:54:51 -0800	[thread overview]
Message-ID: <20211209195450.GB35526@Asurada-Nvidia> (raw)
In-Reply-To: <fab11209-a579-bbfb-a701-e613cecabd56@gmail.com>

On Thu, Dec 09, 2021 at 10:44:25PM +0300, Dmitry Osipenko wrote:
> External email: Use caution opening links or attachments
> 
> 
> 09.12.2021 22:24, Nicolin Chen пишет:
> > On Thu, Dec 09, 2021 at 05:49:09PM +0300, Dmitry Osipenko wrote:
> >> External email: Use caution opening links or attachments
> >>
> >>
> >> 09.12.2021 10:38, Nicolin Chen пишет:
> >>> +static unsigned long pd_pt_index_iova(unsigned int pd_index, unsigned int pt_index)
> >>> +{
> >>> +     return (pd_index & (SMMU_NUM_PDE - 1)) << SMMU_PDE_SHIFT |
> >>> +            (pt_index & (SMMU_NUM_PTE - 1)) << SMMU_PTE_SHIFT;
> >>> +}
> >>
> >> I'd change the return type to u32 here, for consistency.
> >
> > The whole file defines iova using "unsigned long", which I see
> > as the consistency... If we change it to u32, it'd be probably
> > necessary to change all iova types to u32 too... So I'd rather
> > keep it "unsigned long" here. If you see a big necessity to do
> > that, an additional patch would be nicer IMHO.
> >
> 
> In general IOVA is "unsigned long", of course. But in case of Tegra
> SMMU, we know that is always u32.
> 
> Alright, I see now that there are other places in the driver code that
> use "unsigned long", so need to change it in this patch.

I think we should do that in a separate patch that changes the iova
type in the entire tegra-smmu file. I can add one in this series, if
this makes you happy...
_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

  reply	other threads:[~2021-12-09 19:54 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-09  7:38 [PATCH v8 0/6] iommu/tegra-smmu: Add pagetable mappings to debugfs Nicolin Chen
2021-12-09  7:38 ` Nicolin Chen via iommu
2021-12-09  7:38 ` [PATCH v8 1/6] iommu/tegra-smmu: Rename struct iommu_group *group to *grp Nicolin Chen
2021-12-09  7:38   ` Nicolin Chen via iommu
2021-12-09  7:38 ` [PATCH v8 2/6] iommu/tegra-smmu: Rename tegra_smmu_find_group to tegra_smmu_find_group_soc Nicolin Chen
2021-12-09  7:38   ` Nicolin Chen via iommu
2021-12-09  7:38 ` [PATCH v8 3/6] iommu/tegra-smmu: Rename struct tegra_smmu_swgroup *group to *swgrp Nicolin Chen
2021-12-09  7:38   ` Nicolin Chen via iommu
2021-12-09  7:38 ` [PATCH v8 4/6] iommu/tegra-smmu: Use swgrp pointer instead of swgroup id Nicolin Chen
2021-12-09  7:38   ` Nicolin Chen via iommu
2021-12-09  7:38 ` [PATCH v8 5/6] iommu/tegra-smmu: Attach as pointer to tegra_smmu_group Nicolin Chen
2021-12-09  7:38   ` Nicolin Chen via iommu
2021-12-09  7:38 ` [PATCH v8 6/6] iommu/tegra-smmu: Add pagetable mappings to debugfs Nicolin Chen
2021-12-09  7:38   ` Nicolin Chen via iommu
2021-12-09 14:47   ` Dmitry Osipenko
2021-12-09 14:47     ` Dmitry Osipenko
2021-12-09 19:32     ` Nicolin Chen
2021-12-09 19:32       ` Nicolin Chen via iommu
2021-12-09 19:40       ` Dmitry Osipenko
2021-12-09 19:40         ` Dmitry Osipenko
2021-12-09 19:51         ` Nicolin Chen
2021-12-09 19:51           ` Nicolin Chen via iommu
2021-12-09 19:58           ` Dmitry Osipenko
2021-12-09 19:58             ` Dmitry Osipenko
2021-12-09 20:06             ` Nicolin Chen
2021-12-09 20:06               ` Nicolin Chen via iommu
2021-12-09 14:49   ` Dmitry Osipenko
2021-12-09 14:49     ` Dmitry Osipenko
2021-12-09 19:24     ` Nicolin Chen
2021-12-09 19:24       ` Nicolin Chen via iommu
2021-12-09 19:44       ` Dmitry Osipenko
2021-12-09 19:44         ` Dmitry Osipenko
2021-12-09 19:54         ` Nicolin Chen [this message]
2021-12-09 19:54           ` Nicolin Chen via iommu
2021-12-09 19:58           ` Dmitry Osipenko
2021-12-09 19:58             ` Dmitry Osipenko
2021-12-09 20:01             ` Nicolin Chen
2021-12-09 20:01               ` Nicolin Chen via iommu
2021-12-09 20:03               ` Dmitry Osipenko
2021-12-09 20:03                 ` Dmitry Osipenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20211209195450.GB35526@Asurada-Nvidia \
    --to=nicolinc@nvidia.com \
    --cc=digetx@gmail.com \
    --cc=iommu@lists.linux-foundation.org \
    --cc=jonathanh@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-tegra@vger.kernel.org \
    --cc=thierry.reding@gmail.com \
    --cc=vdumpa@nvidia.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.