All of lore.kernel.org
 help / color / mirror / Atom feed
From: Saravana Kannan <skannan@codeaurora.org>
To: Mike Turquette <mturquette@linaro.org>,
	Arnd Bergman <arnd.bergmann@linaro.org>,
	linux-arm-kernel@lists.infradead.org,
	Andrew Lunn <andrew@lunn.ch>, Paul Walmsley <paul@pwsan.com>,
	Russell King <linux@arm.linux.org.uk>,
	Linus Walleij <linus.walleij@stericsson.com>,
	Stephen Boyd <sboyd@codeaurora.org>,
	linux-arm-msm@vger.kernel.org,
	Sascha Hauer <s.hauer@pengutronix.de>,
	Mark Brown <broonie@opensource.wolfsonmicro.com>,
	Magnus Damm <magnus.damm@gmail.com>,
	linux-kernel@vger.kernel.org,
	Rob Herring <rob.herring@calxeda.com>,
	Richard Zhao <richard.zhao@linaro.org>,
	Grant Likely <grant.likely@secretlab.ca>,
	Deepak Saxena <dsaxena@linaro.org>,
	Amit Kucheria <amit.kucheria@linaro.org>,
	Jamie Iles <jamie@jamieiles.com>,
	Jeremy Kerr <jeremy.kerr@canonical.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Shawn Guo <shawn.guo@freescale.com>
Subject: Re: [PATCH] clk: Use a separate struct for holding init data.
Date: Thu, 03 May 2012 18:11:56 -0700	[thread overview]
Message-ID: <4FA32CDC.3070005@codeaurora.org> (raw)
In-Reply-To: <20120503230308.GA13016@glitch>

On 05/03/2012 04:03 PM, Domenico Andreoli wrote:
> On Wed, Apr 25, 2012 at 10:58:56PM -0700, Saravana Kannan wrote:
>>
>> diff --git a/drivers/clk/clk-divider.c b/drivers/clk/clk-divider.c
>> index 90627e4..8ea11b4 100644
>> --- a/drivers/clk/clk-divider.c
>> +++ b/drivers/clk/clk-divider.c
>> @@ -167,6 +167,7 @@ struct clk *clk_register_divider(struct device *dev, const char *name,
>>   {
>>   	struct clk_divider *div;
>>   	struct clk *clk;
>> +	struct clk_init_data init;
>>
>>   	/* allocate the divider */
>>   	div = kzalloc(sizeof(struct clk_divider), GFP_KERNEL);
>> @@ -175,19 +176,22 @@ struct clk *clk_register_divider(struct device *dev, const char *name,
>>   		return ERR_PTR(-ENOMEM);
>>   	}
>>
>> +	init.name = name;
>> +	init.ops =&clk_divider_ops;
>> +	init.flags = flags;
>> +	init.parent_names = (parent_name ?&parent_name: NULL);
>> +	init.num_parents = (parent_name ? 1 : 0);
>> +
>>   	/* struct clk_divider assignments */
>>   	div->reg = reg;
>>   	div->shift = shift;
>>   	div->width = width;
>>   	div->flags = clk_divider_flags;
>>   	div->lock = lock;
>> +	div->hw.init =&init;
>>
>>   	/* register the clock */
>> -	clk = clk_register(dev, name,
>> -			&clk_divider_ops,&div->hw,
>> -			(parent_name ?&parent_name: NULL),
>> -			(parent_name ? 1 : 0),
>> -			flags);
>> +	clk = clk_register(dev,&div->hw);
>>
>>   	if (IS_ERR(clk))
>>   		kfree(div);
>
> I would prefer to rip the parent _settings_ configuration out of
> clk_register(). It's optional right? And passing a single parent is a
> common case.
>
> Three cases:
>
>    1) one parent:
>       __clk_register_parent(clk, parent_name);
>       clk_register(dev, name,&ops, flags);
>
>    2) many parents:
>       __clk_register_parents(clk, parent_names, num_parents);
>       clk_register(dev, name,&ops, flags);
>
>    3) no parents:
>       clk_register(dev, name,&ops, flags);
>
> You may also want to move the whole parent initialization into
> __clk_register_parents() and call it after clk_register(), it would
> simplify some error paths.
>
> This pattern could be used also with other common clocks registration
> functions (fixed rate, divider, mux, etc) that may have complex
> initializations and/or optional parameters that cannot go all on the
> same function call.

Please no. If anything, make those other register functions go in the 
direction of clk_register(). Have a long list of params to a function 
and then having it fill up a structure just makes the code less 
readable. Why would that be any better than having the whole structure 
statically declared or the whole structure dynamically populated (by 
device tree) and then calling clk_register()?

Take about 50 clocks with 3 parents each and try to register them in the 
way you suggested and in a way how clk_register() in this patch will 
need you to declare them statically. Compare the two and see which would 
be more readable.

-Saravana

-- 
Sent by an employee of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.

WARNING: multiple messages have this Message-ID (diff)
From: skannan@codeaurora.org (Saravana Kannan)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH] clk: Use a separate struct for holding init data.
Date: Thu, 03 May 2012 18:11:56 -0700	[thread overview]
Message-ID: <4FA32CDC.3070005@codeaurora.org> (raw)
In-Reply-To: <20120503230308.GA13016@glitch>

On 05/03/2012 04:03 PM, Domenico Andreoli wrote:
> On Wed, Apr 25, 2012 at 10:58:56PM -0700, Saravana Kannan wrote:
>>
>> diff --git a/drivers/clk/clk-divider.c b/drivers/clk/clk-divider.c
>> index 90627e4..8ea11b4 100644
>> --- a/drivers/clk/clk-divider.c
>> +++ b/drivers/clk/clk-divider.c
>> @@ -167,6 +167,7 @@ struct clk *clk_register_divider(struct device *dev, const char *name,
>>   {
>>   	struct clk_divider *div;
>>   	struct clk *clk;
>> +	struct clk_init_data init;
>>
>>   	/* allocate the divider */
>>   	div = kzalloc(sizeof(struct clk_divider), GFP_KERNEL);
>> @@ -175,19 +176,22 @@ struct clk *clk_register_divider(struct device *dev, const char *name,
>>   		return ERR_PTR(-ENOMEM);
>>   	}
>>
>> +	init.name = name;
>> +	init.ops =&clk_divider_ops;
>> +	init.flags = flags;
>> +	init.parent_names = (parent_name ?&parent_name: NULL);
>> +	init.num_parents = (parent_name ? 1 : 0);
>> +
>>   	/* struct clk_divider assignments */
>>   	div->reg = reg;
>>   	div->shift = shift;
>>   	div->width = width;
>>   	div->flags = clk_divider_flags;
>>   	div->lock = lock;
>> +	div->hw.init =&init;
>>
>>   	/* register the clock */
>> -	clk = clk_register(dev, name,
>> -			&clk_divider_ops,&div->hw,
>> -			(parent_name ?&parent_name: NULL),
>> -			(parent_name ? 1 : 0),
>> -			flags);
>> +	clk = clk_register(dev,&div->hw);
>>
>>   	if (IS_ERR(clk))
>>   		kfree(div);
>
> I would prefer to rip the parent _settings_ configuration out of
> clk_register(). It's optional right? And passing a single parent is a
> common case.
>
> Three cases:
>
>    1) one parent:
>       __clk_register_parent(clk, parent_name);
>       clk_register(dev, name,&ops, flags);
>
>    2) many parents:
>       __clk_register_parents(clk, parent_names, num_parents);
>       clk_register(dev, name,&ops, flags);
>
>    3) no parents:
>       clk_register(dev, name,&ops, flags);
>
> You may also want to move the whole parent initialization into
> __clk_register_parents() and call it after clk_register(), it would
> simplify some error paths.
>
> This pattern could be used also with other common clocks registration
> functions (fixed rate, divider, mux, etc) that may have complex
> initializations and/or optional parameters that cannot go all on the
> same function call.

Please no. If anything, make those other register functions go in the 
direction of clk_register(). Have a long list of params to a function 
and then having it fill up a structure just makes the code less 
readable. Why would that be any better than having the whole structure 
statically declared or the whole structure dynamically populated (by 
device tree) and then calling clk_register()?

Take about 50 clocks with 3 parents each and try to register them in the 
way you suggested and in a way how clk_register() in this patch will 
need you to declare them statically. Compare the two and see which would 
be more readable.

-Saravana

-- 
Sent by an employee of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.

  reply	other threads:[~2012-05-04  1:12 UTC|newest]

Thread overview: 71+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-04-26  5:58 [PATCH] clk: Use a separate struct for holding init data Saravana Kannan
2012-04-26  5:58 ` Saravana Kannan
2012-04-26  6:28 ` Saravana Kannan
2012-04-26  6:28   ` Saravana Kannan
2012-04-26  8:42   ` Sascha Hauer
2012-04-26  8:42     ` Sascha Hauer
2012-04-26  9:36     ` Saravana Kannan
2012-04-26  9:36       ` Saravana Kannan
2012-04-26  9:36       ` Saravana Kannan
2012-04-26  9:51       ` Sascha Hauer
2012-04-26  9:51         ` Sascha Hauer
2012-04-30 19:30         ` Saravana Kannan
2012-04-30 19:30           ` Saravana Kannan
2012-04-30 22:19           ` Turquette, Mike
2012-04-30 22:19             ` Turquette, Mike
2012-04-30 22:46             ` Saravana Kannan
2012-04-30 22:46               ` Saravana Kannan
2012-05-01  8:11               ` Shawn Guo
2012-05-01  8:11                 ` Shawn Guo
2012-05-01  9:13                 ` Andrew Lunn
2012-05-01  9:13                   ` Andrew Lunn
2012-05-01  9:13                   ` Andrew Lunn
2012-05-01 17:00                   ` Mark Brown
2012-05-01 17:00                     ` Mark Brown
2012-05-01 17:00                     ` Mark Brown
2012-05-01 18:03                     ` Saravana Kannan
2012-05-01 18:03                       ` Saravana Kannan
2012-05-01 18:19                       ` Mark Brown
2012-05-01 18:19                         ` Mark Brown
2012-05-02  1:56                         ` Mike Turquette
2012-05-02  1:56                           ` Mike Turquette
2012-05-02  2:14                           ` Shawn Guo
2012-05-02  2:14                             ` Shawn Guo
2012-05-02  5:16                           ` Andrew Lunn
2012-05-02  5:16                             ` Andrew Lunn
2012-05-02  5:16                             ` Andrew Lunn
2012-05-02 19:19                             ` Mike Turquette
2012-05-02 19:19                               ` Mike Turquette
2012-05-02 19:19                               ` Mike Turquette
2012-05-02 13:32                           ` Arnd Bergmann
2012-05-02 13:32                             ` Arnd Bergmann
2012-05-02 15:28                           ` Mark Brown
2012-05-02 15:28                             ` Mark Brown
2012-05-01 18:04                     ` Andrew Lunn
2012-05-01 18:04                       ` Andrew Lunn
2012-05-01 18:04                       ` Andrew Lunn
2012-04-26  8:39 ` Sascha Hauer
2012-04-26  8:39   ` Sascha Hauer
2012-04-26  9:15   ` Saravana Kannan
2012-04-26  9:15     ` Saravana Kannan
2012-04-26  9:15     ` Saravana Kannan
2012-04-26  9:49   ` Mark Brown
2012-04-26  9:49     ` Mark Brown
2012-05-02  2:04 ` Mike Turquette
2012-05-02  2:04   ` Mike Turquette
2012-05-02  4:42   ` Saravana Kannan
2012-05-02  4:42     ` Saravana Kannan
2012-05-02 19:07     ` Mike Turquette
2012-05-02 19:07       ` Mike Turquette
2012-05-02  9:58 ` Sascha Hauer
2012-05-02  9:58   ` Sascha Hauer
2012-05-02 10:02   ` Russell King - ARM Linux
2012-05-02 10:02     ` Russell King - ARM Linux
2012-05-02 10:11     ` Sascha Hauer
2012-05-02 10:11       ` Sascha Hauer
2012-05-03 23:03 ` Domenico Andreoli
2012-05-03 23:03   ` Domenico Andreoli
2012-05-04  1:11   ` Saravana Kannan [this message]
2012-05-04  1:11     ` Saravana Kannan
2012-05-04  6:50     ` Domenico Andreoli
2012-05-04  6:50       ` Domenico Andreoli

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4FA32CDC.3070005@codeaurora.org \
    --to=skannan@codeaurora.org \
    --cc=amit.kucheria@linaro.org \
    --cc=andrew@lunn.ch \
    --cc=arnd.bergmann@linaro.org \
    --cc=broonie@opensource.wolfsonmicro.com \
    --cc=dsaxena@linaro.org \
    --cc=grant.likely@secretlab.ca \
    --cc=jamie@jamieiles.com \
    --cc=jeremy.kerr@canonical.com \
    --cc=linus.walleij@stericsson.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=magnus.damm@gmail.com \
    --cc=mturquette@linaro.org \
    --cc=paul@pwsan.com \
    --cc=richard.zhao@linaro.org \
    --cc=rob.herring@calxeda.com \
    --cc=s.hauer@pengutronix.de \
    --cc=sboyd@codeaurora.org \
    --cc=shawn.guo@freescale.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.