All of lore.kernel.org
 help / color / mirror / Atom feed
* [GIT PULL] x86/mce fix (ready for 3.6 merge window)
@ 2012-07-10 17:50 Luck, Tony
  2012-07-11  8:04 ` Ingo Molnar
  0 siblings, 1 reply; 6+ messages in thread
From: Luck, Tony @ 2012-07-10 17:50 UTC (permalink / raw)
  To: Ingo Molnar; +Cc: linux-kernel

The following changes since commit 6887a4131da3adaab011613776d865f4bcfb5678:

  Linux 3.5-rc5 (2012-06-30 16:08:57 -0700)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/ras/ras.git tags/please-pull-mce-ripvfix

for you to fetch changes up to b99c2fc9366d4e32b8d087cd28f6dbf5f7932dae:

  x86/mce: Need to let kill_proc() send signal to doomed process (2012-07-10 10:18:29 -0700)

----------------------------------------------------------------
Fix application level machine check recovery

----------------------------------------------------------------
Tony Luck (1):
      x86/mce: Need to let kill_proc() send signal to doomed process

 arch/x86/kernel/cpu/mcheck/mce.c |  6 ++++--
 include/linux/mm.h               |  1 +
 mm/memory-failure.c              | 10 ++++++----
 3 files changed, 11 insertions(+), 6 deletions(-)

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [GIT PULL] x86/mce fix (ready for 3.6 merge window)
  2012-07-10 17:50 [GIT PULL] x86/mce fix (ready for 3.6 merge window) Luck, Tony
@ 2012-07-11  8:04 ` Ingo Molnar
  2012-07-11  8:31   ` Borislav Petkov
  2012-07-11 16:26   ` Tony Luck
  0 siblings, 2 replies; 6+ messages in thread
From: Ingo Molnar @ 2012-07-11  8:04 UTC (permalink / raw)
  To: Luck, Tony; +Cc: linux-kernel, Borislav Petkov, the arch/x86 maintainers


* Luck, Tony <tony.luck@intel.com> wrote:

> The following changes since commit 6887a4131da3adaab011613776d865f4bcfb5678:
> 
>   Linux 3.5-rc5 (2012-06-30 16:08:57 -0700)
> 
> are available in the git repository at:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/ras/ras.git tags/please-pull-mce-ripvfix
> 
> for you to fetch changes up to b99c2fc9366d4e32b8d087cd28f6dbf5f7932dae:
> 
>   x86/mce: Need to let kill_proc() send signal to doomed process (2012-07-10 10:18:29 -0700)
> 
> ----------------------------------------------------------------
> Fix application level machine check recovery
> 
> ----------------------------------------------------------------
> Tony Luck (1):
>       x86/mce: Need to let kill_proc() send signal to doomed process
> 
>  arch/x86/kernel/cpu/mcheck/mce.c |  6 ++++--
>  include/linux/mm.h               |  1 +
>  mm/memory-failure.c              | 10 ++++++----
>  3 files changed, 11 insertions(+), 6 deletions(-)

A couple of commit log details:

 - If it's for v3.6 then the Cc: stable backport is not 
   justified. Either it's for tip:x86/urgent and then we'll 
   merge it straight away, or for tip:x86/mce for v3.6 and then 
   there's no Cc: stable tag.

 - This reference to a commit is a bit unusual:

In commit dad1743e5993f19b3d7e7bd0fb35dc45b5326626
x86/mce: Only restart instruction after machine check recovery if it is safe

   the canonical format is something like:

  In commit dad1743e5993f1 ("x86/mce: Only restart instruction 
  after machine check recovery if it is safe") ...

 - We tend to use such an ordering of tags:

  Signed-off-by: Tony Luck <tony.luck@intel.com>
  Acked-by: Borislav Petkov <borislav.petkov@amd.com>
  Cc: stable@kernel.org    # 3.4+

  I.e. Tested-by and Reported-by tags first (if any), then 
  author SOB, then SOB chain (if any), then Reviewed-by
  and Acked-by, then stable tags, then Cc:s.

  (I fix this up silently for email space patches, for Git pulls
   I cannot do that.)

 - The title is suboptimal:

  x86/mce: Need to let kill_proc() send signal to doomed process

   In titles we prefer proper sentences, starting with a verb, 
   so something like this would do:

  x86/mce: Allow kill_proc() to send signals to doomed process

   Or rather, use a good title that talks about what the change 
   is really about:

  x86/mce: Fix siginfo_t->si_addr value for non-recoverable memory faults

 - (Spelling nitpick: it's not "et. al." but "et al.".)

 - Style nit, this:

       if (mi->restartable == 0)

   is better written as:

       if (!mi->restartable)

   because mi->restartable's role here is not really an integer 
   value, but a boolean in essence.

 - The 'doit' flag was significantly misnamed when kill_procs() 
   was written and now it spreads further, it's a totally opaque 
   name that tells nothing about the role of the flag.

   How about 'force'?

Thanks,

	Ingo

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [GIT PULL] x86/mce fix (ready for 3.6 merge window)
  2012-07-11  8:04 ` Ingo Molnar
@ 2012-07-11  8:31   ` Borislav Petkov
  2012-07-11 16:26   ` Tony Luck
  1 sibling, 0 replies; 6+ messages in thread
From: Borislav Petkov @ 2012-07-11  8:31 UTC (permalink / raw)
  To: Ingo Molnar; +Cc: Luck, Tony, linux-kernel, the arch/x86 maintainers

On Wed, Jul 11, 2012 at 10:04:46AM +0200, Ingo Molnar wrote:
> A couple of commit log details:
> 
>  - If it's for v3.6 then the Cc: stable backport is not 
>    justified. Either it's for tip:x86/urgent and then we'll 
>    merge it straight away, or for tip:x86/mce for v3.6 and then 
>    there's no Cc: stable tag.

This could be part of checkpatch - whenever a stable tag is added to a
patch commit msg, it should at least warn the patch author to check with
<Documentation/stable_kernel_rules.txt> first.

>  - This reference to a commit is a bit unusual:
> 
> In commit dad1743e5993f19b3d7e7bd0fb35dc45b5326626
> x86/mce: Only restart instruction after machine check recovery if it is safe
> 
>    the canonical format is something like:
> 
>   In commit dad1743e5993f1 ("x86/mce: Only restart instruction 
>   after machine check recovery if it is safe") ...

Commit referencing in commit messages doesn't come up for the first time
so can we get this as a rule into checkpatch so that we can have unified
commit reference format?

The regex would be probably hairy and generate a couple of false
positives but sure it will help in a lot of other situations.

Also, how many chars of the commit id we keep? The first 12, 14, 15? I'm
thinking of commit id uniqueness sometime far in the future.

>  - We tend to use such an ordering of tags:
> 
>   Signed-off-by: Tony Luck <tony.luck@intel.com>
>   Acked-by: Borislav Petkov <borislav.petkov@amd.com>
>   Cc: stable@kernel.org    # 3.4+
> 
>   I.e. Tested-by and Reported-by tags first (if any), then 
>   author SOB, then SOB chain (if any), then Reviewed-by
>   and Acked-by, then stable tags, then Cc:s.

patch tags order could be checked for in checkpatch too?

[ … ]

>  - Style nit, this:
> 
>        if (mi->restartable == 0)
> 
>    is better written as:
> 
>        if (!mi->restartable)
> 
>    because mi->restartable's role here is not really an integer 
>    value, but a boolean in essence.

Yes, we talked about this but having a bool as a u8 there would add
padding to the struct so it's the same thing, space-wise. It could be
converted to a bitfield if more flags are added/needed.

>  - The 'doit' flag was significantly misnamed when kill_procs() 
>    was written and now it spreads further, it's a totally opaque 
>    name that tells nothing about the role of the flag.
> 
>    How about 'force'?

Even better, make it even more descriptive: 'force_kill' or 'do_kill' or
'really_kill' - this way one knows exactly what one is looking at.

Thanks.

-- 
Regards/Gruss,
    Boris.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [GIT PULL] x86/mce fix (ready for 3.6 merge window)
  2012-07-11  8:04 ` Ingo Molnar
  2012-07-11  8:31   ` Borislav Petkov
@ 2012-07-11 16:26   ` Tony Luck
  2012-07-11 17:45     ` [GIT PULL v2] " Luck, Tony
  1 sibling, 1 reply; 6+ messages in thread
From: Tony Luck @ 2012-07-11 16:26 UTC (permalink / raw)
  To: Ingo Molnar; +Cc: linux-kernel, Borislav Petkov, the arch/x86 maintainers

On Wed, Jul 11, 2012 at 1:04 AM, Ingo Molnar <mingo@kernel.org> wrote:
>  - If it's for v3.6 then the Cc: stable backport is not
>    justified. Either it's for tip:x86/urgent and then we'll
>    merge it straight away, or for tip:x86/mce for v3.6 and then
>    there's no Cc: stable tag.

The commit that this fixes was included in 3.4 - so I was thinking that this
should be backported to stable 3.4 ... but 3.4 isn't a long term release, so
it will be abandoned when 3.5 is released.

Since we are at -rc6 and this isn't a regression from the current merge,
I figured that it wasn't a candidate for immediate merge ... hence the
3.6 request. So it would appear that there isn't a way that this can make
it back to 3.4-stable.

I'll fix up all the other stuff and send a new pull (still for 3.6,
and still with
a Cc: stable for backport to 3.5)

-Tony

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [GIT PULL v2] x86/mce fix (ready for 3.6 merge window)
  2012-07-11 16:26   ` Tony Luck
@ 2012-07-11 17:45     ` Luck, Tony
  2012-07-11 20:53       ` Ingo Molnar
  0 siblings, 1 reply; 6+ messages in thread
From: Luck, Tony @ 2012-07-11 17:45 UTC (permalink / raw)
  To: Ingo Molnar; +Cc: linux-kernel, Borislav Petkov, the arch/x86 maintainers

The following changes since commit 6887a4131da3adaab011613776d865f4bcfb5678:

  Linux 3.5-rc5 (2012-06-30 16:08:57 -0700)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/ras/ras.git mce-ripvfix

for you to fetch changes up to 6751ed65dc6642af64f7b8a440a75563c8aab7ae:

  x86/mce: Fix siginfo_t->si_addr value for non-recoverable memory faults (2012-07-11 10:20:47 -0700)

----------------------------------------------------------------
Fix application level machine check recovery

----------------------------------------------------------------
Tony Luck (1):
      x86/mce: Fix siginfo_t->si_addr value for non-recoverable memory faults

 arch/x86/kernel/cpu/mcheck/mce.c |  6 ++++--
 include/linux/mm.h               |  1 +
 mm/memory-failure.c              | 14 ++++++++------
 3 files changed, 13 insertions(+), 8 deletions(-)

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [GIT PULL v2] x86/mce fix (ready for 3.6 merge window)
  2012-07-11 17:45     ` [GIT PULL v2] " Luck, Tony
@ 2012-07-11 20:53       ` Ingo Molnar
  0 siblings, 0 replies; 6+ messages in thread
From: Ingo Molnar @ 2012-07-11 20:53 UTC (permalink / raw)
  To: Luck, Tony; +Cc: linux-kernel, Borislav Petkov, the arch/x86 maintainers


* Luck, Tony <tony.luck@intel.com> wrote:

> The following changes since commit 6887a4131da3adaab011613776d865f4bcfb5678:
> 
>   Linux 3.5-rc5 (2012-06-30 16:08:57 -0700)
> 
> are available in the git repository at:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/ras/ras.git mce-ripvfix
> 
> for you to fetch changes up to 6751ed65dc6642af64f7b8a440a75563c8aab7ae:
> 
>   x86/mce: Fix siginfo_t->si_addr value for non-recoverable memory faults (2012-07-11 10:20:47 -0700)
> 
> ----------------------------------------------------------------
> Fix application level machine check recovery
> 
> ----------------------------------------------------------------
> Tony Luck (1):
>       x86/mce: Fix siginfo_t->si_addr value for non-recoverable memory faults
> 
>  arch/x86/kernel/cpu/mcheck/mce.c |  6 ++++--
>  include/linux/mm.h               |  1 +
>  mm/memory-failure.c              | 14 ++++++++------
>  3 files changed, 13 insertions(+), 8 deletions(-)

Pulled, thanks Tony!

	Ingo

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2012-07-11 20:53 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-07-10 17:50 [GIT PULL] x86/mce fix (ready for 3.6 merge window) Luck, Tony
2012-07-11  8:04 ` Ingo Molnar
2012-07-11  8:31   ` Borislav Petkov
2012-07-11 16:26   ` Tony Luck
2012-07-11 17:45     ` [GIT PULL v2] " Luck, Tony
2012-07-11 20:53       ` Ingo Molnar

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.